View Issue Details

IDProjectCategoryView StatusLast Update
0015649LazarusIDEpublic2015-03-04 02:46
ReporterWimpie NortjeAssigned ToMartin Friebe 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSWindowsOS VersionXP
Product Version0.9.28.3 (SVN)Product Build23609 
Target Version1.6Fixed in Version1.5 (SVN) 
Summary0015649: For Block selected text, TAB should indent only the selection not whole line
DescriptionIf text is selected in a block (alt-mouse) and TAB is pressed, only the selection must be indented. Currently the whole line is indented.

The goal is to indent '2;' and '3;' beneath '1;' by block selecting them and pressing TAB
Val1 = 1;
Val2 = 2;
Val3 = 3;
TagsNo tags attached.
Fixed in Revision48123
LazTarget1.6
Widgetset
Attached Files

Activities

Martin Friebe

2010-02-02 13:01

manager   ~0034158

It's an idea, yes it could be done this way.

IMHO aligning text (columns) should be done smarter, since block indent will only work if they are partly aligned already. If each line is at a diff position, block-indent wouldn't help:
abc := 1;
e := 2;
foobar := 3;

It needs a dedicated command to align at either the ":=" or at the token behind the ":=" (that is at the number).

One way or another, it's a valid feature request, and a good idea. Thanks

Martin Friebe

2015-03-04 01:03

manager   ~0081619

The editor (Lazarus 1.5)) now has a multi-caret mode (optional enabled together with column mode selection).

If you press shift-alt-down several times (without any left/right movement), then you get a caret at the same x pos on each line. This allows you to insert spaces or tabs (effectively indent).

This should do exactly what indent at column would have done.


If you need to align tokens that each need a different amount of spaces/tabs, then have a look at:
http://wiki.lazarus.freepascal.org/Editor_Macros_PascalScript#Example


If you believe the issue is not solved please provide additional details.

Issue History

Date Modified Username Field Change
2010-02-02 08:41 Wimpie Nortje New Issue
2010-02-02 13:01 Martin Friebe LazTarget => 1.2
2010-02-02 13:01 Martin Friebe Note Added: 0034158
2010-02-02 13:01 Martin Friebe Assigned To => Martin Friebe
2010-02-02 13:01 Martin Friebe Status new => assigned
2013-09-14 19:35 Martin Friebe LazTarget 1.2 => post 1.4
2015-03-04 01:03 Martin Friebe Fixed in Revision => 48123
2015-03-04 01:03 Martin Friebe LazTarget post 1.4 => 1.6
2015-03-04 01:03 Martin Friebe Note Added: 0081619
2015-03-04 01:03 Martin Friebe Status assigned => resolved
2015-03-04 01:03 Martin Friebe Fixed in Version => 1.5 (SVN)
2015-03-04 01:03 Martin Friebe Resolution open => fixed
2015-03-04 01:03 Martin Friebe Target Version => 1.6