View Issue Details

IDProjectCategoryView StatusLast Update
0015654LazarusLCLpublic2010-03-23 08:48
ReporterAdibeAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0015654: WinCE align not working for Timage
DescriptionThe Timage is on the Tpanel and its align is set to alBottom. When program is runing image is on position 0,0 on the panel. The same on Wince 5.0 Windows Mobile 6.0 and WM 6.1 . when align is set to alNone position on runtime is always 0,0 .
TagsNo tags attached.
Fixed in Revision24177
LazTarget1.2
WidgetsetWinCE
Attached Files

Relationships

related to 0015945 closedFelipe Monteiro de Carvalho Position of Tlabel wrong at runtime in wince. 
related to 0014760 closedFelipe Monteiro de Carvalho TGroupBox in WinCE: Displacement of child controls / TLabel not visible 

Activities

2010-02-02 15:05

 

wincealignerror.jpg (10,293 bytes)
wincealignerror.jpg (10,293 bytes)

Adibe

2010-02-02 21:26

reporter   ~0034168

Transparency on image is off and the parent panel is green box on the screen.FPC version is 2.4.0 and the same is on 2.5.1 from SVN and 2.3.1.

Adibe

2010-02-03 13:31

reporter   ~0034192

SVN Rev. 23001 and FPC 2.4.1 no problem with images on Wince

Adibe

2010-03-03 08:04

reporter   ~0034913

I was tested this problem with lazarus 0.9.29(SVN 23807) and FPC 2.4.1 and Timage was align corect but the image from this component is painting on position 0,0 on this form not in Timage .

Felipe Monteiro de Carvalho

2010-03-09 22:15

developer   ~0035111

So in SVN rev 23001 it worked and in SVN 23807 it no longer worked? Could you pin point the exact revision which broke it? thanks

Adibe

2010-03-12 12:53

reporter   ~0035323

The pin point is version SVN 23136/23137 .Problem start in version SVN 23137.

Adibe

2010-03-12 13:22

reporter   ~0035328

changes :win32, gtk, qt: implement viewport affine transformation functions by tk (issue 0014857) by paul are not working on wince

Adibe

2010-03-12 16:46

reporter   ~0035374

Something is wrong with GetViewPort functions on Wince like. GetWindowOrgEx

Adibe

2010-03-12 17:00

reporter   ~0035378

Felipe i think the problem is in new fun. from this rev.

function GetViewPortExtEx(DC: HDC; Size: PSize): Integer;
function GetViewPortOrgEx(DC: HDC; P: PPoint): Integer;
function GetWindowExtEx(DC: HDC; Size: PSize): Integer;

Paul Ishenin

2010-03-23 06:55

manager   ~0035963

Please test and close if ok.

Adibe

2010-03-23 08:48

reporter   ~0035966

Paul :)) Thanks for Your help . After Your commit everything is OK.

Issue History

Date Modified Username Field Change
2010-02-02 15:05 Adibe New Issue
2010-02-02 15:05 Adibe File Added: wincealignerror.jpg
2010-02-02 15:05 Adibe Widgetset => WinCE
2010-02-02 21:26 Adibe Note Added: 0034168
2010-02-03 04:42 Paul Ishenin LazTarget => 1.2
2010-02-03 04:42 Paul Ishenin Status new => acknowledged
2010-02-03 13:31 Adibe Note Added: 0034192
2010-03-03 08:04 Adibe Note Added: 0034913
2010-03-09 21:55 Felipe Monteiro de Carvalho Status acknowledged => assigned
2010-03-09 21:55 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2010-03-09 22:15 Felipe Monteiro de Carvalho Note Added: 0035111
2010-03-09 22:15 Felipe Monteiro de Carvalho Status assigned => feedback
2010-03-12 12:53 Adibe Note Added: 0035323
2010-03-12 13:22 Adibe Note Added: 0035328
2010-03-12 16:46 Adibe Note Added: 0035374
2010-03-12 17:00 Adibe Note Added: 0035378
2010-03-15 15:16 Felipe Monteiro de Carvalho Relationship added related to 0015945
2010-03-23 06:55 Paul Ishenin Fixed in Revision => 24177
2010-03-23 06:55 Paul Ishenin Status feedback => resolved
2010-03-23 06:55 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-03-23 06:55 Paul Ishenin Resolution open => fixed
2010-03-23 06:55 Paul Ishenin Note Added: 0035963
2010-03-23 08:48 Adibe Status resolved => closed
2010-03-23 08:48 Adibe Note Added: 0035966
2010-05-04 15:31 Felipe Monteiro de Carvalho Relationship added related to 0014760