View Issue Details

IDProjectCategoryView StatusLast Update
0015673LazarusIDEpublic2011-12-01 11:23
ReporterGraeme GeldenhuysAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSUbuntu LinuxOS Version9.04
Product Version0.9.29 (SVN)Product Buildr23630 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0015673: HTML tooltips not fully readable
DescriptionWhen the IDE uses HTML tooltips in the code editor, a lot of the text is hidden by scrollbars. You cannot scroll or resize the tooltip window, because as soon as you move the mouse the tooltip window disappears.

See attached screenshot.

Lazarus 0.9.29 r23630 FPC 2.4.1 x86_64-linux-gtk 2 (beta)
TagsNo tags attached.
Fixed in Revision23696
LazTarget-
Widgetset
Attached Files

Relationships

child of 0013968 closedJesus Reyes Scrollbars: SIF_DISABLENOSCROLL does not work for Gtk1/2 

Activities

2010-02-04 09:40

 

Screenshot-1.png (12,898 bytes)
Screenshot-1.png (12,898 bytes)

Vincent Snijders

2010-02-04 12:28

manager   ~0034219

I assume this is another typo:
> You can scroll or resize the tooltip window
must be
> You cannot scroll or resize the tooltip window

Graeme Geldenhuys

2010-02-04 12:47

reporter   ~0034220

Oops, you are correct. [I was in a bit of a hurry - it shows]
Can you fix that text please.

Why can't we edit the original text if we were the reporter? After all, we can edit our own added comments, but not the original bug report comments. This makes no sense.

user268

2010-02-04 13:41

  ~0034224

Last edited: 2010-02-04 13:42

Reporter can change nothing, expect his own note and reopen issue if closed by manager.

Thus manager's phrase: "Test and close if fixed" mean nothing to reporter, since he cannot close/modify/delete his own report.

Vincent Snijders

2010-02-04 15:38

manager   ~0034229

@Sasa: a reporter can close his own issue, see for example:
http://bugs.freepascal.org/view.php?id=15669

If it doesn't work for you, please create a separate issue in the Mantis project of this bug tracker, so we can investigate why it doesn't work for you.

user268

2010-02-04 16:14

  ~0034230

Last edited: 2010-02-04 16:15

Vincent: I see. It does not work for me (no comboboxes and buttons appears when issue is closed). I do not really need it. Thank you.

Graeme Geldenhuys

2010-02-12 15:22

reporter   ~0034408

Thanks it's working nicely now.

ps:
Sorry I screwed up and re-opened the report. You can close it again.

Issue History

Date Modified Username Field Change
2010-02-04 09:40 Graeme Geldenhuys New Issue
2010-02-04 09:40 Graeme Geldenhuys File Added: Screenshot-1.png
2010-02-04 12:03 Marc Weustink LazTarget => -
2010-02-04 12:03 Marc Weustink Summary HTML toolkits not fully readable => HTML tooltips not fully readable
2010-02-04 12:28 Vincent Snijders Note Added: 0034219
2010-02-04 12:47 Graeme Geldenhuys Note Added: 0034220
2010-02-04 12:56 Vincent Snijders Description Updated
2010-02-04 13:41 user268 Note Added: 0034224
2010-02-04 13:42 user268 Note Edited: 0034224
2010-02-04 15:38 Vincent Snijders Note Added: 0034229
2010-02-04 16:14 user268 Note Added: 0034230
2010-02-04 16:15 user268 Note Edited: 0034230
2010-02-09 22:55 Jesus Reyes Status new => assigned
2010-02-09 22:55 Jesus Reyes Assigned To => Jesus Reyes
2010-02-10 02:33 Jesus Reyes Relationship added related to 0013968
2010-02-12 07:47 Jesus Reyes Relationship deleted related to 0013968
2010-02-12 07:47 Jesus Reyes Relationship added child of 0013968
2010-02-12 07:49 Jesus Reyes Fixed in Revision => 23696
2010-02-12 07:49 Jesus Reyes Status assigned => resolved
2010-02-12 07:49 Jesus Reyes Fixed in Version => 0.9.29 (SVN)
2010-02-12 07:49 Jesus Reyes Resolution open => fixed
2010-02-12 15:19 Graeme Geldenhuys Status resolved => closed
2010-02-12 15:19 Graeme Geldenhuys Status closed => assigned
2010-02-12 15:19 Graeme Geldenhuys Resolution fixed => reopened
2010-02-12 15:22 Graeme Geldenhuys Note Added: 0034408
2010-02-12 17:02 Jesus Reyes Status assigned => resolved
2010-02-12 17:02 Jesus Reyes Resolution reopened => fixed
2011-12-01 11:23 Marc Weustink Status resolved => closed