View Issue Details

IDProjectCategoryView StatusLast Update
0015699LazarusIDEpublic2010-12-28 10:01
ReporterMarelisAssigned ToAbou Al Montacir 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSUbuntuOS Version9.10
Product Version0.9.29 (SVN)Product Build23657 
Target Version0.9.30Fixed in Version 
Summary0015699: Error while compiling resources, missing (?) ../lcl/units/x86_64-linux/finddlgunit.lfm
DescriptionIf I save default project to disk (default filenames) and try Build then error occurred: "project1.lpr(19,1) Error: Error while compiling resources".

Funny is that I do not know exactly how I did it, but some log indicating the row like this: "can not find /usr/lib/lazarus/0.9.29/lcl/units/x86_64-linux/finddlgunit.lfm.

It's a bit fuzzy (sorry), but I do not have time, perhaps it would be enough to determine the problem. Thx.
TagsNo tags attached.
Fixed in Revision
LazTarget0.9.30
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0018017 closedAbou Al Montacir project1.lpr(17,1) Error: Error while compiling resources 

Activities

2010-02-09 09:04

 

test_project.tar.gz (249,076 bytes)

2010-02-09 09:04

 

home_lazarus.tar.gz (18,108 bytes)

Marelis

2010-02-09 09:05

reporter   ~0034314

Same problem with default project on the i386 platform. Interesting is that the file "../lib/i386-linux/project1.reslst" contains:

/usr/lib/lazarus/0.9.29/lcl/units/i386-linux/finddlgunit.lfm
/usr/lib/lazarus/0.9.29/lcl/units/i386-linux/replacedlgunit.lfm
project1.res

I added the project and HOME/.lazarus directory for testing.

Thanks.

Marelis

2010-02-13 07:59

reporter   ~0034426

So guys, how you see it? Any change or the problems the queue is too long and this problem is too insignificant? :o)

Marelis

2010-02-13 15:20

reporter   ~0034445

I change the file path in project1.reslst to the desired *.lfm (../lcl/forms) And after using the script ppas.sh (quick compilation) to see:

~ ../lib/x86_64-linux/project1.o:(.data+0xd58): undefined reference to FPC_RESSYMBOL'

This I see, even though the two lines with .lfm removed from the file project1.reslst

Can this help?

OT: why is this little script called ppas.sh? :o)

Paul Ishenin

2010-02-15 09:26

manager   ~0034486

1. What fpc version do you use?
2. Do you have the missing lfm at that location?

Marelis

2010-02-15 20:54

reporter   ~0034510

Last edited: 2010-02-15 21:05

> 1. What fpc version do you use?

2.5.1 (14856)

> 2. Do you have the missing lfm at that location?

in the directory "../usr/lib/lazarus/0.9.29/lcl/units/i386-linux" no
in the directory "../usr/lib/lazarus/0.9.29/lcl/forms" yes

I do not understand why it is linking "finddlg" and "replacedlg" when not used in the application.

Linking works without errors after a new building Lazarus IDE.

Note: I have two ubuntu installations, one i386 and one x86_64, the problem I have both. I write this because somewhere in the text one platform and sometimes another.

Paul Ishenin

2010-02-16 02:56

manager   ~0034511

finddlg and replacedlg are indirectly used by LCL. We can't solve the problem that they are used at moment.

So, as I see after rebuilding of IDE you have no more problems? If so then can we resolve the issue?

Marelis

2010-02-16 05:44

reporter   ~0034516

I guess we have different views on what is an error/problem and what is not.

You think it's okay, when, after a clean install of fpc and Lazarus IDE like mad - if - after a new building Lazarus IDE everything okay. I think that after a clean install of fpc and Lazarus IDE application should compile and link without errors. And who of us is right?

Plenty of time, maybe someone can figure out where the error. Somewhere around the error when it happens, right?

I understand that you would like to shut the (bury) all the problems that the fpc and lazarus pure as glass, but I'm afraid it's full dynamic system with changes, which never ends ;-)

Thanks.

Mattias Gaertner

2010-02-16 13:16

manager   ~0034527

How did you create "a clean install of fpc and Lazarus IDE"?
How can I reproduce the error?

The ppas.sh is created by the compiler. Normally it is removed when compilation is successful.

Marelis

2010-02-17 08:32

reporter   ~0034549

I see that it does not make sense not to waste time, say that it is "resolved" simply made after each install Lazarus IDE his new building, it is to "solve". Close, please, this problem. I will not bother, thank you for your time.

Zeljan Rikalo

2010-02-17 08:58

developer   ~0034550

hm..mattias correctly asked you about "clean install of fpc and lazarus IDE".
If you installed lazarus from daily snapshots, but U use fpc-2.5.1 then it's obvious why you have to rebuild lazarus.

Marelis

2010-02-17 09:28

reporter   ~0034551

Last edited: 2010-02-17 18:21

Of course, that I use fpc 2.5.1 and Lazarus IDE compiled in it. I'm not such a fool. Oh, and how about this:

1) clean filesystem (fpc, lazarus)
2) install fpc 2.4.0 (official packages)
3) checkout fpc 2.5.1 svn + export (correction: fpcbuild - see Note 0034563)
4) make deb
5) uninstall fpc 2.4.0 packages
6) clean filesystem (fpc)
7) install new packages fpc 2.5.1
8) checkout lazarus svn + export
9) make deb
10) install new packages lazarus

You could call this a "clean install ..." ?

Do you have a project and lazarus user configuration directory. If this error is non-reproducible, so this place probably has no meaning unless one of you able to determine from available information what is happening and or any other information requests it from me.

Yet this I can do a new building Lazarus IDE, it should resolve itself over time ;-)

Close it, we do, I'm user-crazy and everything is okay. Thanks.

Mattias Gaertner

2010-02-17 16:52

manager   ~0034560

I never tried that.
I checked out http://svn.freepascal.org/svn/fpc/trunk, got fpc 2.5.1. I tried 'make deb', which gives:

make: *** No rule to make target `deb'. Stop.

I usually build my fpc deb with the script in lazarus/tools/install:

http://wiki.lazarus.freepascal.org/Getting_Lazarus#Building_a_fpc_debian.2Fubuntu_package_from_fpc_svn

I tried it with the debs (fpc,fpc-src,lazarus) build via the scripts. There was a warning that the default lazarus directory is wrong. I fixed that.
It compiles a project without error under linux/i386/ubuntu.

So, I guess the bug is in one of the two 'make deb'.

Marelis

2010-02-17 17:57

reporter   ~0034563

Last edited: 2010-02-17 18:42

I'm sorry, line number 3) must be with fpcbuild, there can be done make deb. Excuse me.

http://svn.freepascal.org/svn/fpcbuild/trunk

Previously, I also enjoyed the way fpc + fpc-src + lazarus, but after a longer time and the fight can be done Debian packages without errors (mostly :o) with make deb.

I just enter "make deb NOGDB=1" because they are tiny problems linking gdb v7.0 under Ubuntu 9.10 :-) See:

http://bugs.freepascal.org/view.php?id=15272

Marelis

2010-02-18 01:19

reporter   ~0034571

Last edited: 2010-02-18 02:48

I can for this misunderstanding, I did not write here that I fpc and lazarus IDE installed from Debian packages, which I call the "clean install". Sorry.

(general: the barbaric method "configure / make / make install" I use only in an emergency because it usually entered into the file system disorder)

If you had the creation of a Debian package fpc / lazarus any problems, so I can help. I got luck. Thank you for trying to clarify this issue. Currently, when building fpc (fpcbuild) svn "make deb" error, see:

http://bugs.freepascal.org/view.php?id=15753

Last built fpc (fpcbuild) svn "make deb" I have release 14856. I'm waiting on someone to correct the "make". I could use a newer version of fpc and official version 2.4.0 is a bit too many mistakes, perhaps someone fix, oh yeah: o)

I added a log file with the building Lazarus IDE svn rev 23728 (command "make deb"). Installed fpc 2.4.0 (official packages). Maybe it somehow helps explain why the lazarus/linker try to find files *.lfm in "../lcl/units/i386-linux".

At the beginning of the log to see "patching ... debian/control", there are just removing the dependence on a mysterious fpc-abi: o) This is reported and so far it seems to sleep, so I solve it himself:

http://bugs.freepascal.org/view.php?id=15712

2010-02-18 02:40

 

lazarus.sh_20100218_020446.log.tar.gz (43,553 bytes)

Marelis

2010-02-19 04:17

reporter   ~0034587

Could be related:

http://bugs.freepascal.org/view.php?id=15808

Devi Mandiri

2010-02-25 05:55

reporter   ~0034740

Today I got the same problem: "error compiling missing resources" after installing lazarus-0.9.29.23738-20100219.i386 (and then lazarus-0.9.29.23772-20100224.i386) from shikami snapshots

I'm using ubuntu 8.04 and fpc-2.4.0-0.i386
I don't know how to solve this error by reading through this thread,

so I did a quick hack;

copied these files:
"/usr/lib/lazarus/0.9.29/lcl/forms/finddlgunit.lfm"
"/usr/lib/lazarus/0.9.29/lcl/forms/replacedlgunit.lfm"

to /usr/lib/lazarus/0.9.29/lcl/units/i386-linux

Marelis

2010-02-25 09:36

reporter   ~0034746

Thanks for the tip, I'll do a small patch after installing debian packages with Lazarus IDE than the authors attempt to solve this problem. Maybe they can find an answer to the question:

Why lazarus/linker tries to find files "*.lfm" in "../lcl/units/i386-linux" after the installation of Lazarus from the Debian packages?

If the authors probably need some additional information on this puzzle, so just write a few words. Maybe this one will be okay and it will be great :o)

Thanks.

Vincent Snijders

2010-11-02 16:16

manager   ~0042629

Can you retest this issue?

Marelis

2010-11-10 09:22

reporter   ~0042939

Since I have myself creating Debian packages with the FPC and Lazarus IDE from the SVN source, I do not have this problem (and others too;)

Mark this as solved, if the problem does not bother someone else.

Thank you.

Marelis

2010-11-30 11:07

reporter   ~0043783

I tested again but the error is still the same, I assume it's related to building debian packages, see Issue No. 0018111.

File '../lib/i386-linux/project1.reslst' also contains:

/usr/lib/lazarus/0.9.29/lcl/units/i386-linux/finddlgunit.lfm
/usr/lib/lazarus/0.9.29/lcl/units/i386-linux/replacedlgunit.lfm

I'm going to go back to my Debian packages with the FPC and Lazarus IDE, from this 'original' I would probably go mad :o)

Thanks.

Abou Al Montacir

2010-12-18 01:05

developer   ~0044314

Duplicate of issue 0018017

Issue History

Date Modified Username Field Change
2010-02-07 07:27 Marelis New Issue
2010-02-07 07:27 Marelis Widgetset => GTK 2
2010-02-09 09:04 Marelis File Added: test_project.tar.gz
2010-02-09 09:04 Marelis File Added: home_lazarus.tar.gz
2010-02-09 09:05 Marelis Note Added: 0034314
2010-02-13 07:59 Marelis Note Added: 0034426
2010-02-13 15:20 Marelis Note Added: 0034445
2010-02-15 09:26 Paul Ishenin LazTarget => -
2010-02-15 09:26 Paul Ishenin Note Added: 0034486
2010-02-15 09:26 Paul Ishenin Status new => feedback
2010-02-15 20:54 Marelis Note Added: 0034510
2010-02-15 21:00 Marelis Note Edited: 0034510
2010-02-15 21:04 Marelis Note Edited: 0034510
2010-02-15 21:05 Marelis Note Edited: 0034510
2010-02-16 02:56 Paul Ishenin Note Added: 0034511
2010-02-16 05:44 Marelis Note Added: 0034516
2010-02-16 13:16 Mattias Gaertner Note Added: 0034527
2010-02-17 08:32 Marelis Note Added: 0034549
2010-02-17 08:58 Zeljan Rikalo Note Added: 0034550
2010-02-17 09:28 Marelis Note Added: 0034551
2010-02-17 09:49 Marelis Note Edited: 0034551
2010-02-17 09:51 Marelis Note Edited: 0034551
2010-02-17 16:52 Mattias Gaertner Note Added: 0034560
2010-02-17 17:57 Marelis Note Added: 0034563
2010-02-17 18:02 Marelis Note Edited: 0034563
2010-02-17 18:21 Marelis Note Edited: 0034551
2010-02-17 18:27 Marelis Note Edited: 0034563
2010-02-17 18:41 Marelis Note Edited: 0034563
2010-02-17 18:42 Marelis Note Edited: 0034563
2010-02-18 01:19 Marelis Note Added: 0034571
2010-02-18 02:17 Marelis Note Edited: 0034571
2010-02-18 02:19 Marelis Note Edited: 0034571
2010-02-18 02:21 Marelis Note Edited: 0034571
2010-02-18 02:39 Marelis Note Edited: 0034571
2010-02-18 02:40 Marelis File Added: lazarus.sh_20100218_020446.log.tar.gz
2010-02-18 02:48 Marelis Note Edited: 0034571
2010-02-19 04:17 Marelis Note Added: 0034587
2010-02-25 05:55 Devi Mandiri Note Added: 0034740
2010-02-25 09:36 Marelis Note Added: 0034746
2010-11-02 16:16 Vincent Snijders Note Added: 0042629
2010-11-10 09:22 Marelis Note Added: 0042939
2010-11-30 11:07 Marelis Note Added: 0043783
2010-11-30 11:21 Vincent Snijders LazTarget - => 0.9.30
2010-11-30 11:21 Vincent Snijders Assigned To => Abou Al Montacir
2010-11-30 11:21 Vincent Snijders Status feedback => assigned
2010-11-30 11:21 Vincent Snijders Target Version => 0.9.30
2010-11-30 11:21 Vincent Snijders Relationship added duplicate of 0018017
2010-12-18 01:05 Abou Al Montacir Duplicate ID 0 => 18017
2010-12-18 01:05 Abou Al Montacir Status assigned => resolved
2010-12-18 01:05 Abou Al Montacir Resolution open => fixed
2010-12-18 01:05 Abou Al Montacir Note Added: 0044314
2010-12-28 10:01 Marelis Status resolved => closed