View Issue Details

IDProjectCategoryView StatusLast Update
0015712Lazarus-public2010-03-16 09:33
ReporterMarelisAssigned ToAbou Al Montacir 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx86_64OSUbuntuOS Version9.10
Product Version0.9.29 (SVN)Product Build23657 
Target VersionFixed in Version 
Summary0015712: Missing a dependency on virtual package fpc-abi-2.4.0
DescriptionWhen I create Debian packages for Lazarus (make deb) and I want to install it, so missing a dependency on virtual package fpc-abi-2.4.0. It's not a forgotten orphan?

In debian/control is "${fpc-abi:Depends}" for package lazarus-ide.

Sidelight: if I remember correctly, during the creation of the debian package is shown warning of "${shlibs:Depends}" (ibid.)

I found this link (can help?):

http://packages.debian.org/unstable/fpc-abi-2.4.0

Thanks.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Marelis

2010-02-13 08:12

reporter   ~0034430

Who wants to install Debian packages lazarus IDE, for example, in Ubuntu, he will have unmet dependencies. Incidentally, the same dependence on fpc-abi is in your Debian packages that you offer through the ftp server.

And the question is what do you think goes well install a package that satisfied no dependencies?

Abou Al Montacir

2010-02-23 22:35

developer   ~0034713

the pseudo-package fpc-abi-2.4.0 is provided by the fp-units-rtl (>= 2.4.0-0). This package is available in debian sid and squeeze. The packages are available on ftp.debian.org and are working well.

Of course the easiest way to use lazarus is to download packages binaries from debian.org or from ubuntu depending on your system.

Now how to build Lazarus deb packages? This depends on what branch you want to build. The trunk will probably not build as I didn't test it, but I know that there are snapshots so I assume it will build somewhat fine. I can guarentee building form tags/lazarus_0_9_28_2. You just checkout it and make deb will do the job for you.
If you want the latest debian changes, you just checkout https://bollin.googlecode.com/svn/lazarus/trunk too and use make deb DEBDIR=<path to this checkout>/debian

I'll write a wiki page for this :) Please report issues attaching the log file
make deb DEBDIR=path 2>&1 | tee build.log

Marelis

2010-02-24 00:51

reporter   ~0034715

Last edited: 2010-02-24 10:44

Thank you for your response and interesting information!

I guess I'm an idiot, but the virtual package fpc-abi is there for something good? What is physical dependence on nonexistent package? Because a reference or voodoo? :o)

IN ADDITION: if I try (in Ubuntu 9.10), this package fpc-abi install, so it can not find the package manager (command: 'sudo apt-get install fpc-abi'). A manual install "virtual" package comes to me as not very useful. If the dependence on the package fpc-abi unnecessary, it can be considered as a mistake? (reason for the amputation? :o) Or is it really voodoo, and without him it 'not live'? :o)

IN ADDITION: package fpc-abi is not in this list:

http://www.debian.org/doc/packaging-manuals/virtual-package-names-list.txt

Lazarus IDE from svn trunk: I manage to build a Debian packages by running make deb.

I tried the "bollin.googlecode.com" svn source, but "Authorization Required". You know the magic formula, which is passed through the gateway? :o)

I look forward to the wiki page as a little boy :o)

Thanks.

Abou Al Montacir

2010-02-24 12:11

developer   ~0034727

fpc-abi works just like a virtual package. It ensures depending of FPC ABI version and thus avoid error messages like interface CRC changed. This is not an error but a feature.

Abou Al Montacir

2010-02-24 12:12

developer   ~0034728

For bollin, please use htt instead of https, please refer to googlecode user manual.

Marelis

2010-02-24 13:09

reporter   ~0034729

I would have to be repeated, so it seems that I have this 'feature' to remove a patch before each command 'make deb' to install the Lazarus IDE no problems with dependencies in Ubuntu.

So now classic phrase "resolved, right?" and it's done :o)

Maybe it was something good, I know about the new resources with svn fpc/lazarus debian directory, and future wiki article. So thanks.

Mattias Gaertner

2010-02-25 07:30

manager   ~0034742

Fixed by Mazen.

Marelis

2010-03-02 07:31

reporter   ~0034891

Last edited: 2010-03-03 07:05

File '../debian/control' contains more dependent on the package fpc-abi and when I built the debian packages 'make deb', svn revision 23821, so that dependence on fpc-abi is still there (package lazarus-ide).

What do Mazen of fixing?

ADDITION: Package manager for lazarus-ide silent on fpc-abi, so to install okay, it would be that in the package version number is not required fpc-abi in brackets? I must have gaps in education :o)

ADDITION: So that it was entirely visual: '../debian/control' in the package lazarus-ide:

Package: lazarus-ide
Source: lazarus
Version: 0.9.29-0
Architecture: i386
Maintainer: Carlos Laviola <claviola@debian.org>
Installed-Size: 205088
Pre-Depends: dpkg (>= 1.10.24)
Depends: libatk1.0-0 (>= 1.20.0), libc6 (>= 2.3.6-6~), libcairo2 (>= 1.2.4), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.8.0), libpango1.0-0 (>= 1.14.0), libx11-6, fp-compiler (>= 2.2.4-3), fp-units-base, fp-units-rtl, fp-units-fcl, fp-units-gtk2, fpc-abi-2.5.1, lazarus-src
Recommends: fpc, gdb
Suggests: fp-utils
Section: devel
Priority: optional
Homepage: http://www.lazarus.freepascal.org
Description: ...

I see who it was assigned, oh yeah, that perhaps I read that it's 'feature' :o)

Vincent Snijders

2010-03-11 15:18

manager   ~0035257

The missing dependency is explained. What needs to be done to resolve this issue?

Marelis

2010-03-15 19:25

reporter   ~0035583

If you do not mind the dependency on fpc-abi, which is not in the list of virtual packages, and Ubuntu package manager can not know and if you consider it solved, so that close. As for me, so it can always fix patch. I wanted to let it all right for others, so I reported it here as a bug. Thanks.

Vincent Snijders

2010-03-15 19:38

manager   ~0035586

I still don't see what is wrong with a dependency on fpc-abi, even the official ubuntu packages for lazarus do it:
http://packages.ubuntu.com/en/lucid/lazarus-ide
fpc-abi-2.4.0
    virtual package provided by fp-units-rtl

So, it seems to be rather a Ubuntu package manager issue.

Marelis

2010-03-15 20:13

reporter   ~0035590

I will not repeat, Okay, it's okay. Please close. Thank you.

Vincent Snijders

2010-03-15 21:18

manager   ~0035596

Thanks for helping to make Lazarus better.

Marelis

2010-03-16 09:33

reporter   ~0035624

Pedant's never easy ;-) Thank you for your time.

Issue History

Date Modified Username Field Change
2010-02-08 21:32 Marelis New Issue
2010-02-08 21:32 Marelis Widgetset => GTK 2
2010-02-13 08:12 Marelis Note Added: 0034430
2010-02-23 22:35 Abou Al Montacir Note Added: 0034713
2010-02-24 00:51 Marelis Note Added: 0034715
2010-02-24 10:39 Marelis Note Edited: 0034715
2010-02-24 10:44 Marelis Note Edited: 0034715
2010-02-24 12:11 Abou Al Montacir Note Added: 0034727
2010-02-24 12:12 Abou Al Montacir Note Added: 0034728
2010-02-24 13:09 Marelis Note Added: 0034729
2010-02-25 07:30 Mattias Gaertner LazTarget => -
2010-02-25 07:30 Mattias Gaertner Note Added: 0034742
2010-02-25 07:30 Mattias Gaertner Status new => resolved
2010-02-25 07:30 Mattias Gaertner Resolution open => fixed
2010-03-02 07:31 Marelis Status resolved => assigned
2010-03-02 07:31 Marelis Resolution fixed => reopened
2010-03-02 07:31 Marelis Note Added: 0034891
2010-03-02 07:42 Marelis Note Edited: 0034891
2010-03-02 13:15 Vincent Snijders Project Packages => Lazarus
2010-03-02 13:15 Vincent Snijders Assigned To => Abou Al Montacir
2010-03-03 07:05 Marelis Note Edited: 0034891
2010-03-11 15:18 Vincent Snijders Note Added: 0035257
2010-03-11 15:18 Vincent Snijders Status assigned => feedback
2010-03-15 19:25 Marelis Note Added: 0035583
2010-03-15 19:38 Vincent Snijders Note Added: 0035586
2010-03-15 20:13 Marelis Note Added: 0035590
2010-03-15 21:18 Vincent Snijders Status feedback => resolved
2010-03-15 21:18 Vincent Snijders Resolution reopened => no change required
2010-03-15 21:18 Vincent Snijders Note Added: 0035596
2010-03-16 09:33 Marelis Status resolved => closed
2010-03-16 09:33 Marelis Note Added: 0035624