View Issue Details

IDProjectCategoryView StatusLast Update
0015747LazarusIDEpublic2011-12-01 11:23
ReporterStéphane BérubéAssigned ToVincent Snijders 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Product Version0.9.26.2Product Build 
Target VersionFixed in Version 
Summary0015747: Complete crash when browsing folders
DescriptionWhen I try to open a file via "Project -> Open Project" or "File -> Open", an empty popup opens. If I close the popup the IDE crash when I change folder.
Additional InformationKubuntu 9.10 i386 running in VirtualBox 3.1.2
Lazarus freshly fetched from ubuntu repository.
Tagscrash, ide_editor, kde, kubuntu, linux
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0015267 closedVincent Snijders Crash on open dialog 
duplicate of 0015114 closedJuha Manninen IDE dies when trying to select FPC source directory 

Activities

2010-02-12 21:35

 

kubuntu910_lazarus_crash.jpg (308,998 bytes)

Stéphane Bérubé

2010-02-12 22:47

reporter   ~0034417

reproduced with Lazarus 0.9.29-20100210 + FPC 2.4.0.
crashes with no "empty popup"

Patrick Chevalley

2010-02-12 23:59

reporter   ~0034419

Try with another Gtk theme, for me Clearlooks work fine but I also have this problem with the default QtCurve.
Install gtk2-engines, and change it from KDE system setting / Appearance / GTK+ Appearance

It may be nice to have a better workaround, because of this problem no Lazarus application work by default on Kubuntu and maybe other KDE distribution.

Stéphane Bérubé

2010-02-13 00:29

reporter   ~0034420

Works with GTK+. the other themes makes it crash.
I think I'm gonna install Ubuntu instead :)

Thank you!

Issue History

Date Modified Username Field Change
2010-02-12 21:35 Stéphane Bérubé New Issue
2010-02-12 21:35 Stéphane Bérubé File Added: kubuntu910_lazarus_crash.jpg
2010-02-12 21:36 Stéphane Bérubé Tag Attached: crash
2010-02-12 21:36 Stéphane Bérubé Tag Attached: ide_editor
2010-02-12 21:36 Stéphane Bérubé Tag Attached: linux
2010-02-12 22:47 Stéphane Bérubé Note Added: 0034417
2010-02-12 22:48 Stéphane Bérubé Tag Attached: kubuntu
2010-02-12 22:57 Stéphane Bérubé Tag Attached: kde
2010-02-12 23:59 Patrick Chevalley Note Added: 0034419
2010-02-13 00:29 Stéphane Bérubé Note Added: 0034420
2010-03-12 10:54 Vincent Snijders Relationship added duplicate of 0015267
2010-03-12 10:56 Vincent Snijders LazTarget => -
2010-03-12 10:56 Vincent Snijders Relationship added duplicate of 0015114
2010-03-12 10:56 Vincent Snijders Duplicate ID 0 => 15114
2010-03-12 10:56 Vincent Snijders Status new => resolved
2010-03-12 10:56 Vincent Snijders Resolution open => duplicate
2010-03-12 10:56 Vincent Snijders Assigned To => Vincent Snijders
2011-12-01 11:23 Marc Weustink Status resolved => closed