View Issue Details

IDProjectCategoryView StatusLast Update
0015753FPCPackagespublic2010-12-26 17:56
ReporterMarelisAssigned ToAbou Al Montacir 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSUbuntuOS Version9.10
Product Version2.5.1Product Build 
Target VersionFixed in Version2.6.0 
Summary0015753: 'make deb' error: rmdir ~ '../debian/tmp/usr/share/doc/fpc-2.5.1': Directory not empty
Description*) after this:

**** Examples copyed ****

*) error:

rmdir: failed to remove `/media/Marelis/Build/fpc/20100213_064845.fpc.sh/build/fpc-2.5.1/debian/tmp/usr/share/doc/fpc-2.5.1': Directory not empty
make[1]: *** [install-arch-stamp] Error 1
make[1]: Leaving directory `/media/Marelis/Build/fpc/20100213_064845.fpc.sh/build/fpc-2.5.1'
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
make: *** [debbuild] Error 2
TagsNo tags attached.
Fixed in Revision741
FPCOldBugId0
FPCTarget
Attached Files

Relationships

related to 0018109 closedMichael Van Canneyt File ezcgi.pp not found 

Activities

Marelis

2010-02-21 08:30

reporter   ~0034626

Last edited: 2010-02-21 08:41

Could help:

1) I added a log dump file

2) directory, which, according to reports is not empty (../debian/tmp/usr/share/doc/fpc-2.5.1), contains the following:

./libsee
./libsee/examples
./libsee/examples/Makefile.fpc
./libsee/examples/mod_stream.pp
./libsee/examples/tlibsee.pp
./libsee/examples/teststream.pp
./libsee/examples/Makefile
./libsee/examples/testwrite.pp

Tested today with:

'fpcbuild/fpcsrc'
Checked out external at revision 14931.

'fpcbuild/fpcdocs'
Checked out external at revision 636.

'fpcbuild/logs'
Checked out external at revision 22402.

'fpcbuild'
Checked out revision 753.

Tested on i386 platform, where the error also seen (not the fault of just x86_64)

Thanks.

2010-02-21 08:30

 

make_deb_log.tar.gz (112,423 bytes)

Abou Al Montacir

2010-03-15 12:37

manager   ~0035550

I386 are known to work (see snapshot generation). I have daily snashots and it works very well.

Marco van de Voort

2010-03-15 13:05

manager   ~0035553

Abou: for 2.5.1? libsee is recently added to -trunk afaik

Marelis

2010-03-22 07:01

reporter   ~0035899

Any progress? Have the 'libsee' during the build (make deb) process better? Thanks.

Marelis

2010-04-21 14:17

reporter   ~0036880

Any change? (I ask you again next month :o)

Abou Al Montacir

2010-05-13 11:15

manager   ~0037507

Debian snapshot building was OK as I can see here


(debian-sid)abou@fpclin32:~$ svn inf fpcbuild-2.5.1
Unknown command: 'inf'
Type 'svn help' for usage.
(debian-sid)abou@fpclin32:~$ svn info fpcbuild-2.5.1
Path: fpcbuild-2.5.1
URL: http://abou@svn.freepascal.org/svn/fpcbuild/trunk
Repository Root: http://abou@svn.freepascal.org/svn/fpcbuild
Repository UUID: b4dd5b90-57f8-0310-8fd5-d8d89816a767
Revision: 767
Node Kind: directory
Schedule: normal
Last Changed Author: hajny
Last Changed Rev: 766
Last Changed Date: 2010-04-11 15:31:48 +0000 (Sun, 11 Apr 2010)

(debian-sid)abou@fpclin32:~$ ls -lh fpcbuild-2.5.1
total 69M
-rw-r--r-- 1 abou abou 66K Apr 11 22:30 Makefile
-rw-r--r-- 1 abou abou 26K Apr 11 22:30 Makefile.fpc
-rwxr-xr-x 1 abou abou 1.7K Nov 5 2009 createbranch.sh
drwxr-xr-x 19 abou abou 4.0K Mar 28 22:33 demo
-rw-r--r-- 1 abou abou 2.1M May 12 22:42 fp-compiler_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 1.6M May 12 22:47 fp-docs_2.5.1-0_all.deb
-rw-r--r-- 1 abou abou 1.3M May 12 22:42 fp-ide_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 1.3M May 12 22:43 fp-units-base_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 1.1M May 12 22:43 fp-units-db_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 4.7M May 12 22:43 fp-units-fcl_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 475K May 12 22:43 fp-units-fv_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 990K May 12 22:43 fp-units-gfx_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 336K May 12 22:43 fp-units-gnome1_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 1.5M May 12 22:43 fp-units-gtk2_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 983K May 12 22:43 fp-units-gtk_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 458K May 12 22:43 fp-units-i386_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 424K May 12 22:43 fp-units-math_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 1.3M May 12 22:43 fp-units-misc_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 239K May 12 22:43 fp-units-multimedia_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 608K May 12 22:43 fp-units-net_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 2.2M May 12 22:43 fp-units-rtl_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 3.5M May 12 22:42 fp-utils_2.5.1-0_i386.deb
-rw-r--r-- 1 abou abou 13M May 12 22:47 fpc-source_2.5.1-0_all.deb
-rw-r--r-- 1 abou abou 17K May 12 22:35 fpc_2.5.1-0.diff.gz
-rw-r--r-- 1 abou abou 1.4K May 12 22:35 fpc_2.5.1-0.dsc
-rw-r--r-- 1 abou abou 11K May 12 22:46 fpc_2.5.1-0_all.deb
-rw-r--r-- 1 abou abou 7.5K May 12 22:47 fpc_2.5.1-0_i386.changes
-rw-r--r-- 1 abou abou 32M Jan 22 23:32 fpc_2.5.1.orig.tar.gz
drwxr-xr-x 47 abou abou 4.0K May 11 22:31 fpcdocs
drwxr-xr-x 10 abou abou 4.0K Dec 8 23:30 fpcsrc
drwxr-xr-x 20 abou abou 4.0K Feb 21 23:33 install
drwxr-xr-x 3 abou abou 4.0K May 12 22:31 logs
(debian-sid)abou@fpclin32:~$

Marelis

2010-05-13 13:01

reporter   ~0037513

Last edited: 2010-05-13 13:27

I now fpcbuild exported from SVN source, so I tried to "make deb NOGDB=1" and a little more I explored it:

It seems that bash script 'moveexamples' does not move a folder with examples of libsee. So, after move examples the last command in this script (rmdir $EXAMPLE_TEMP) failed and exits with an error.

I added a log and debian folder, which is used to generate packages (created on the fly - without tmp sub.)

Ubuntu 10.04 Lucid i386 with fpc 2.4.0.

Thanks.

2010-05-13 13:02

 

make.log.tar.gz (113,224 bytes)

2010-05-13 13:02

 

debian.tar.gz (19,685 bytes)

Marelis

2010-05-13 14:18

reporter   ~0037517

liska@mar-liska-ntb:/media/Marelis/Subversion$ svn info fpcbuild
Path: fpcbuild
URL: http://svn.freepascal.org/svn/fpcbuild/trunk
Repository Root: http://svn.freepascal.org/svn/fpcbuild
Repository UUID: b4dd5b90-57f8-0310-8fd5-d8d89816a767
Revision: 767
Node Kind: directory
Schedule: normal
Last Changed Author: hajny
Last Changed Rev: 766
Last Changed Date: 2010-04-11 17:31:48 +0200 (Ne, 11 dub 2010)

Marelis

2010-05-13 14:39

reporter   ~0037519

Maybe I'm wrong, but if libsee belongs to the rtl, so the file '../debian/fp-units-rtl.install.in' should contain the line:

/usr/lib/fpc/%{fpcversion}/units/%{fpctarget}/libsee

.. so that the bash script 'moveexamples' could also find this folder (libsee).

Or Am I wrong?

Marelis

2010-05-13 14:54

reporter   ~0037520

Do you have an external current items from SVN fpcbuild? (fpcsrc, fpcdocs, logs)

On my machine:

Fetching external item into 'fpcbuild/fpcsrc'
Checked out external at revision 15262.

Fetching external item into 'fpcbuild/fpcdocs'
Checked out external at revision 663.

Fetching external item into 'fpcbuild/logs'
Checked out external at revision 23667.

It might want to check the integrity of your SVN repository fpcbuild including external items, so we have the same data for building.

Maybe I'm wrong, who knows ;-) Thanks.

Marelis

2010-05-13 15:18

reporter   ~0037521

I found some mistakes in fpcsrc:

path is fpcsrc/packages

add to file fpmake_proc.inc:

procedure add_libsee;
begin
  with Installer do
{$include libsee/fpmake.pp}
end;

add to file fpmake_add.inc:

  add_libsee;

PS: This is not the whole solution, I'm looking for more.

Marelis

2010-05-13 22:36

reporter   ~0037551

I noticed that the files have been corrected (fpmake_proc.inc, fpmake_add.inc) in the SVN source.

When the file 'fpcbuild/install/debian/fp-units-rtl.install.in' add the following line:

/usr/lib/fpc/%{fpcversion}/units/%{fpctarget}/libsee

(not to enter a new blank behind him)

... so for example libsee moves and creates a nice Debian packages, a pleasure to look ;-)

If you have for this libsee better location and put the line into another file in the directory ../debian

@Abou Al Montacir:

If I have a broken car and my neighbor turns out that his car is working, so everything is okay, I'll be in a similar situation with Your directory listing with Debian packages.

Yours sincerely,

Your user/developer Marelis
(Mark Liška from Orlová city from Czech Republic)

Marelis

2010-05-13 22:43

reporter   ~0037554

A few more irregularities (warning) from the log during the creation of Debian packages:

----8<----

touch install-arch-stamp
dh_testdir
dh_testroot
dh_install -s --sourcedir=debian/tmp --list-missing
dh_install: usr/share/doc/fp-units-rtl/examples/libsee/tlibsee.pp exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-rtl/examples/libsee/mod_stream.pp exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-rtl/examples/libsee/testwrite.pp exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-rtl/examples/libsee/teststream.pp exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-rtl/examples/libsee/Makefile.fpc exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-rtl/examples/libsee/Makefile exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/gmp_accept_test.pas exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/pidigits_example2.pas exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/pidigits_example.pas exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/gmp_test_intf.inc exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/scanf_example.pas exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/gmp_testcase.pas exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/Makefile.fpc exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/Makefile exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/printf_example.pas exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/scanf_example2.pas exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/printf_example2.pas exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/doc/fp-units-math/examples/gmp/gmp_test_impl.inc exists in debian/tmp but is not installed to anywhere
dh_install: usr/bin/mkarmins exists in debian/tmp but is not installed to anywhere
dh_install: usr/bin/fpclasschart exists in debian/tmp but is not installed to anywhere
dh_install: usr/bin/mkx86ins exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/fcl-extra/daemonapp.ppu exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/fcl-extra/libpdaemonapp.a exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/fcl-extra/daemonapp.o exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/fcl-extra/Package.fpc exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/bzip2/libpbzip2stream.a exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/bzip2/bzip2.ppu exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/bzip2/bzip2comn.ppu exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/bzip2/libpbzip2.a exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/bzip2/bzip2stream.o exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/bzip2/bzip2.o exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/bzip2/bzip2comn.o exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/bzip2/bzip2stream.ppu exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/bzip2/Package.fpc exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/bzip2/libpbzip2comn.a exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/zorba/zorbadyn.ppu exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/zorba/libpzorba.a exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/zorba/libpzorbadyn.a exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/zorba/zorba.ppu exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/zorba/libpxqc.a exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/zorba/xqc.ppu exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/zorba/xqc.o exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/zorba/zorbadyn.o exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/zorba/zorba.o exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/zorba/Package.fpc exists in debian/tmp but is not installed to anywhere

----8<----

--- Building: arch packages
dh_testdir
dh_testroot
dh_link
dh_installdocs -a
dh_installchangelogs -a
dh_installexamples -a
pod2man -c 'Free pascal for Debian GNU/Linux' \
      debian/fpc-depends > debian/fpc-depends.1
dh_installman -s
dh_strip -s
dh_compress -a
dh_fixperms -a
dh_installdeb -s
dh_shlibdeps -s
dh_gencontrol -s
dpkg-gencontrol: warning: unknown substitution variable ${shlibs:Depends}

----8<----

cp -f preamble.hevea preamble.inc
/usr/bin/hevea ref.tex
./syntax/diagram.tex:17: Warning: Command not found: \@ifpackageloaded
./syntax/diagram.tex:31: Warning: Command not found: \latex
./syntax/diagram.tex:31: Warning: Defining '\litleft' by \renewcommand
./syntax/diagram.tex:32: Warning: Defining '\ulitleft' by \renewcommand
./syntax/diagram.tex:33: Warning: Defining '\syntleft' by \renewcommand
./syntax/diagram.tex:34: Warning: Defining '\litright' by \renewcommand
./syntax/diagram.tex:35: Warning: Defining '\ulitright' by \renewcommand
./syntax/diagram.tex:36: Warning: Defining '\syntright' by \renewcommand
./ref.tex:54: Warning: File \jobname.htoc not found
./ref.tex:103: Warning: Command not found: \mysyntdiag
./ref.tex:104: Warning: Command not found: \synt
./ref.tex:105: Warning: Command not found: \endmysyntdiag
./ref.tex:107: Warning: Command not found: \mysyntdiag
./ref.tex:108: Warning: Command not found: \lit*
./ref.tex:109: Warning: Command not found: \endmysyntdiag
./ref.tex:111: Warning: Command not found: \mysyntdiag
./ref.tex:112: Warning: Command not found: \rep
./ref.tex:112: Warning: Command not found: \synt
./ref.tex:112: Warning: Command not found: \endrep
./ref.tex:113: Warning: Command not found: \endmysyntdiag
./ref.tex:115: Warning: Command not found: \mysyntdiag
./ref.tex:116: Warning: Command not found: \stack
./ref.tex:117: Warning: Command not found: \synt

... etc ...

Marelis

2010-06-27 16:25

reporter   ~0038832

'trunk' should be able to translate the project and generate distribution packages and archives. The same applies to documentation generation. You should get an order in the project at all. Today, I am cleaning and disappearing here, so take note as the council at the end ;-)

Good luck!

Abou Al Montacir

2010-11-02 13:42

manager   ~0042615

Please test if fixed

Marelis

2010-11-29 22:40

reporter   ~0043760

Tested 'make deb NOGDB=1' with doc errors ...

Compiler fpc 2.4.2 -> compiled fpc 2.5.1 SVN:

Fetching external item into 'fpcbuild/fpcsrc'
Checked out external at revision 16476.

Fetching external item into 'fpcbuild/fpcdocs'
Checked out external at revision 735.

Fetching external item into 'fpcbuild/logs'
Checked out external at revision 26658.

Checked out revision 823.

fpc packages created successfully, but:

---8<---
fpdoc --package=fcl --warn-no-node --descr=fcl.xml --content=fcl.xct --import=rtl.xct,../rtl/ --descr=iostream.xml --input="-S2 ../fpcsrc/packages/fcl-base/src/iostream.pp" --descr=pipes.xml --input="../fpcsrc/packages/fcl-process/src/pipes.pp" --descr=streamio.xml --input="../fpcsrc/packages/fcl-base/src/streamio.pp" --descr=process.xml --input="../fpcsrc/packages/fcl-process/src/process.pp" --descr=dbugintf.xml --input="../fpcsrc/packages/fcl-process/src/dbugintf.pp" --descr=contnrs.xml --input="../fpcsrc/packages/fcl-base/src/contnrs.pp" --descr=zstream.xml --input="../fpcsrc/packages/paszlib/src/zstream.pp" --descr=idea.xml --input="../fpcsrc/packages/fcl-base/src/idea.pp" --descr=bufstream.xml --input="../fpcsrc/packages/fcl-base/src/bufstream.pp" --descr=base64.xml --input="../fpcsrc/packages/fcl-base/src/base64.pp" --descr=gettext.xml --input="../fpcsrc/packages/fcl-base/src/gettext.pp" --descr=ezcgi.xml --input="../fpcsrc/packages/fcl-web/src/ezcgi.pp" --descr=pooledmm.xml --input="../fpcsrc/packages/fcl-base/src/pooledmm.pp" --descr=dbugmsg.xml --input="../fpcsrc/packages/fcl-process/src/dbugmsg.pp" --descr=streamex.xml --input="../fpcsrc/packages/fcl-base/src/streamex.pp" --descr=inicol.xml --input="../fpcsrc/packages/fcl-base/src/inicol.pp" --descr=streamcoll.xml --input="../fpcsrc/packages/fcl-base/src/streamcoll.pp" --descr=cachecls.xml --input="../fpcsrc/packages/fcl-base/src/cachecls.pp" --descr=eventlog.xml --input="../fpcsrc/packages/fcl-base/src/eventlog.pp" --descr=syncobjs.xml --input="../fpcsrc/packages/fcl-base/src/syncobjs.pp" --descr=custapp.xml --input="../fpcsrc/packages/fcl-base/src/custapp.pp" --descr=blowfish.xml --input="../fpcsrc/packages/fcl-base/src/blowfish.pp" --descr=simpleipc.xml --input="../fpcsrc/packages/fcl-process/src/simpleipc.pp" --descr=inifiles.xml --input="../fpcsrc/packages/fcl-base/src/inifiles.pp" --descr=rttiutils.xml --input="../fpcsrc/packages/fcl-base/src/rttiutils.pp" --descr=avl_tree.xml --input="../fpcsrc/packages/fcl-base/src/avl_tree.pp" --descr=uriparser.xml --input="../fpcsrc/packages/fcl-base/src/uriparser.pp" --descr=daemonapp.xml --input="../fpcsrc/packages/fcl-extra/src/daemonapp.pp" --descr=libtar.xml --input="../fpcsrc/packages/fcl-base/src/libtar.pp" --descr=ascii85.xml --input="../fpcsrc/packages/fcl-base/src/ascii85.pp" --descr=fptimer.xml --input="../fpcsrc/packages/fcl-base/src/fptimer.pp" --descr=db.xml --input="../fpcsrc/packages/fcl-db/src/base/db.pas" --hide-protected --format=html --output=fcl --footer-date='mmm dd yyyy'
FPDoc - Free Pascal Documentation Tool
Version 2.4.2 [2010/11/11]
(c) 2000 - 2003 Areca Systems GmbH / Sebastian Guenther, sg@freepascal.org

An unhandled exception occurred at $080DE70A :
EFileNotFoundError : ../fpcsrc/packages/fcl-web/src/ezcgi.pp
  $080DE70A
  $080DED61
  $080A9AF5
  $0804944B
  $08049A20

make[3]: *** [fcl.chk] Error 217
make[3]: Leaving directory `/media/Marelis/repos/export/subversion/fpcbuild-2.5.1-823/build/fpc-2.5.1/fpcdocs'
make[2]: *** [hevea] Error 2
make[2]: Leaving directory `/media/Marelis/repos/export/subversion/fpcbuild-2.5.1-823/build/fpc-2.5.1/fpcdocs'
make[1]: *** [build-doc-stamp] Error 2
make[1]: Leaving directory `/media/Marelis/repos/export/subversion/fpcbuild-2.5.1-823/build/fpc-2.5.1'
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
make: *** [debbuild] Error 2
---8<---

Still some details from log file:

---8<---
dh_install -s --sourcedir=debian/tmp --list-missing
dh_install: usr/bin/mkarmins exists in debian/tmp but is not installed to anywhere
dh_install: usr/bin/mkx86ins exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/opencl/cl.ppu exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/opencl/libpcl.a exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/opencl/libpcl_gl.a exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/opencl/cl_gl.o exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/opencl/cl_gl.ppu exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/opencl/cl.o exists in debian/tmp but is not installed to anywhere
dh_install: usr/lib/fpc/2.5.1/units/i386-linux/opencl/Package.fpc exists in debian/tmp but is not installed to anywhere
touch arrange-arch-stamp
---8<---

Thx.

Marco van de Voort

2010-11-30 21:17

manager   ~0043821

This is normal, see related bugticket.

Marelis

2010-12-01 07:46

reporter   ~0043829

Well, it seems that part of the problem with the doc is 'normal' error (beautiful saying :o)

There's still a problem with dh_install -s --sourcedir=debian/tmp --list-missing

Thx.

Marco van de Voort

2010-12-04 21:25

manager   ~0043995

Last edited: 2010-12-18 14:25

The ezcgi problem will be fixed in the coming months, the offending change has been merged to 2.4.3.

This problem is because we don't branch docs, and fix the (very) rare problems that this causes manually when needed.

This means that the docs are not always in buildable state for trunk, since the docs typically focus on the next release (which can be from a brancH)

Marco van de Voort

2010-12-18 14:27

manager   ~0044327

I changed the makefile to the new situation, but could not test easily. Please reopen if it doesn't work.

Marelis

2010-12-26 17:56

reporter   ~0044603

The initial problem is solved, Thanks.

Issue History

Date Modified Username Field Change
2010-02-13 07:10 Marelis New Issue
2010-02-13 12:08 Marco van de Voort Status new => assigned
2010-02-13 12:08 Marco van de Voort Assigned To => Abou Al Montacir
2010-02-21 08:30 Marelis Note Added: 0034626
2010-02-21 08:30 Marelis File Added: make_deb_log.tar.gz
2010-02-21 08:41 Marelis Note Edited: 0034626
2010-03-15 12:37 Abou Al Montacir Note Added: 0035550
2010-03-15 12:42 Abou Al Montacir FPCOldBugId => 0
2010-03-15 12:42 Abou Al Montacir Status assigned => feedback
2010-03-15 13:05 Marco van de Voort Note Added: 0035553
2010-03-22 07:01 Marelis Note Added: 0035899
2010-04-21 14:17 Marelis Note Added: 0036880
2010-05-13 11:15 Abou Al Montacir Note Added: 0037507
2010-05-13 13:01 Marelis Note Added: 0037513
2010-05-13 13:02 Marelis File Added: make.log.tar.gz
2010-05-13 13:02 Marelis File Added: debian.tar.gz
2010-05-13 13:05 Marelis Note Edited: 0037513
2010-05-13 13:20 Marelis Note Edited: 0037513
2010-05-13 13:27 Marelis Note Edited: 0037513
2010-05-13 14:18 Marelis Note Added: 0037517
2010-05-13 14:39 Marelis Note Added: 0037519
2010-05-13 14:54 Marelis Note Added: 0037520
2010-05-13 15:18 Marelis Note Added: 0037521
2010-05-13 22:36 Marelis Note Added: 0037551
2010-05-13 22:43 Marelis Note Added: 0037554
2010-06-27 16:25 Marelis Note Added: 0038832
2010-11-02 13:42 Abou Al Montacir Note Added: 0042615
2010-11-29 22:40 Marelis Note Added: 0043760
2010-11-30 21:16 Marco van de Voort Relationship added related to 0018109
2010-11-30 21:17 Marco van de Voort Note Added: 0043821
2010-12-01 07:46 Marelis Note Added: 0043829
2010-12-04 21:25 Marco van de Voort Note Added: 0043995
2010-12-18 14:25 Marco van de Voort Note Edited: 0043995
2010-12-18 14:27 Marco van de Voort Fixed in Revision => 741
2010-12-18 14:27 Marco van de Voort Status feedback => resolved
2010-12-18 14:27 Marco van de Voort Fixed in Version => 2.5.1
2010-12-18 14:27 Marco van de Voort Resolution open => fixed
2010-12-18 14:27 Marco van de Voort Note Added: 0044327
2010-12-26 17:56 Marelis Status resolved => closed
2010-12-26 17:56 Marelis Note Added: 0044603