View Issue Details

IDProjectCategoryView StatusLast Update
0015808LazarusWebsitepublic2011-12-01 11:23
ReporterDenis GottardelloAssigned ToVincent Snijders 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionwon't fix 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0015808: Freepascal snapshots
DescriptionIn the daily snapshots there aren't the latest debian packages. There are the 2.4.0 version that does not compile Lazarus. See this iussue: http://bugs.freepascal.org/view.php?id=15593.
Can you update them?
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Marco van de Voort

2010-02-18 21:45

manager   ~0034582

FPC has never had debian snapshots as far I know. Debian (and rpm) pkgs are only made for releases.

Denis Gottardello

2010-02-18 22:52

reporter   ~0034583

I don't understand
http://www.hu.freepascal.org/lazarus/

Marelis

2010-02-19 03:48

reporter   ~0034586

Last edited: 2010-02-21 07:47

I'm beginning to suspect that the authors of excellent fpc and Lazarus IDE to underestimate the importance of the distribution of their works. Just look at the approach to the problems which I have reported on building Debian packages from the svn with make deb (which is the most economical way better than pulling dozens of megabytes of packages from the ftp):

http://bugs.freepascal.org/view.php?id=15699

http://bugs.freepascal.org/view.php?id=15753

http://bugs.freepascal.org/view.php?id=15712

fpcbuild and lazarus svn have build target "make deb" (this should be very cared file), but such as are ancillary lazarus bash scripts in "tools/install/..", which can also be used to build Debian packages (fpc or lazarus). So a little schizo.

Even if I noticed the lazarus packages in the snapshots are not done "make deb", but these auxiliary scripts, which are dependent on the package fpc and fpc-src (!), which can be built only with the auxiliary scripts. But they are not based on official fpc packages created "make deb".

(I removed rudeness, which I have written. Very sorry. Marelis)

Perhaps someone will argue that the fpc and lazarus package together unrelated, but fpc and lazarus are in some way linked projects. It is "the case" too.

Marelis

2010-02-19 04:27

reporter   ~0034588

Last edited: 2010-02-21 07:45

Why Jonas Maebe assigned this problem minor => feature and Packages => Website ?

(I removed rudeness, which I have written. Very sorry. Marelis)

Marco van de Voort

2010-02-19 21:14

manager   ~0034609

Last edited: 2010-02-19 21:16

That is a lazarus site.

I think it is safe to assume that Jonas (correctly) classified it as a feature request since FPC doesn't generate .deb snapshots currently.

But since it is about Lazarus built snapshots, I think it is better to move this issue to lazarus.

Vincent Snijders

2010-03-11 14:44

manager   ~0035248

No, these deb packages will keep using the latest fpc release, which is fpc 2.4.0.

There is a workaround for issue 0015593.

As soon as there is a new fpc release, the lazarus snapshots will be built against those.

Issue History

Date Modified Username Field Change
2010-02-18 17:48 Denis Gottardello New Issue
2010-02-18 18:25 Jonas Maebe FPCOldBugId => 0
2010-02-18 18:25 Jonas Maebe Severity minor => feature
2010-02-18 18:25 Jonas Maebe Category Packages => Website
2010-02-18 21:45 Marco van de Voort Note Added: 0034582
2010-02-18 22:52 Denis Gottardello Note Added: 0034583
2010-02-19 03:48 Marelis Note Added: 0034586
2010-02-19 04:01 Marelis Note Edited: 0034586
2010-02-19 04:09 Marelis Note Edited: 0034586
2010-02-19 04:27 Marelis Note Added: 0034588
2010-02-19 04:28 Marelis Note Edited: 0034588
2010-02-19 21:14 Marco van de Voort Note Added: 0034609
2010-02-19 21:16 Marco van de Voort Note Edited: 0034609
2010-02-19 21:17 Marco van de Voort Project FPC => Lazarus
2010-02-21 07:45 Marelis Note Edited: 0034588
2010-02-21 07:46 Marelis Note Edited: 0034586
2010-02-21 07:47 Marelis Note Edited: 0034586
2010-03-11 14:44 Vincent Snijders LazTarget => -
2010-03-11 14:44 Vincent Snijders Status new => resolved
2010-03-11 14:44 Vincent Snijders Resolution open => won't fix
2010-03-11 14:44 Vincent Snijders Assigned To => Vincent Snijders
2010-03-11 14:44 Vincent Snijders Note Added: 0035248
2011-12-01 11:23 Marc Weustink Status resolved => closed