View Issue Details

IDProjectCategoryView StatusLast Update
0015863LazarusDebuggerpublic2011-02-27 17:28
ReporterEric HeijnenAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSWindowsOS Version7
Product Version0.9.29 (SVN)Product Build23661 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0015863: Debugger specific settings are not saved
DescriptionChanging the debugger specific settings and then restarting lazarus has them set to the default.
Steps To Reproduceenvironment->options
go to debugger->general
fill in Debugger_startup_options and/or change the calling convention
Close lazarus, save if prompted
Start lazarus

environment->options
go to debugger->general
the changes are gone
Additional InformationMight also explain why debugger_startup_options are not passed on to gdb
TagsNo tags attached.
Fixed in Revision28997
LazTarget0.99.0
Widgetset
Attached Files

Relationships

related to 0018169 closedMarc Weustink Debugger_Startup_options are not saved persistent 

Activities

Eric Heijnen

2010-02-27 21:59

reporter   ~0034841

Last edited: 2010-02-27 23:45

Ignore the debugger_startup_options comment, because gdb keeps running on the background after the first launch, any modification after wouldn't make a difference.

Martin Friebe

2011-01-13 17:51

manager   ~0045150

Please test and close if ok.

Yes startup options are only applied, if the debugger is reset. (will need to look at, and restart on change...)

Issue History

Date Modified Username Field Change
2010-02-27 21:46 Eric Heijnen New Issue
2010-02-27 21:46 Eric Heijnen Status new => assigned
2010-02-27 21:46 Eric Heijnen Assigned To => Marc Weustink
2010-02-27 21:59 Eric Heijnen Note Added: 0034841
2010-02-27 23:45 Eric Heijnen Note Edited: 0034841
2010-12-19 20:19 Martin Friebe Relationship added related to 0018169
2011-01-13 17:44 Martin Friebe Assigned To Marc Weustink => Martin Friebe
2011-01-13 17:51 Martin Friebe Fixed in Revision => 28997
2011-01-13 17:51 Martin Friebe LazTarget => 0.99.0
2011-01-13 17:51 Martin Friebe Status assigned => resolved
2011-01-13 17:51 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-01-13 17:51 Martin Friebe Resolution open => fixed
2011-01-13 17:51 Martin Friebe Note Added: 0045150
2011-01-13 17:51 Martin Friebe Target Version => 0.99.1 (SVN)
2011-02-27 17:28 Eric Heijnen Status resolved => closed