View Issue Details

IDProjectCategoryView StatusLast Update
0015877LazarusWidgetsetpublic2011-12-01 11:23
ReporterAndrzej KałużaAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.28.2Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0015877: Access Vilation on Canvas.Draw WinCE
DescriptionHi,

This is my first application for wince.
On form.paint() method I draw on buffer (TBitmap) jpg image converted to bitmap and small png or bmp image with alpha channel made by GIMP.
Repaint is called by Timer (100, 150, 200 ms tested).
On different windows mobile 6.0 (128 RAM), 6.5 (128 RAM) on MS device emulator and wm 6.0 (64 RAM) on my pda (e-ten x800) raise access violation at Canvas.Draw(png) always after 107, 105 and 96 iterations. My pda after run this application and lapse of time - handgs, and I must trigger hard-reset. On device emulator not.
All devices are runing width 480x640 (vga) pixels.
I tested aplication on WinXP and it seems to be ok.

Application throws log into exception.txt at "current" patch.
Additional InformationI'w been search google, lazarus forum and bugtracket but i'm not found any solution.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWinCE
Attached Files

Relationships

related to 0015832 closedFelipe Monteiro de Carvalho Memory Leak for Alphablend in "StretchMaskBlt" (lclintfh.inc) Only in Arm-WinCE 

Activities

2010-03-01 22:46

 

bug.zip (780,909 bytes)

Andrzej Kałuża

2010-03-02 08:12

reporter   ~0034892

I have made more tests and ai'm sure on 90% that is e memory leak and touch images with alpha channel.

Andrzej Kałuża

2010-03-02 08:58

reporter   ~0034894

Strange... problem solved in 0015832

Issue History

Date Modified Username Field Change
2010-03-01 22:46 Andrzej Kałuża New Issue
2010-03-01 22:46 Andrzej Kałuża File Added: bug.zip
2010-03-01 22:46 Andrzej Kałuża Widgetset => WinCE
2010-03-02 08:12 Andrzej Kałuża Note Added: 0034892
2010-03-02 08:58 Andrzej Kałuża Note Added: 0034894
2010-03-08 14:32 Felipe Monteiro de Carvalho Status new => assigned
2010-03-08 14:32 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2010-05-01 14:38 Felipe Monteiro de Carvalho Relationship added related to 0015832
2010-05-01 14:38 Felipe Monteiro de Carvalho LazTarget => -
2010-05-01 14:38 Felipe Monteiro de Carvalho Status assigned => resolved
2010-05-01 14:38 Felipe Monteiro de Carvalho Fixed in Version => 0.9.29 (SVN)
2010-05-01 14:38 Felipe Monteiro de Carvalho Resolution open => fixed
2011-12-01 11:23 Marc Weustink Status resolved => closed