View Issue Details

IDProjectCategoryView StatusLast Update
0015943LazarusWidgetsetpublic2010-03-10 15:50
ReporterSpongeBobAssigned ToDmitry Boyarintsev 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.30 
Summary0015943: Carbon: Relative to absolute mouse coordinates translation error; controls not clickable
DescriptionCarbon/Mac

TPopupMenu assigned to a form pops out on wrong position. Also TSpeedButton dropped onto the form is not clickable. Possibly many other controls are affected with wrong mouse coordinates translation.

Additional InformationIf you move the form to the upper-left corner, then you can click on TSpeedButton and popup menu popups out where it should. It looks like Form.Left and Form.Top were not added to mouse coordinates during translation. As debugger on Mac is supper buggy it was not possible to trace the code which causes the error.

If you place TSpeedButton into a TPanel, then it works like expected. Also TPopupMenu pops out correctly on TPanel.

This was tested on Mac OS X 10.5.5 Intel.
TagsNo tags attached.
Fixed in Revision23917
LazTarget0.9.30
WidgetsetCarbon
Attached Files

Activities

Dmitry Boyarintsev

2010-03-10 13:52

developer   ~0035176

please test and close if ok

SpongeBob

2010-03-10 15:49

reporter   ~0035181

It's fixed. Thank you.

Issue History

Date Modified Username Field Change
2010-03-10 08:02 SpongeBob New Issue
2010-03-10 08:02 SpongeBob Widgetset => Carbon
2010-03-10 12:58 Dmitry Boyarintsev Status new => assigned
2010-03-10 12:58 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2010-03-10 13:52 Dmitry Boyarintsev Fixed in Revision => 23917
2010-03-10 13:52 Dmitry Boyarintsev LazTarget => 0.9.30
2010-03-10 13:52 Dmitry Boyarintsev Status assigned => resolved
2010-03-10 13:52 Dmitry Boyarintsev Fixed in Version => 0.9.30
2010-03-10 13:52 Dmitry Boyarintsev Resolution open => fixed
2010-03-10 13:52 Dmitry Boyarintsev Note Added: 0035176
2010-03-10 15:49 SpongeBob Note Added: 0035181
2010-03-10 15:50 SpongeBob Status resolved => closed