View Issue Details

IDProjectCategoryView StatusLast Update
0015945LazarusWidgetsetpublic2011-12-01 11:23
ReporterzariqAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0015945: Position of Tlabel wrong at runtime in wince.
DescriptionWhen a program with Tlabels on it is executed on windows mobile emulator or a phone with windows mobile, all the labels are situated at the top left hand corner of the parent. It's not possible to change the positions during program execution by setting left and right properties. Some other issues are

# Cannot change the caption at runtime.
# If you change the font size, then not all the text is visible.
# If you change the caption and then change the font size then I think the caption is changed but can't tell what it has changed to.

# If the font size is set in the properties editor then cannot change caption or font color or probably anything else at runtime. Font color can be changed during execution if font size is not altered in the properties editor.
Additional InformationThis is happening in lazarus 0.9.29 revision 23844 f.p.c. 2.4.1 and lazarus 0.9.29 revision 23908 f.p.c 2.4.0

It worked fine in o.9.28.2

Sorry if this has been reported allready but I didn't see anything exactly the same while searching the issues.

Everything was happening as describeb above until set the font size property from the property editor and now I can't get it to change anything during runtime on the 0.9.29 versions. Setting the font size from the property editor
didn't have this effect the first few times. Have uninstalled and reinstalled both versions twice without change. Have included test program anyway.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWinCE
Attached Files

Relationships

related to 0015654 closedFelipe Monteiro de Carvalho WinCE align not working for Timage 
related to 0015424 closedFelipe Monteiro de Carvalho TLabel 
related to 0014760 closedFelipe Monteiro de Carvalho TGroupBox in WinCE: Displacement of child controls / TLabel not visible 

Activities

2010-03-10 10:38

 

tlabeltest.zip (129,366 bytes)

Felipe Monteiro de Carvalho

2010-03-10 13:04

developer   ~0035171

Inside a Form too, or only inside a PageControl, or group box or something similar?

zariq

2010-03-10 21:53

reporter   ~0035205

Last edited: 2010-03-10 22:00

Just tested again on a form, inside a panel and a groupbox. Label behaved as described originally when some things could be changed but with results not as intended.

Felipe Monteiro de Carvalho

2010-03-11 17:25

developer   ~0035272

Could you test with Lazarus 0.9.28.2 and FPC 2.4.0?

You can install both 0.9.28.2 and the latest snapshot and then open 0.9.28.2 and change the compiler path to use the compiler from the snapshot, rebuild your LCL for wince-wince-arm and rebuild your test application.

zariq

2010-03-11 20:23

reporter   ~0035285

About six months ago I had a quick look at the instructions for rebuilding and installing mutiple versions on the wiki but the process seemed too long and complicated for something I didn't really need at the time therefore I didnt't take it any further. To do what you suggest I will need to have a good look at the instructions again. If I manage to get it working then I will post it later.

Paul van Helden

2010-03-12 16:26

reporter   ~0035360

I'm getting the same with TSpeedButtons in a panel. They are all placed at 0,0.

Also tested with Lazarus 0.9.28.2 with compiler changed to 2.4.1 snapshot. That works as before.

Adibe

2010-03-12 16:32

reporter   ~0035363

Maybe this is the same problem , like in 15654 from SVN 23137.

zariq

2010-03-13 08:35

reporter   ~0035430

tried 0.9.28.2 with 2.4.0-20100310 and 2.4.1-20100313. Both not working for me.

Felipe Monteiro de Carvalho

2010-04-26 11:05

developer   ~0037019

This bug has multiple parts, AFAIK the first part:

> When a program with Tlabels on it is executed on windows mobile emulator or a phone with windows mobile, all the labels are situated at the top left hand corner of the parent.

Was already solved.

So what is left is Label updating to be fixed.

Felipe Monteiro de Carvalho

2010-04-26 11:41

developer   ~0037021

And the Label updating is almost fixed too (in the mean time, somehow)

Felipe Monteiro de Carvalho

2010-05-21 06:08

developer   ~0037833

I searched for further fixes for the test program but none were necessary, so I consider the bug fixed.

Note that the first time the button is pressed and the second one produce different positions, because (copyed from Mattias):


unit1.lfm:

object Form1: TForm1
 Left = 290
 Height = 320
 Top = 175
 Width = 240
 ClientHeight = 320
 ClientWidth = 240
 object Label1: TLabel
   Left = 86
   Height = 14
   Top = 64
   Width = 32
   Anchors = []
   Caption = 'Label1'
 end

Label1 is center anchored horizontally and vertically.
And Label1.AutoSize defaults to true.

...

> label1.Height := 30;

Increasing the height moves the center down. The Label has
AutoSize=true, so the label height is restored to 18, resulting in a
move down:
x1=20,y1=106,x2=97,y2=124


> label1.font.size := 20;

Increasing the font size increases the automatic width and height. The
center is kept, so the Left,Top is reduced:
x1=-26,y1=99,x2=142,y2=132

Issue History

Date Modified Username Field Change
2010-03-10 10:38 zariq New Issue
2010-03-10 10:38 zariq File Added: tlabeltest.zip
2010-03-10 10:38 zariq Widgetset => WinCE
2010-03-10 12:57 Felipe Monteiro de Carvalho Status new => assigned
2010-03-10 12:57 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2010-03-10 13:04 Felipe Monteiro de Carvalho Note Added: 0035171
2010-03-10 21:53 zariq Note Added: 0035205
2010-03-10 22:00 zariq Note Edited: 0035205
2010-03-11 17:25 Felipe Monteiro de Carvalho LazTarget => -
2010-03-11 17:25 Felipe Monteiro de Carvalho Note Added: 0035272
2010-03-11 17:25 Felipe Monteiro de Carvalho Status assigned => feedback
2010-03-11 20:23 zariq Note Added: 0035285
2010-03-12 16:26 Paul van Helden Note Added: 0035360
2010-03-12 16:32 Adibe Note Added: 0035363
2010-03-13 08:35 zariq Note Added: 0035430
2010-03-15 15:16 Felipe Monteiro de Carvalho Relationship added related to 0015654
2010-04-26 10:53 Felipe Monteiro de Carvalho Relationship added related to 0015424
2010-04-26 11:05 Felipe Monteiro de Carvalho Note Added: 0037019
2010-04-26 11:37 Felipe Monteiro de Carvalho Relationship added related to 0014760
2010-04-26 11:41 Felipe Monteiro de Carvalho Note Added: 0037021
2010-05-05 15:47 Felipe Monteiro de Carvalho Status feedback => confirmed
2010-05-05 15:51 Felipe Monteiro de Carvalho Project Lazarus => FPC
2010-05-05 15:52 Felipe Monteiro de Carvalho Project FPC => Lazarus
2010-05-21 06:08 Felipe Monteiro de Carvalho Status confirmed => resolved
2010-05-21 06:08 Felipe Monteiro de Carvalho Fixed in Version => 0.9.29 (SVN)
2010-05-21 06:08 Felipe Monteiro de Carvalho Resolution open => fixed
2010-05-21 06:08 Felipe Monteiro de Carvalho Note Added: 0037833
2011-12-01 11:23 Marc Weustink Status resolved => closed