View Issue Details

IDProjectCategoryView StatusLast Update
0015974LazarusIDEpublic2020-04-10 12:21
ReporterSven Barth Assigned ToJuha Manninen  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version0.9.28.2 
Summary0015974: CodeExplorer should display all used units in uses sections
DescriptionCodeExplorer should display a list of used units below "Uses Section" (for Interface and Implementation section respectively). Clicking on a unit should move the cursor to the unit's declaration in the uses clause.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0015975 acknowledged CodeExplorer: Show uses sections as "Interface" and "Implementation" instead of "Uses Section" 

Activities

Sven Barth

2012-01-08 14:14

manager   ~0055584

This seems to be mostly implemented now in 0.9.31. The only thing is that now it's not easily recognizeable whether a unit is used in the "interface" or the "implementation" section...

Regards,
Sven

Juha Manninen

2020-03-30 18:50

developer   ~0121771

I resolve this now and leave the related issue open.

Sven Barth

2020-04-10 12:21

manager   ~0122059

Fair enough :)

Issue History

Date Modified Username Field Change
2010-03-12 14:46 Sven Barth New Issue
2010-03-12 16:18 Vincent Snijders LazTarget => -
2010-03-12 16:18 Vincent Snijders Status new => acknowledged
2010-12-20 15:37 Juha Manninen Relationship added related to 0015975
2012-01-08 14:14 Sven Barth Note Added: 0055584
2012-02-04 11:10 Zeljan Rikalo LazTarget - => 1.2
2014-01-14 15:16 Martin Friebe LazTarget 1.2 => 1.4
2015-04-27 21:59 Juha Manninen LazTarget 1.4 => -
2020-03-30 18:50 Juha Manninen Assigned To => Juha Manninen
2020-03-30 18:50 Juha Manninen Status acknowledged => resolved
2020-03-30 18:50 Juha Manninen Resolution open => fixed
2020-03-30 18:50 Juha Manninen Note Added: 0121771
2020-04-10 12:21 Sven Barth Status resolved => closed
2020-04-10 12:21 Sven Barth Note Added: 0122059