View Issue Details

IDProjectCategoryView StatusLast Update
0000016Lazaruspublic2000-08-11 12:34
ReporterBug ImportAssigned ToShane 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0000016: Typing in the editor. Sometimes the SHIFT is ignored
DescriptionWhen typing quickly, it appears that the SHIFT key will be ignored when typing quickly. If you type your name and capitalize it, it appears we check to see what key was pressed, then check to see if the SHIFT key is down. By that time it's no longer down. This needs to be fixed...
Additional InformationImported information
--------------------
Name: Shane Miller
Mail: smiller (at) lakefield.net
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2000-08-11 12:34

reporter   ~0000015

The problem was that the key's were not being sent out on the PRESS event, they were being sent out on the RELEASE or UP event. So if you typed:

TButton1 you had to make sure you let the 'T' and the 'B' button up before the shift key. If you didn't then the message was sent AFTER the 'T' and 'B' button came up. The 'T' would be capitalized because you kept the Shift key down for the 'B', but the 'B' wouldn't because by the time the message was sent for the 'B' button up, the SHIFT key was already up.

Issue History

Date Modified Username Field Change
2000-08-07 00:00 Bug Import New Issue
2000-08-07 00:00 Bug Import Widgetset => GTK, Win32
2000-08-11 12:34 Bug Import Status new => assigned
2000-08-11 12:34 Bug Import Assigned To => Shane Miller
2000-08-11 12:34 Bug Import Note Added: 0000015
2000-08-11 12:34 Bug Import Status new => closed
2000-08-11 12:34 Bug Import Resolution open => fixed