View Issue Details

IDProjectCategoryView StatusLast Update
0016013LazarusLCLpublic2010-05-06 18:36
ReporterFlávio Etrusco Assigned ToMattias Gaertner  
PrioritynormalSeveritymajorReproducibilityN/A
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Target Version0.9.30 
Summary0016013: New AutoSize/AutoSizing bugs (meta-bug)
DescriptionMeta-bug to link to all bugs caused by NewAutoSize.
TagsNo tags attached.
Fixed in Revision
LazTarget0.9.30
WidgetsetGTK, GTK 2, Win32/Win64, WinCE, Carbon
Attached Files

Relationships

parent of 0015971 closedMattias Gaertner Lazarus IDE Starts "minimized" / strangely autosized  
parent of 0015993 closedMattias Gaertner Setting autosize = true on an empty form makes the IDE hang 
parent of 0015972 closedMattias Gaertner Division by Zero with latest svn 
parent of 0016010 closedMattias Gaertner The form "Find/Replace" is broken 
parent of 0016009 closedMattias Gaertner GTK2: New Autosizing completely breaks standard align behavior 
parent of 0015996 closedMattias Gaertner Resizing "Search Results" window freezes IDE after new autosize 
parent of 0015979 closedMattias Gaertner TRadioGroup and other components width/heigh messed up! 
parent of 0015973 closedMattias Gaertner Opening Environment -> Options crashes the IDE 
parent of 0016020 closedMattias Gaertner Pasting controls (4) inside an AutoSize Panel causes "Invalid Floating Point Operation" 
parent of 0016026 closedMattias Gaertner LCL: Child controls of TForm docked (parented) to TPageControl sized strangely 
parent of 0016028 closedMattias Gaertner Can't change TLabel at runtime 
parent of 0016037 closedMattias Gaertner Click to property Color (Object Inspector) causes crash (invalid floating point operation). 
parent of 0016048 closedMattias Gaertner "Main Menu" window does not use window position stored in the Options dialog. 
parent of 0016041 closedMattias Gaertner Main Menu window of IDE doesn't restore its geometry 
parent of 0016085 closedMattias Gaertner Lazarus hangs when opening my project's form 
parent of 0016104 closedMattias Gaertner Lazarus hangs when setting Align to a component on the Toolbar 
parent of 0016173 closedMattias Gaertner TLabel autosize does not work on Linux (both 32 and 64 bit versions). 
parent of 0016143 closedMattias Gaertner Lazarus resets the size of forms 
parent of 0016137 closedAlexander S. Klenin Labels on About form are sized incorrectly 
parent of 0016184 closedMattias Gaertner Top/Left of form still locating incorrectly 
parent of 0016192 closedMattias Gaertner New Autosize fails on re-parent 
parent of 0016194 closedMattias Gaertner Application hangs up on TToolBar resized 
parent of 0016202 closedMattias Gaertner AutoSized panels ignore InnerBorder (NewAutoSize) 
parent of 0016205 closedMattias Gaertner Lazarus' dialogs in snapshots aren't screen centered 
parent of 0016217 closedMattias Gaertner Some "third level" IDE dialog windows are opened at 0,0 screen position 
parent of 0016246 closedPaul Ishenin Edit Color property in Lazarus causes Div by zero 
parent of 0016250 closedMattias Gaertner TScrollBox.AutoScroll conflicts with Anchors 
related to 0015205 closedMattias Gaertner LCL AutoSizing bug 
related to 0016087 closedMattias Gaertner Setting top of the form fails change the size 

Activities

Vladimir Zhirov

2010-03-27 08:29

reporter   ~0036153

Since the number of child issues is growing it might worth to mention a workaround here for those who does not follow mailing list discussion.

In order to use old stable autosizing behaviour you can rebuild LCL and/or IDE with OldAutoSize defined.

When rebuilding from the IDE:
Tools - Configure "Build Lazarus" ... - Options edit box - "-dOldAutoSize"

When rebuilding from the command line
make OPT="-dOldAutoSize"

Issue History

Date Modified Username Field Change
2010-03-16 17:46 Flávio Etrusco New Issue
2010-03-16 17:46 Flávio Etrusco LazTarget => -
2010-03-16 17:46 Flávio Etrusco Widgetset => GTK, GTK 2, Win32/Win64, WinCE, Carbon
2010-03-16 17:46 Flávio Etrusco Relationship added child of 0015971
2010-03-16 17:48 Flávio Etrusco Relationship added child of 0015993
2010-03-16 17:49 Flávio Etrusco Relationship added child of 0015972
2010-03-16 17:49 Flávio Etrusco Summary New AutoSize/AutoSizing bug (metabug) => New AutoSize/AutoSizing bugs (meta-bug)
2010-03-16 17:50 Flávio Etrusco Relationship added child of 0016010
2010-03-16 17:50 Flávio Etrusco Relationship added child of 0016009
2010-03-16 19:02 Vincent Snijders Relationship replaced parent of 0015971
2010-03-16 19:02 Vincent Snijders LazTarget - => 0.9.30
2010-03-16 19:02 Vincent Snijders Assigned To => Mattias Gaertner
2010-03-16 19:02 Vincent Snijders Status new => assigned
2010-03-16 19:02 Vincent Snijders Target Version => 0.9.30
2010-03-16 19:17 Flávio Etrusco Relationship replaced child of 0015971
2010-03-16 19:23 Flávio Etrusco Relationship replaced parent of 0015971
2010-03-16 19:29 Flávio Etrusco Relationship replaced parent of 0015993
2010-03-16 19:30 Flávio Etrusco Relationship replaced parent of 0015972
2010-03-16 19:30 Flávio Etrusco Relationship replaced parent of 0016010
2010-03-16 19:30 Flávio Etrusco Relationship replaced parent of 0016009
2010-03-16 20:50 Flávio Etrusco Relationship added parent of 0015996
2010-03-16 20:50 Flávio Etrusco Relationship added parent of 0015979
2010-03-16 20:51 Flávio Etrusco Relationship added parent of 0015973
2010-03-17 08:18 Flávio Etrusco Relationship added parent of 0016020
2010-03-17 13:21 Vincent Snijders Relationship added parent of 0016026
2010-03-18 04:26 Flávio Etrusco Status assigned => resolved
2010-03-18 04:26 Flávio Etrusco Resolution open => fixed
2010-03-18 04:27 Flávio Etrusco Status resolved => assigned
2010-03-18 04:27 Flávio Etrusco Resolution fixed => reopened
2010-03-18 08:32 Vincent Snijders Relationship added parent of 0016028
2010-03-18 15:12 Mattias Gaertner Relationship added parent of 0016037
2010-03-19 14:42 Martin Friebe Relationship added parent of 0016048
2010-03-19 14:42 Martin Friebe Relationship added parent of 0016041
2010-03-23 14:30 Zeljan Rikalo Relationship added related to 0015205
2010-03-23 14:30 Zeljan Rikalo Relationship added related to 0016087
2010-03-27 04:48 Flávio Etrusco Relationship added parent of 0016085
2010-03-27 04:48 Flávio Etrusco Relationship added child of 0016104
2010-03-27 07:40 Flávio Etrusco Relationship replaced parent of 0016104
2010-03-27 08:29 Vladimir Zhirov Note Added: 0036153
2010-03-31 21:17 Flávio Etrusco Relationship added parent of 0016173
2010-04-01 01:16 Alexander S. Klenin Relationship added parent of 0016143
2010-04-04 05:58 Alexander S. Klenin Relationship added parent of 0016137
2010-04-04 09:49 Mattias Gaertner Relationship added parent of 0016184
2010-04-04 18:00 Martin Friebe Relationship added parent of 0016192
2010-04-04 22:50 Mattias Gaertner Relationship added parent of 0016194
2010-04-05 12:03 Flávio Etrusco Relationship added parent of 0016202
2010-04-06 10:23 Mattias Gaertner Relationship added parent of 0016205
2010-04-07 00:33 Martin Friebe Relationship added parent of 0016217
2010-04-13 00:44 Maxim Ganetsky Relationship added parent of 0016246
2010-04-22 23:38 Mattias Gaertner Status assigned => resolved
2010-04-22 23:38 Mattias Gaertner Resolution reopened => fixed
2010-04-29 15:23 Flávio Etrusco Relationship added child of 0016250
2010-04-29 15:24 Flávio Etrusco Relationship replaced parent of 0016250
2010-05-06 18:36 Flávio Etrusco Status resolved => closed