View Issue Details

IDProjectCategoryView StatusLast Update
0016045FPCPackagespublic2010-03-19 14:00
Reporterwovan.bugger Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformwin32 / win 64OSwindows 
Product Version2.5.1 
Summary0016045: TToolbar Issue
DescriptionI have ToolBar with ToolButton and PopupMenu with MenuItem with assigned onclick event. I set the MenuItem to the ToolButton's MenuItem property.
So under Win32, when i click the Toolbutton, no menuitem's onclick event fires up. no matter if it's an action assigned to.
I tested under w.s. GTK2 and it works properly. So it seems there is a bug ws win32's.

I use:
FPC 2.5.1
Laz 0.9.29, SVN 23820
on win 7 under w.s. win32/win64
Steps To Reproducecompile under ws win32/win64
Additional InformationI attached the source showing thah issue
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0016044 resolvedPaul Ishenin Lazarus TToolbar Issue 

Activities

2010-03-19 12:57

 

Toolbar_BUG.7z (60,356 bytes)

Marco van de Voort

2010-03-19 14:00

manager   ~0035801

Closed as duplicate of 16044, which has been moved to the Lazarus part of the repository.

Issue History

Date Modified Username Field Change
2010-03-19 12:57 wovan.bugger New Issue
2010-03-19 12:57 wovan.bugger File Added: Toolbar_BUG.7z
2010-03-19 13:59 Marco van de Voort Relationship added duplicate of 0016044
2010-03-19 14:00 Marco van de Voort Status new => closed
2010-03-19 14:00 Marco van de Voort Note Added: 0035801
2010-03-19 14:00 Marco van de Voort Resolution open => duplicate