View Issue Details

IDProjectCategoryView StatusLast Update
0016082LazarusIDEpublic2011-04-09 07:54
ReporterFlávio Etrusco (notifications not working)Assigned ToVincent Snijders 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.30 
Summary0016082: File changes (on disk, i.e. from another app) detection failure/aren't always detected
DescriptionWhat works:
1) Open Lazarus with a project.
2) Change one of the files outside Lazarus.
3) Focus Lazarus back and the file change gets detected.
In step 1) you can make some modification and the notification will work just the same.


What does not work:
1) Open Lazarus with a project.
2) Make several modifications, undo one of them.
3) Change one of the files outside Lazarus.
4) Focus Lazarus back and the file change doesn't get detected.
Now I don't know whether this is by-design, but there's more:
5) Undo all changes in Lazarus.
6) Make an external modification.
7) Focus Lazarus and changes still don't get noticed.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Zeljan Rikalo

2010-05-26 10:26

developer   ~0037999

What ws ?

Flávio Etrusco (notifications not working)

2010-05-26 17:43

developer   ~0038023

Last edited: 2010-05-26 17:49

GTK2 2.20.0 (Ubuntu 10.04).
(PS. I still didn't try reproduce it recently)

Zeljan Rikalo

2010-05-26 18:47

developer   ~0038025

Please try, since I've changed OnActivate() OnDeactivate() behaviour under gtk2 few weeks ago, and I cannot reproduce problem here.

Vincent Snijders

2010-11-30 10:36

manager   ~0043777

No feedback from reporter. Probably fixed in the meantime.

Issue History

Date Modified Username Field Change
2010-03-23 00:20 Flávio Etrusco (notifications not working) New Issue
2010-03-23 00:20 Flávio Etrusco (notifications not working) LazTarget => -
2010-05-26 10:26 Zeljan Rikalo Note Added: 0037999
2010-05-26 17:43 Flávio Etrusco (notifications not working) Note Added: 0038023
2010-05-26 17:49 Flávio Etrusco (notifications not working) Note Edited: 0038023
2010-05-26 18:47 Zeljan Rikalo Note Added: 0038025
2010-10-29 14:33 Vincent Snijders Status new => feedback
2010-11-30 10:36 Vincent Snijders Status feedback => resolved
2010-11-30 10:36 Vincent Snijders Resolution open => fixed
2010-11-30 10:36 Vincent Snijders Assigned To => Vincent Snijders
2010-11-30 10:36 Vincent Snijders Note Added: 0043777
2011-04-09 07:54 Flávio Etrusco (notifications not working) Status resolved => closed
2011-04-09 07:54 Flávio Etrusco (notifications not working) Fixed in Version => 0.9.30
2011-04-09 07:54 Flávio Etrusco (notifications not working) Target Version => 0.9.30