View Issue Details

IDProjectCategoryView StatusLast Update
0016086Lazarus-public2010-03-25 13:40
ReporterMario Bonati Assigned ToPaul Ishenin  
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows XP 
Product Version0.9.29 (SVN) 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0016086: Problem whein i paste from Clipboard (regression)
DescriptionSee this code:

//////////////////////////BEGIN///////////////////////
procedure TForm1.Button1Click(Sender: TObject);
var Pippo, Pippo1:String;
begin
  Pippo:='Prova';
  Clipboard.AsText:=Pippo;

  InputQuery('Ricerca nell''albero','Digita la stringa da cercare:', Pippo1);
end;
//////////////////////////END///////////////////////

When InputQuery is showed and i paste from clipboard, the value of the InputQuery is "ProvaProva" instead of "Prova"
TagsNo tags attached.
Fixed in Revision24206
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Activities

Tomasz Wieckowski

2010-03-23 14:40

reporter   ~0035977

I can't reproduce on Linux (gtk2). Only on Windows.

Martin Friebe

2010-03-23 17:30

manager   ~0035986

on windows this is a regression, it happens within lazarus-ide itself too.
Clipboard content is always pasted twice into edit boxes, memos, ....

Martin Friebe

2010-03-24 15:52

manager   ~0036033

This was introduced in revision
Revision: 24144
Author: paul
Date: 14:21:04, 21 March 2010
Message:
win32: don't block win32 messages in the default handler - let's pass them to windows
----
Modified : /trunk/lcl/interfaces/win32/win32winapi.inc

Paul Ishenin

2010-03-25 08:21

manager   ~0036059

Sorry, my fault. Revision is reverted. Please close if ok.

Mario Bonati

2010-03-25 13:40

reporter   ~0036074

I've tried now and it's Ok

Thanks, Mario

Issue History

Date Modified Username Field Change
2010-03-23 10:15 Mario Bonati New Issue
2010-03-23 10:15 Mario Bonati Widgetset => Win32/Win64
2010-03-23 14:40 Tomasz Wieckowski Note Added: 0035977
2010-03-23 17:30 Martin Friebe LazTarget => 0.9.30
2010-03-23 17:30 Martin Friebe Note Added: 0035986
2010-03-23 17:30 Martin Friebe Priority normal => urgent
2010-03-23 17:30 Martin Friebe Status new => confirmed
2010-03-23 17:30 Martin Friebe Target Version => 0.9.30
2010-03-23 17:30 Martin Friebe Summary Problem whein i paste from Clipboard => Problem whein i paste from Clipboard (regression)
2010-03-24 15:51 Martin Friebe Status confirmed => assigned
2010-03-24 15:51 Martin Friebe Assigned To => Paul Ishenin
2010-03-24 15:52 Martin Friebe Note Added: 0036033
2010-03-25 08:21 Paul Ishenin Fixed in Revision => 24206
2010-03-25 08:21 Paul Ishenin Status assigned => resolved
2010-03-25 08:21 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-03-25 08:21 Paul Ishenin Resolution open => fixed
2010-03-25 08:21 Paul Ishenin Note Added: 0036059
2010-03-25 13:40 Mario Bonati Status resolved => closed
2010-03-25 13:40 Mario Bonati Note Added: 0036074