View Issue Details

IDProjectCategoryView StatusLast Update
0016123LazarusIDEpublic2010-03-27 09:25
Reportersamuel herzog Assigned ToMattias Gaertner  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformwin32OSxp 
Product Version0.9.29 (SVN) 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0016123: New Project generates invalid code.
DescriptionCould please someone confirm this problem ?
I am not sure if just something got mixed up on my laptop or if
it is a real issue/regression ?
Steps To Reproduce1.) start lazarus. (SVN 24235)
2.) choose "Project" -> "New Project" ->"Application".
3.) press F9 to run.

This fails on my machine.

If you look at the generate project code, then you will see that there is a misplacement of the semicolon.
Additional Informationprogram Project1;

{$mode objfpc}{$H+}

uses
  {$IFDEF UNIX}{$IFDEF UseCThreads}
  cthreads,
  {$ENDIF}{$ENDIF}
  Interfaces, // this includes the LCL widgetset
  Forms,Unit1
  { you can add units after this };

{$R *.res}

begin
  Application.Initialize
  Application.CreateForm(TForm1,Form1);
  ;
  Application.Run;
end.
TagsNo tags attached.
Fixed in Revision
LazTarget0.9.30
Widgetset
Attached Files

Activities

Flávio Etrusco

2010-03-27 04:09

developer   ~0036149

I confirm the problem.

samuel herzog

2010-03-27 04:18

developer   ~0036150

At the moment I can only say the problem was introduced somewhere between revision 24220 and 24229.

Vincent Snijders

2010-03-27 08:33

manager   ~0036154

Probably caused by
http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&root=lazarus&revision=24221

samuel herzog

2010-03-27 08:35

developer   ~0036155

Last edited: 2010-03-27 08:35

The problem was introduced by 24225. Changes in BasicCodeTools.

samuel herzog

2010-03-27 09:25

developer   ~0036156

Fixed now. Thank you.

Issue History

Date Modified Username Field Change
2010-03-27 03:22 samuel herzog New Issue
2010-03-27 03:22 samuel herzog LazTarget => -
2010-03-27 04:09 Flávio Etrusco Note Added: 0036149
2010-03-27 04:18 samuel herzog LazTarget - => 0.9.30
2010-03-27 04:18 samuel herzog Note Added: 0036150
2010-03-27 04:18 samuel herzog Status new => confirmed
2010-03-27 08:18 samuel herzog Summary New Project does generates invalid code. => New Project generates invalid code.
2010-03-27 08:33 Vincent Snijders Note Added: 0036154
2010-03-27 08:33 Vincent Snijders Assigned To => Mattias Gaertner
2010-03-27 08:33 Vincent Snijders Status confirmed => assigned
2010-03-27 08:35 samuel herzog Note Added: 0036155
2010-03-27 08:35 samuel herzog Note Edited: 0036155
2010-03-27 09:09 Mattias Gaertner Status assigned => resolved
2010-03-27 09:09 Mattias Gaertner Resolution open => fixed
2010-03-27 09:25 samuel herzog Status resolved => closed
2010-03-27 09:25 samuel herzog Note Added: 0036156
2010-03-27 09:25 samuel herzog Fixed in Version => 0.9.29 (SVN)