View Issue Details

IDProjectCategoryView StatusLast Update
0016141LazarusLCLpublic2010-04-19 20:01
ReporterJuha Manninen Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Fixed in Version0.9.29 (SVN) 
Summary0016141: TBevel.Shape does not support bsSpacer
DescriptionThis is mostly for Delphi compatibility. It came up when testing Delphi converter.
TagsNo tags attached.
Fixed in Revision24720
LazTarget0.9.30
Widgetset
Attached Files

Activities

2010-03-31 13:36

 

bevel.patch (831 bytes)   
Index: lcl/extctrls.pp
===================================================================
--- lcl/extctrls.pp	(revision 24310)
+++ lcl/extctrls.pp	(working copy)
@@ -684,7 +684,8 @@
   { TBevel }
 
   TBevelStyle = (bsLowered, bsRaised);
-  TBevelShape=(bsBox, bsFrame, bsTopLine, bsBottomLine, bsLeftLine, bsRightLine);
+  TBevelShape=(bsBox, bsFrame, bsTopLine, bsBottomLine, bsLeftLine, bsRightLine,
+               bsSpacer);
 
   TBevel = Class(TGraphicControl)
   private
Index: lcl/include/bevel.inc
===================================================================
--- lcl/include/bevel.inc	(revision 24310)
+++ lcl/include/bevel.inc	(working copy)
@@ -168,6 +168,7 @@
       MoveTo(ALeft + AWidth - 2, ATop);
       LineTo(ALeft + AWidth - 2, ATop + AHeight);
     End;
+    bsSpacer: ;
   End;
   
   inherited Paint;
bevel.patch (831 bytes)   

Juha Manninen

2010-03-31 13:38

developer   ~0036320

Uploaded a patch to implement bsSpacer. It was easy because bsSpacer is empty, no drawing is needed.
Someone please apply.

Paul Ishenin

2010-04-19 14:05

manager   ~0036825

Thanks, applied. Please close if ok.

Juha Manninen

2010-04-19 20:01

developer   ~0036833

Closing...

Issue History

Date Modified Username Field Change
2010-03-29 14:46 Juha Manninen New Issue
2010-03-29 14:46 Juha Manninen LazTarget => -
2010-03-31 13:36 Juha Manninen File Added: bevel.patch
2010-03-31 13:38 Juha Manninen Note Added: 0036320
2010-03-31 14:04 Zeljan Rikalo LazTarget - => 0.9.30
2010-04-19 14:05 Paul Ishenin Fixed in Revision => 24720
2010-04-19 14:05 Paul Ishenin Status new => resolved
2010-04-19 14:05 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-04-19 14:05 Paul Ishenin Resolution open => fixed
2010-04-19 14:05 Paul Ishenin Assigned To => Paul Ishenin
2010-04-19 14:05 Paul Ishenin Note Added: 0036825
2010-04-19 20:01 Juha Manninen Status resolved => closed
2010-04-19 20:01 Juha Manninen Note Added: 0036833