View Issue Details

IDProjectCategoryView StatusLast Update
0016148LazarusDebuggerpublic2010-04-16 21:51
ReporterFlávio Etrusco Assigned ToMarc Weustink  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Fixed in Version0.9.29 (SVN) 
Summary0016148: [Patch] Initial Debugger Events dialog, to show relevant debugger events
DescriptionCreate a new TDbgOutputForm to output relevant debugger events.
Additional InformationFor now the dialog is pretty limited, simply a TDbgOutputForm with whole gdb output lines.

Currently the events put there include libraries load/unload, thread created/exited and file loaded with no debug info.

The events redirected to this form aren't DebugLn'ed; the main reason for this patch is to cleanup the output of DebugLn messages (thus easing debugging of the debugger).

The patch also replaces TMemo with TSynEdit in TDbgOutputForm (because it's much faster).

Currently the limit of stored events when the form is hidden is 1000, Debugger Output is 100. IMHO both should be increased.
TagsNo tags attached.
Fixed in Revision24577
LazTarget0.9.30
Widgetset
Attached Files

Activities

2010-03-30 08:00

 

Flávio Etrusco

2010-03-30 08:21

developer   ~0036262

Last edited: 2010-03-30 08:22

Patch is missing add nmiwDbgEvents to NonModalIDEWindowManualOpen, in ide/ideoptiondefs.pas.
Shoot. I swear I checked the patch was correctly refreshed :-/

Flávio Etrusco

2010-04-05 10:50

developer   ~0036451

Last edited: 2010-04-05 11:26

Updated patch.
Comments:
1) scroll behavior when changing filters is dumb.
2) there's some code in DebugEventForm to cope with changes in the TDBGEventCategory enumeration. If enumeration order is meant to me immutable than the code is useless (and should be removed)...
3) Patch doesn't use OwnerData because performance seems good enough with normal ListView. I had an implementation using OwnerData but managed somehow to lose the whole form :-/

Paul Ishenin

2010-04-05 11:02

manager   ~0036453

Why the log is limited? Look at debugger options - there are options:

a. to clear log on run
b. to limit log to paticular line count and to skip limits

2010-04-05 11:19

 

2010-04-05 11:21

 

debugeventsform.pp (6,235 bytes)

2010-04-05 11:21

 

debugeventsform.lfm (17,424 bytes)

Flávio Etrusco

2010-04-05 11:22

developer   ~0036454

Paul: I hadn't seem the options dialog previously, later I've seem it and current patch obeys it.

Flávio Etrusco

2010-04-05 11:31

developer   ~0036455

Creatig patches which add files with svn is not funny. I don't know whether 'svn revert' doesn't un-add files or whether I had some old files dangling in my svn sandbox (I use it only to create patches) - svn doesn't help me clear it anyway :( -, but I scratched my head for one hour trying to figure out why my script was generating an obsolete patch :-/

Marc Weustink

2010-04-11 16:12

administrator   ~0036623

Thanks. Applied with minor changes

Issue History

Date Modified Username Field Change
2010-03-30 08:00 Flávio Etrusco New Issue
2010-03-30 08:00 Flávio Etrusco Status new => assigned
2010-03-30 08:00 Flávio Etrusco Assigned To => Marc Weustink
2010-03-30 08:00 Flávio Etrusco File Added: dbg_event_viewer.r24290M.svndiff
2010-03-30 08:00 Flávio Etrusco LazTarget => -
2010-03-30 08:21 Flávio Etrusco Note Added: 0036262
2010-03-30 08:22 Flávio Etrusco Note Edited: 0036262
2010-04-05 10:50 Flávio Etrusco Note Added: 0036451
2010-04-05 11:02 Paul Ishenin Note Added: 0036453
2010-04-05 11:19 Flávio Etrusco File Added: debugger_event_log.r24427M.svndiff
2010-04-05 11:21 Flávio Etrusco File Added: debugeventsform.pp
2010-04-05 11:21 Flávio Etrusco File Added: debugeventsform.lfm
2010-04-05 11:22 Flávio Etrusco Note Added: 0036454
2010-04-05 11:26 Flávio Etrusco Note Edited: 0036451
2010-04-05 11:31 Flávio Etrusco Note Added: 0036455
2010-04-07 07:35 Flávio Etrusco LazTarget - => 0.9.30
2010-04-11 16:12 Marc Weustink Fixed in Revision => 24577
2010-04-11 16:12 Marc Weustink Status assigned => resolved
2010-04-11 16:12 Marc Weustink Fixed in Version => 0.9.29 (SVN)
2010-04-11 16:12 Marc Weustink Resolution open => fixed
2010-04-11 16:12 Marc Weustink Note Added: 0036623
2010-04-16 21:51 Flávio Etrusco Status resolved => closed