View Issue Details

IDProjectCategoryView StatusLast Update
0016209LazarusIDEpublic2010-04-17 19:36
ReporterFlávio Etrusco (notifications not working)Assigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.30 
Summary0016209: [patch] CodeTools/SourceChanger: avoid change of text/identifiers/kewords in comments
Description
=== (+2,-2) components/codetools/sourcechanger.pas ===
@@ -1062,7 +1062,7 @@
   //DebugLn('[TBeautifyCodeOptions.AddAtom]  NewAtom=',NewAtom,' s="',s,'"');
 
   // beautify identifier
-  if IsIdentStartChar[NewAtom[1]] then begin
+  if IsIdentStartChar[NewAtom[1]] and (CommentLvl = 0) then begin
     if AllKeyWords.DoItCaseInsensitive(NewAtom) then
       NewAtom:=BeautifyWord(NewAtom,KeyWordPolicy)
     else
Tagshas_patch, patch
Fixed in Revision
LazTarget0.9.30
WidgetsetGTK, GTK 2, Win32/Win64, WinCE, Carbon, QT, fpGUI
Attached Files

Relationships

related to 0016211 closedMattias Gaertner [patch] Packager: re-generating packages change case of registration unit 

Activities

Alexander S. Klenin

2010-04-06 11:23

developer   ~0036491

Hm, would not this make problems like issue 0013497 worse?
Define 'worse' ;-)
AFAICS they are not related, since that function only change formatting of the token. If someone changes the capitalization rule for Identifiers, well, then this change could make the comment not follow the rule.
That other issue seems to needs a completely different (and more complex) change, and would force the capitalization rules on its own.

Issue History

Date Modified Username Field Change
2010-04-06 09:34 Flávio Etrusco (notifications not working) New Issue
2010-04-06 09:34 Flávio Etrusco (notifications not working) LazTarget => -
2010-04-06 09:34 Flávio Etrusco (notifications not working) Widgetset => GTK, GTK 2, Win32/Win64, WinCE, Carbon, QT, fpGUI
2010-04-06 09:38 Flávio Etrusco (notifications not working) Summary [patch] Avoid change of text/identifiers/kewords in comments => [patch] CodeTools/SourceChanger: avoid change of text/identifiers/kewords in comments
2010-04-06 09:38 Flávio Etrusco (notifications not working) Tag Attached: has_patch
2010-04-06 09:38 Flávio Etrusco (notifications not working) Tag Attached: patch
2010-04-06 09:59 Flávio Etrusco (notifications not working) Product Version => 0.9.29 (SVN)
2010-04-06 10:00 Flávio Etrusco (notifications not working) LazTarget - => 0.9.30
2010-04-06 10:00 Flávio Etrusco (notifications not working) Status new => acknowledged
2010-04-06 10:13 Flávio Etrusco (notifications not working) Relationship added related to 0016211
2010-04-06 11:23 Alexander S. Klenin Note Added: 0036491
2010-04-06 11:49 Flávio Etrusco (notifications not working) Note Added: 0036493
2010-04-16 21:38 Flávio Etrusco (notifications not working) Status acknowledged => assigned
2010-04-16 21:38 Flávio Etrusco (notifications not working) Assigned To => Mattias Gaertner
2010-04-16 21:54 Flávio Etrusco (notifications not working) Assigned To Mattias Gaertner =>
2010-04-16 21:54 Flávio Etrusco (notifications not working) Status assigned => new
2010-04-17 17:05 Mattias Gaertner Assigned To => Mattias Gaertner
2010-04-17 17:05 Mattias Gaertner Status new => resolved
2010-04-17 17:05 Mattias Gaertner Resolution open => fixed
2010-04-17 19:36 Flávio Etrusco (notifications not working) Status resolved => closed
2010-04-17 19:36 Flávio Etrusco (notifications not working) Fixed in Version => 0.9.30