View Issue Details

IDProjectCategoryView StatusLast Update
0016246LazarusIDEpublic2010-04-17 06:50
ReporterTeemu ValoAssigned ToPaul Ishenin 
PrioritynormalSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
PlatformWin32OSWindows XPOS VersionSP2
Product VersionProduct BuildLazarus SVN 24550 
Target Version0.9.30Fixed in Version0.9.30 
Summary0016246: Edit Color property in Lazarus causes Div by zero
DescriptionClicking Color property of objects cause div by zero crash error. If i click to ignore the error and continue in IDE the problem doesn't appear anymore and color list and dialog comes up nicely.
Steps To ReproduceStart Lazarus and make a new empty application, click form's Color property. This causes division by zero which wants to crash the IDE.

I tried to find the limits to this error so i tried font.color etc. "Some" don't seem to give the error but form always does, that 1 time. If i happen to get color property clicked properly once from other object then even form doesn't give error.
Additional InformationThis only appeared after installing latest Lazarus daily snapshot.
TagsNo tags attached.
Fixed in Revision24636
LazTarget0.9.30
Widgetset
Attached Files
  • bt.txt (3,123 bytes)
    Program received signal SIGFPE, Arithmetic exception.
    0x00426f12 in RAISEGDBEXCEPTION (MSG=0x0) at lclproc.pas:1505
    1505      if (length(Msg) div (length(Msg) div 10000))=0 then ;
    (gdb) bt
    #0  0x00426f12 in RAISEGDBEXCEPTION (MSG=0x0) at lclproc.pas:1505
    #1  0x00526ea4 in TWINCONTROL__CREATEWND (this=0x98a8f80)
        at ./include/wincontrol.inc:7078
    #2  0x00526d25 in TWINCONTROL__CREATEHANDLE (this=0x98a8f80)
        at ./include/wincontrol.inc:7030
    #3  0x00527e1a in TWINCONTROL__HANDLENEEDED (this=0x98a8f80)
        at ./include/wincontrol.inc:7516
    #4  0x00525e31 in TWINCONTROL__GETHANDLE (this=0x98a8f80)
        at ./include/wincontrol.inc:6276
    #5  0x00528c77 in TWINCONTROL__GETDEVICECONTEXT (WINDOWHANDLE=0,
        this=0x98a8f80) at ./include/wincontrol.inc:7935
    #6  0x00519ba2 in TCONTROLCANVAS__CREATEHANDLE (this=0xd9e90)
        at ./include/controlcanvas.inc:90
    #7  0x004b6de6 in TCANVAS__REQUIREDSTATE (
        REQSTATE=[CSHANDLEVALID..CSFONTVALID], this=0xd9e90)
        at ./include/canvas.inc:1564
    #8  0x004b7020 in TCANVAS__TEXTEXTENT (TEXT=0xcb54b0 'Fj', this=0xd9e90,
        result={CX = 0, CY = 0}) at ./include/canvas.inc:1624
    #9  0x004b70b3 in TCANVAS__TEXTHEIGHT (TEXT=0xcb54b0 'Fj', this=0xd9e90)
        at ./include/canvas.inc:1649
    #10 0x00663820 in TPROPERTYEDITOR__LISTMEASUREHEIGHT (AVALUE=0xcb54b0 'Fj',
        INDEX=-1, ACANVAS=0xd9e90, AHEIGHT=15, this=0xa00a090)
        at propedits.pp:2766
    #11 0x0064b157 in TOICUSTOMPROPERTYGRID__VALUECOMBOBOXMEASUREITEM (
        CONTROL=0x98a8f80, INDEX=-1, AHEIGHT=15, this=0x98a87d0)
        at objectinspector.pp:1474
    #12 0x0058780e in TCUSTOMCOMBOBOX__MEASUREITEM (INDEX=-1, THEHEIGHT=15,
        this=0x98a8f80) at ./include/customcombobox.inc:889
    #13 0x00587be9 in TCUSTOMCOMBOBOX__LMMEASUREITEM (THEMESSAGE=
          {MSG = 44, IDCTL = 160075648, MEASUREITEMSTRUCT = 0x8b8ec20, RESULT = 0},
    this=0x98a8f80) at ./include/customcombobox.inc:996
    #14 0x0040bd7a in SYSTEM_TOBJECT_$__DISPATCH$formal ()
    #15 0x00587b80 in TCUSTOMCOMBOBOX__LMDRAWLISTITEM (THEMESSAGE=
          {MSG = 44, UNUSED = 160075648, DRAWLISTITEMSTRUCT = 0x8b8ec20, RESULT = 0}
    , this=0x98a8f80) at ./include/customcombobox.inc:983
    #16 0x005242a9 in TWINCONTROL__WNDPROC (MESSAGE=
          {MSG = 44, WPARAM = 160075648, LPARAM = 146336800, RESULT = 0, WPARAMLO =
    36736, WPARAMHI = 2442, LPARAMLO = 60448, LPARAMHI = 2232, RESULTLO = 0, RESULTH
    I = 0}, this=0x98a8f80) at ./include/wincontrol.inc:5164
    #17 0x005ac4f7 in DELIVERMESSAGE (TARGET=0x98a8f80, AMESSAGE=void)
        at lclmessageglue.pas:111
    #18 0x0054b3f6 in WINDOWPROC (WINDOW=4063924, MSG=44, WPARAM=160075648,
        LPARAM=146336800) at win32callback.inc:2422
    #19 0x77d38709 in USER32!GetDC () from H:\WINDOWS\system32\user32.dll
    #20 0x003e02b4 in ?? ()
    #21 0x0000002c in ?? ()
    #22 0x098a8f80 in ?? ()
    #23 0x08b8ec20 in ?? ()
    #24 0x00548eb0 in GETNEEDPARENTPAINT (AWINDOWINFO=0x548eb0,
        AWINCONTROL=0x8b8ec20) at win32callback.inc:204
    #25 0x77d3d297 in USER32!GetTopWindow () from H:\WINDOWS\system32\user32.dll
    #26 0x77d3b743 in USER32!GetParent () from H:\WINDOWS\system32\user32.dll
    #27 0x00000000 in ?? ()
    (gdb)
    bt.txt (3,123 bytes)

Relationships

child of 0016013 closedMattias Gaertner New AutoSize/AutoSizing bugs (meta-bug) 

Activities

2010-04-11 23:54

 

bt.txt (3,123 bytes)
Program received signal SIGFPE, Arithmetic exception.
0x00426f12 in RAISEGDBEXCEPTION (MSG=0x0) at lclproc.pas:1505
1505      if (length(Msg) div (length(Msg) div 10000))=0 then ;
(gdb) bt
#0  0x00426f12 in RAISEGDBEXCEPTION (MSG=0x0) at lclproc.pas:1505
#1  0x00526ea4 in TWINCONTROL__CREATEWND (this=0x98a8f80)
    at ./include/wincontrol.inc:7078
#2  0x00526d25 in TWINCONTROL__CREATEHANDLE (this=0x98a8f80)
    at ./include/wincontrol.inc:7030
#3  0x00527e1a in TWINCONTROL__HANDLENEEDED (this=0x98a8f80)
    at ./include/wincontrol.inc:7516
#4  0x00525e31 in TWINCONTROL__GETHANDLE (this=0x98a8f80)
    at ./include/wincontrol.inc:6276
#5  0x00528c77 in TWINCONTROL__GETDEVICECONTEXT (WINDOWHANDLE=0,
    this=0x98a8f80) at ./include/wincontrol.inc:7935
#6  0x00519ba2 in TCONTROLCANVAS__CREATEHANDLE (this=0xd9e90)
    at ./include/controlcanvas.inc:90
#7  0x004b6de6 in TCANVAS__REQUIREDSTATE (
    REQSTATE=[CSHANDLEVALID..CSFONTVALID], this=0xd9e90)
    at ./include/canvas.inc:1564
#8  0x004b7020 in TCANVAS__TEXTEXTENT (TEXT=0xcb54b0 'Fj', this=0xd9e90,
    result={CX = 0, CY = 0}) at ./include/canvas.inc:1624
#9  0x004b70b3 in TCANVAS__TEXTHEIGHT (TEXT=0xcb54b0 'Fj', this=0xd9e90)
    at ./include/canvas.inc:1649
#10 0x00663820 in TPROPERTYEDITOR__LISTMEASUREHEIGHT (AVALUE=0xcb54b0 'Fj',
    INDEX=-1, ACANVAS=0xd9e90, AHEIGHT=15, this=0xa00a090)
    at propedits.pp:2766
#11 0x0064b157 in TOICUSTOMPROPERTYGRID__VALUECOMBOBOXMEASUREITEM (
    CONTROL=0x98a8f80, INDEX=-1, AHEIGHT=15, this=0x98a87d0)
    at objectinspector.pp:1474
#12 0x0058780e in TCUSTOMCOMBOBOX__MEASUREITEM (INDEX=-1, THEHEIGHT=15,
    this=0x98a8f80) at ./include/customcombobox.inc:889
#13 0x00587be9 in TCUSTOMCOMBOBOX__LMMEASUREITEM (THEMESSAGE=
      {MSG = 44, IDCTL = 160075648, MEASUREITEMSTRUCT = 0x8b8ec20, RESULT = 0},
this=0x98a8f80) at ./include/customcombobox.inc:996
#14 0x0040bd7a in SYSTEM_TOBJECT_$__DISPATCH$formal ()
#15 0x00587b80 in TCUSTOMCOMBOBOX__LMDRAWLISTITEM (THEMESSAGE=
      {MSG = 44, UNUSED = 160075648, DRAWLISTITEMSTRUCT = 0x8b8ec20, RESULT = 0}
, this=0x98a8f80) at ./include/customcombobox.inc:983
#16 0x005242a9 in TWINCONTROL__WNDPROC (MESSAGE=
      {MSG = 44, WPARAM = 160075648, LPARAM = 146336800, RESULT = 0, WPARAMLO =
36736, WPARAMHI = 2442, LPARAMLO = 60448, LPARAMHI = 2232, RESULTLO = 0, RESULTH
I = 0}, this=0x98a8f80) at ./include/wincontrol.inc:5164
#17 0x005ac4f7 in DELIVERMESSAGE (TARGET=0x98a8f80, AMESSAGE=void)
    at lclmessageglue.pas:111
#18 0x0054b3f6 in WINDOWPROC (WINDOW=4063924, MSG=44, WPARAM=160075648,
    LPARAM=146336800) at win32callback.inc:2422
#19 0x77d38709 in USER32!GetDC () from H:\WINDOWS\system32\user32.dll
#20 0x003e02b4 in ?? ()
#21 0x0000002c in ?? ()
#22 0x098a8f80 in ?? ()
#23 0x08b8ec20 in ?? ()
#24 0x00548eb0 in GETNEEDPARENTPAINT (AWINDOWINFO=0x548eb0,
    AWINCONTROL=0x8b8ec20) at win32callback.inc:204
#25 0x77d3d297 in USER32!GetTopWindow () from H:\WINDOWS\system32\user32.dll
#26 0x77d3b743 in USER32!GetParent () from H:\WINDOWS\system32\user32.dll
#27 0x00000000 in ?? ()
(gdb)
bt.txt (3,123 bytes)

Maxim Ganetsky

2010-04-11 23:54

developer   ~0036627

Backtrace is attached.

Maxim Ganetsky

2010-04-13 00:43

developer   ~0036654

This seems to be yet another NewAutoSize 'regression'.

Paul Ishenin

2010-04-13 16:18

manager   ~0036670

The back trace is:

[WARNING] Recursive call to CreateWnd for ValueComboBox:TComboBox while creating handle
ERROR in LCL:
Creating gdb catchable error:
  $0042C508 line 1504 of lclproc.pas
  $0052FC34 line 7078 of include/wincontrol.inc
  $0052FAB5 line 7030 of include/wincontrol.inc
  $00530BAA line 7516 of include/wincontrol.inc
  $0052EBC1 line 6276 of include/wincontrol.inc
  $00531A07 line 7935 of include/wincontrol.inc
  $00522932 line 90 of include/controlcanvas.inc
  $004BE6E6 line 1564 of include/canvas.inc
  $004BE920 line 1624 of include/canvas.inc
TApplication.HandleException Division by zero

samuel herzog

2010-04-13 20:05

developer   ~0036674

#0 RAISEGDBEXCEPTION(0x0) at lclproc.pas:1505
0000001 TWINCONTROL__CREATEWND(<error reading variable>) at .\include\wincontrol.inc:7078
0000002 TWINCONTROL__CREATEHANDLE(<error reading variable>) at .\include\wincontrol.inc:7030
0000003 TWINCONTROL__HANDLENEEDED(<error reading variable>) at .\include\wincontrol.inc:7516
0000004 TWINCONTROL__GETHANDLE(<error reading variable>) at .\include\wincontrol.inc:6276
0000005 TWINCONTROL__GETDEVICECONTEXT(0, <error reading variable>) at .\include\wincontrol.inc:7935
0000006 TCONTROLCANVAS__CREATEHANDLE(<error reading variable>) at .\include\controlcanvas.inc:90
0000007 TCANVAS__REQUIREDSTATE([CSHANDLEVALID..CSFONTVALID], <error reading variable>) at .\include\canvas.inc:1564
0000008 TCANVAS__TEXTEXTENT(0xc9a260 'Fj', <error reading variable>, {CX = 0, CY = 0}) at .\include\canvas.inc:1624
0000009 TCANVAS__TEXTHEIGHT(0xc9a260 'Fj', <error reading variable>) at .\include\canvas.inc:1649
0000010 TPROPERTYEDITOR__LISTMEASUREHEIGHT(0xc9a260 'Fj', -1, 0x895e0, 15, <error reading variable>) at propedits.pp:2766
0000011 TOICUSTOMPROPERTYGRID__VALUECOMBOBOXMEASUREITEM(0x9ac58b8, -1, 15, <error reading variable>) at objectinspector.pp:1474
0000012 TCUSTOMCOMBOBOX__MEASUREITEM(-1, 15, <error reading variable>) at .\include\customcombobox.inc:889
0000013 TCUSTOMCOMBOBOX__LMMEASUREITEM({MSG = 44, IDCTL = 162289848, MEASUREITEMSTRUCT = 0x85cec20, RESULT = 0}, <error reading variable>) at .\include\customcombobox.inc:996
0000014 SYSTEM_TOBJECT_$__DISPATCH$formal at :0
0000015 TCUSTOMCOMBOBOX__LMDRAWLISTITEM({MSG = 44, UNUSED = 162289848, DRAWLISTITEMSTRUCT = 0x85cec20, RESULT = 0}, <error reading variable>) at .\include\customcombobox.inc:983
0000016 TWINCONTROL__WNDPROC({MSG = 44, WPARAM = 162289848, LPARAM = 140307488, RESULT = 0, WPARAMLO = 22712, WPARAMHI = 2476, LPARAMLO = 60448, LPARAMHI = 2140, RESULTLO = 0, RESULTHI = 0}, <error reading variable>) at .\include\wincontrol.inc:5164
0000017 DELIVERMESSAGE(0x9ac58b8, void) at lclmessageglue.pas:111
0000018 WINDOWPROC(133462, 44, 162289848, 140307488) at win32callback.inc:2422
0000019 ?? at :0
0000020 ?? at :0
0000021 ?? at :0
0000022 ?? at :0
0000023 ?? at :0
0000024 GETNEEDPARENTPAINT(0x548440, 0x85ceb74) at win32callback.inc:204
0000025 ?? at :0
0000026 GETNEEDPARENTPAINT(0x0, 0x7e368830) at win32callback.inc:204
0000027 ?? at :0
0000028 ?? at :0

Paul Ishenin

2010-04-16 00:10

manager   ~0036738

Please test and close if ok.

samuel herzog

2010-04-17 06:50

developer   ~0036755

Is ok now. Thank you.

Issue History

Date Modified Username Field Change
2010-04-10 21:24 Teemu Valo New Issue
2010-04-10 21:49 Marco van de Voort Project FPC => Lazarus
2010-04-11 23:54 Maxim Ganetsky File Added: bt.txt
2010-04-11 23:54 Maxim Ganetsky Note Added: 0036627
2010-04-11 23:55 Maxim Ganetsky LazTarget => -
2010-04-11 23:55 Maxim Ganetsky Status new => confirmed
2010-04-13 00:43 Maxim Ganetsky Note Added: 0036654
2010-04-13 00:44 Maxim Ganetsky Product Version 2.4.1 =>
2010-04-13 00:44 Maxim Ganetsky Target Version => 0.9.30
2010-04-13 00:44 Maxim Ganetsky Relationship added child of 0016013
2010-04-13 16:18 Paul Ishenin Note Added: 0036670
2010-04-13 20:05 samuel herzog Note Added: 0036674
2010-04-16 00:10 Paul Ishenin Fixed in Revision => 24636
2010-04-16 00:10 Paul Ishenin LazTarget - => 0.9.30
2010-04-16 00:10 Paul Ishenin Status confirmed => resolved
2010-04-16 00:10 Paul Ishenin Fixed in Version => 0.9.30
2010-04-16 00:10 Paul Ishenin Resolution open => fixed
2010-04-16 00:10 Paul Ishenin Assigned To => Paul Ishenin
2010-04-16 00:10 Paul Ishenin Note Added: 0036738
2010-04-17 06:50 samuel herzog Status resolved => closed
2010-04-17 06:50 samuel herzog Note Added: 0036755