View Issue Details

IDProjectCategoryView StatusLast Update
0016259LazarusIDEpublic2011-12-01 11:23
ReporterYuri_brAssigned ToPaul Ishenin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.28.2Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0016259: Cannot Change Object Properties
DescriptionHi, I have the same problem described on issue 0015464. It's a very annoying bug that prevents one from changing object properties and that's why I gave up from using Lazarus in the past.

But now I found how to reproduce it.

1. Create a new project and place 2 buttons on it.
2. Click on the first button and change it's CAPTION property to 'test'. After that press TAB (or ENTER + TAB).
3. Now click on the button2 and try to change it's caption property. Instead of editing the property, the cursor will jump through the properties according to the letter you type.

The problem is that this erratic behavior should come back to normal when you change the object selection, but you wont be able to edit a property until you press TAB again.

Also, after you pressed TAB and entered in this 'navigation mode', if you press a key that has no property starting with it, it will actually edit the selected field.

For example, after going thought steps 1-3, try to set the caption of a TButton let's say to 'konkeror'. After you have typed 'KONKEROR' you will have changed the caption to 'ko', then when 'n' was pressed it navigates to the property 'name', so as you keep typing, this property will be set to 'k'. When 'e' is pressed it goes to 'enabled' property wich ends with the value of 'ror'.

So, after that you messed up with all the object properties!!!

In a nutshell, there are in fact two bugs:

1. When in 'navigation mode' (after pressing TAB) it should come back to 'editing mode' when the object selection is changed

2. When in 'navigation mode' if a property that starts with the last key pressed does not exists it SHOULD NOT change the corresponding property.

I'm not sure if this can be reproduced in Linux btw.

Regards
Yuri
TagsNo tags attached.
Fixed in Revision24711
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0016213 resolvedJuha Manninen Data Controls properties key shortcut 
related to 0017487 closedVincent Snijders TAB in Object Inspector causes problem 

Activities

Juha Manninen

2010-04-12 11:36

developer   ~0036633

Confirmed! It happens also on Linux.

If you press TAB just once then Object Inspector switches into 'navigation mode'. There is no way to come back from it, except for restarting Lazarus. Number of controls on the form doesn't affect. Even if you remove all of them and try to edit Form1 properties, the same problem continues.

I don't know why I didn't notice this before. Maybe I never pressed TAB.
Is this 'navigation mode' an intentional feature or is the whole thing a bug?

Workaround: Never press TAB in Object Inspector! Use mouse for navigation.

Yuri_br

2010-04-12 17:16

reporter   ~0036645

In fact if you press TAB again it switches back to normal behavior. No need for restarting Lazarus.

Juha Manninen

2010-04-12 23:36

developer   ~0036650

Right, TAB switches it between normal and navigation modes. Anyway it is not very intuitive. There is no visual indication that the mode has changed. In navigation mode (like Yuri_br explained) some keys are treated as normal keys and some are navigation keys. Not good.
IMO this "mode" could be removed completely.

Yuri_br

2010-04-13 16:09

reporter   ~0036669

I agree.

When TAB is pressed it could either go to the next property (same object next property) or to the next object (next object same property).

Sven Barth

2010-04-13 16:39

manager   ~0036671

It might be better to improve this feature.
The intention of the navigation mode might be to find properties fast by name. Currently it fails this purpose, because it selects properties by its first letter. E. g. if you type "enabled" in "navigation mode" the selection moves to "Enabled" when typing "e" and then to "Name" when typing "n" (and enters a value if the property is missing - which is completly wrong).
Allowing to type the complete property name would be better. The buffer holding the property's name could reset after some time so that you can search another property.
Also the change from "editing mode" to "navigation mode" should be made more visible...

Another possibility (to replace this feature) would be to provide a searchbox which filters the property list.

Regards,
Sven

Paul Ishenin

2010-04-19 09:31

manager   ~0036809

Now when you click on Object inspector or change selected components it switches to editing mode from navigation mode. If someone needs better notifications of that mode please create a patch and open another issue.

Please test the changes and close this issue if you are satisfied with the solution.

Issue History

Date Modified Username Field Change
2010-04-12 04:11 Yuri_br New Issue
2010-04-12 04:11 Yuri_br Widgetset => Win32/Win64
2010-04-12 11:36 Juha Manninen LazTarget => -
2010-04-12 11:36 Juha Manninen Note Added: 0036633
2010-04-12 11:36 Juha Manninen Status new => confirmed
2010-04-12 12:36 Juha Manninen Relationship added duplicate of 0016213
2010-04-12 17:16 Yuri_br Note Added: 0036645
2010-04-12 23:36 Juha Manninen Note Added: 0036650
2010-04-12 23:37 Juha Manninen LazTarget - => 0.9.30
2010-04-13 16:09 Yuri_br Note Added: 0036669
2010-04-13 16:39 Sven Barth Note Added: 0036671
2010-04-19 09:31 Paul Ishenin Fixed in Revision => 24711
2010-04-19 09:31 Paul Ishenin Status confirmed => resolved
2010-04-19 09:31 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-04-19 09:31 Paul Ishenin Resolution open => fixed
2010-04-19 09:31 Paul Ishenin Assigned To => Paul Ishenin
2010-04-19 09:31 Paul Ishenin Note Added: 0036809
2010-09-25 10:50 Juha Manninen Relationship added related to 0017487
2011-12-01 11:23 Marc Weustink Status resolved => closed