View Issue Details

IDProjectCategoryView StatusLast Update
0016279LazarusPatchpublic2010-04-16 21:51
ReporterFlávio Etrusco Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0016279: [patch] SourceNotebook cleanup and conceptual fix
DescriptionWhat this patch does (in SourceEditor.pp, TSourceNotebook):
- don't call NotebookPageChanged explicitly on NextEditor and PrevEditor. It's already called by the FNotebook.OnChange (at on GTK2. If it's not invoked in other ws' then we'd seem other problems).
- fix 'else' clause in PrevEditor.
- update FPageIndex in NoteBookDeletePage, since it doesn't check whether FUpdateLock = 0.
- lower visibility of utilitarian methods/event handlers (from public to protected).
- remove duplicate logic in /change NoteBookDeletePage.
- make TSourceNotebook.PageIndex readonly, since it doesn't seem something that should be public.

I can make separate patches if necessary.
TagsNo tags attached.
Fixed in Revision24639
LazTarget0.9.30
Widgetset
Attached Files

Activities

2010-04-15 23:22

 

Martin Friebe

2010-04-16 01:11

manager   ~0036739

Thanks.

Applied with minor modifications

Issue History

Date Modified Username Field Change
2010-04-15 23:22 Flávio Etrusco New Issue
2010-04-15 23:22 Flávio Etrusco File Added: source_tabindex_cleanup.r24634M.svndiff
2010-04-15 23:22 Flávio Etrusco LazTarget => -
2010-04-15 23:22 Flávio Etrusco Widgetset => GTK, GTK 2, Win32/Win64, WinCE, Carbon, QT, fpGUI
2010-04-16 00:22 Martin Friebe Status new => assigned
2010-04-16 00:22 Martin Friebe Assigned To => Martin Friebe
2010-04-16 01:11 Martin Friebe Fixed in Revision => 24639
2010-04-16 01:11 Martin Friebe LazTarget - => 0.9.30
2010-04-16 01:11 Martin Friebe Widgetset GTK, GTK 2, Win32/Win64, WinCE, Carbon, QT, fpGUI =>
2010-04-16 01:11 Martin Friebe Status assigned => resolved
2010-04-16 01:11 Martin Friebe Fixed in Version => 0.9.29 (SVN)
2010-04-16 01:11 Martin Friebe Resolution open => fixed
2010-04-16 01:11 Martin Friebe Note Added: 0036739
2010-04-16 01:11 Martin Friebe Target Version => 0.9.30
2010-04-16 21:51 Flávio Etrusco Status resolved => closed