View Issue Details

IDProjectCategoryView StatusLast Update
0016281LazarusIDEpublic2011-12-01 11:23
ReporterKisielewski Tomasz Assigned ToFlávio Etrusco  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSTesting 
Fixed in Version0.9.28 
Summary0016281: [Debian Testing]: Access Violation in IDE
DescriptionLazarus Debian 0.9.28.2-9 Beta SVN build 22277
When open dialogs for example "Compile Options" "open package file" and many other... show Access Violation
TApplication.HandleException Access violation
  Stack trace:
  $B75A6E2E
  $082B9C8C
  $081EA5EB
  $081E985A
  $081A8D2C
  $081A8925
  $081A98FA
  $081A8DF5
  $081A8925
  $081A98FA
  $081A7A01
  $0827FA85
  $0824DCCE
  $0824D15C
  $0824D0CF
  $081A8925
  $081A98FA
Steps To ReproduceStart Lazarus - compiler option or open package file
or enviroment -fpdoc Editor - empty window on right , again fpdoc editor -window on right visible -(fpdoc files path) - and ok and crash

GLib:ERROR:/build/buildd-glib2.0_2.24.0-1-i386-o5zIuQ/glib2.0-2.24.0/glib/gmain.c:1963:g_main_dispatch: assertion failed: (current->dispatching_sources == &current_source_link)


indepedent of user ( normal ,root) glibc version libglib2.0.0 2.24.0-1 -lazarus from debian repository, lazarus from lazarus.org (deb i386) crash too
TagsNo tags attached.
Fixed in Revision(debian) 0.9.28.2-10
LazTarget-
Widgetset
Attached Files

Activities

Kisielewski Tomasz

2010-04-18 10:13

reporter   ~0036776

on the another cmputer with the same distribution - the same access violation and crash - on compiler options , project options , load lpk etc - debian testing, xfce 4.6. -after update system - suspicious dbus or glib

Flávio Etrusco

2010-04-19 06:53

developer   ~0036801

Can you test with the latest svn version? Or run lazarus in gdb to get more useful backtrace? This looks like a bug fixed in the exception handling of libraries, although IIRC the exception there was "invalid FP operation"...

Kisielewski Tomasz

2010-04-19 07:50

reporter   ~0036806

is it ok ???

i'm beginner user of linux :-(

in lazarus - click Compiler Option - message box with "Access Violation"


tomek@nblo0005:~$ gdb startlazarus
GNU gdb (GDB) 7.0.1-debian
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/startlazarus...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/startlazarus
[Thread debugging using libthread_db enabled]
[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of unassigned VK codes, assigning $FF
TLazarusManager.Run starting /usr/lib/lazarus/0.9.28.2/lazarus ...
[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of unassigned VK codes, assigning $FF
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/home/tomek/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
NOTE: miscellaneous options file not found - using defaults
TPkgManager.GetWritablePkgOutputDirectory APackage=RunTimeTypeInfoControls 0.1 AnOutDirectory="/home/tomek/.lazarus/lib/RunTimeTypeInfoControls/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=Printer4Lazarus 0.5 AnOutDirectory="/home/tomek/.lazarus/lib/Printer4Lazarus/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=printers4lazide 0.0 AnOutDirectory="/home/tomek/.lazarus/lib/printers4lazide/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=Printer4Lazarus 0.5 AnOutDirectory="/home/tomek/.lazarus/lib/Printer4Lazarus/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=cgiLaz 0.1.1 AnOutDirectory="/home/tomek/.lazarus/lib/cgiLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=CGILazIDE 0.0 AnOutDirectory="/home/tomek/.lazarus/lib/CGILazIDE/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=cgiLaz 0.1.1 AnOutDirectory="/home/tomek/.lazarus/lib/cgiLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=MemDSLaz 1.2.1 AnOutDirectory="/home/tomek/.lazarus/lib/MemDSLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=SDFLaz 0.1.1 AnOutDirectory="/home/tomek/.lazarus/lib/SDFLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=TurboPowerIPro 1.0 AnOutDirectory="/home/tomek/.lazarus/lib/TurboPowerIPro/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=jcfidelazarus 2.0 AnOutDirectory="/home/tomek/.lazarus/lib/jcfidelazarus/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=fpcunitide 0.1 AnOutDirectory="/home/tomek/.lazarus/lib/fpcunitide/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=ProjTemplates 1.0 AnOutDirectory="/home/tomek/.lazarus/lib/ProjTemplates/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=TAChartLazarusPkg 1.0 AnOutDirectory="/home/tomek/.lazarus/lib/TAChartLazarusPkg/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=SQLDBLaz 1.0.1 AnOutDirectory="/home/tomek/.lazarus/lib/SQLDBLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=DBFLaz 0.1.1 AnOutDirectory="/home/tomek/.lazarus/lib/DBFLaz/i386-linux"
TMainIDE.DoNewProject A
TPkgManager.GetWritablePkgOutputDirectory APackage=RunTimeTypeInfoControls 0.1 AnOutDirectory="/home/tomek/.lazarus/lib/RunTimeTypeInfoControls/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=Printer4Lazarus 0.5 AnOutDirectory="/home/tomek/.lazarus/lib/Printer4Lazarus/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=printers4lazide 0.0 AnOutDirectory="/home/tomek/.lazarus/lib/printers4lazide/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=cgiLaz 0.1.1 AnOutDirectory="/home/tomek/.lazarus/lib/cgiLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=CGILazIDE 0.0 AnOutDirectory="/home/tomek/.lazarus/lib/CGILazIDE/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=MemDSLaz 1.2.1 AnOutDirectory="/home/tomek/.lazarus/lib/MemDSLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=SDFLaz 0.1.1 AnOutDirectory="/home/tomek/.lazarus/lib/SDFLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=TurboPowerIPro 1.0 AnOutDirectory="/home/tomek/.lazarus/lib/TurboPowerIPro/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=jcfidelazarus 2.0 AnOutDirectory="/home/tomek/.lazarus/lib/jcfidelazarus/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=fpcunitide 0.1 AnOutDirectory="/home/tomek/.lazarus/lib/fpcunitide/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=ProjTemplates 1.0 AnOutDirectory="/home/tomek/.lazarus/lib/ProjTemplates/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=TAChartLazarusPkg 1.0 AnOutDirectory="/home/tomek/.lazarus/lib/TAChartLazarusPkg/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=SQLDBLaz 1.0.1 AnOutDirectory="/home/tomek/.lazarus/lib/SQLDBLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=DBFLaz 0.1.1 AnOutDirectory="/home/tomek/.lazarus/lib/DBFLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=RunTimeTypeInfoControls 0.1 AnOutDirectory="/home/tomek/.lazarus/lib/RunTimeTypeInfoControls/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=Printer4Lazarus 0.5 AnOutDirectory="/home/tomek/.lazarus/lib/Printer4Lazarus/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=printers4lazide 0.0 AnOutDirectory="/home/tomek/.lazarus/lib/printers4lazide/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=cgiLaz 0.1.1 AnOutDirectory="/home/tomek/.lazarus/lib/cgiLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=CGILazIDE 0.0 AnOutDirectory="/home/tomek/.lazarus/lib/CGILazIDE/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=MemDSLaz 1.2.1 AnOutDirectory="/home/tomek/.lazarus/lib/MemDSLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=SDFLaz 0.1.1 AnOutDirectory="/home/tomek/.lazarus/lib/SDFLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=TurboPowerIPro 1.0 AnOutDirectory="/home/tomek/.lazarus/lib/TurboPowerIPro/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=jcfidelazarus 2.0 AnOutDirectory="/home/tomek/.lazarus/lib/jcfidelazarus/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=fpcunitide 0.1 AnOutDirectory="/home/tomek/.lazarus/lib/fpcunitide/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=ProjTemplates 1.0 AnOutDirectory="/home/tomek/.lazarus/lib/ProjTemplates/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=TAChartLazarusPkg 1.0 AnOutDirectory="/home/tomek/.lazarus/lib/TAChartLazarusPkg/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=SQLDBLaz 1.0.1 AnOutDirectory="/home/tomek/.lazarus/lib/SQLDBLaz/i386-linux"
TPkgManager.GetWritablePkgOutputDirectory APackage=DBFLaz 0.1.1 AnOutDirectory="/home/tomek/.lazarus/lib/DBFLaz/i386-linux"
TCustomFormEditor.CreateComponent Form1:TForm1 True
TMainIDE.DoNewEditorFile END unit1.pas
TApplication.HandleException Access violation
  Stack trace:
  $B7CE3E2E
  $082B9C8C
  $081EA5EB
  $081E985A
  $081A8D2C
  $081A8925
  $081A98FA
  $081A8DF5
  $081A8925
  $081A98FA
  $081A8DF5
  $081A8925
  $081A98FA
  $081A7A01
  $0827FA85
  $0824DCCE
  $0824D15C
TMainIDE.CloseUnitComponent unit1.pas Form1:TForm1
TProject.UpdateUnitComponentDependencies checking properties ...
TProject.UpdateUnitComponentDependencies checking designers ...
TProject.UpdateUnitComponentDependencies used by designer: unit1.pas
TMainIDE.CloseUnitComponent freeing component and designer: unit1.pas Form1:TForm1
TProject.UpdateUnitComponentDependencies checking designers ...
LAZARUS END - cleaning up ...
[TMainIDE.Destroy] A
[TMainIDE.Destroy] B -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END

Program exited normally.
(gdb)

Kisielewski Tomasz

2010-04-21 14:54

reporter   ~0036881

Version 0.9.28.2-10 from sid works without problems

Flávio Etrusco

2010-04-21 18:17

developer   ~0036889

Last edited: 2010-04-21 19:25

So can this issue be marked resolved?
(BTW sorry for the delay, I intended to give you some more detailed instructions for gdb, but couldn't get the time...)

Kisielewski Tomasz

2010-04-22 07:40

reporter   ~0036902

Yes - issue resolved

more instruction for gdb ? - yes - for next problems in the future :-)

Flávio Etrusco

2010-04-22 15:07

developer   ~0036913

$gdb lazarus
(gdb) break FPC_RAISEEXCEPTION
(gdb) run
-- when the exception occurs --
(gdb) bt

You can "set logging on <optional_file_name>" to save the output to a file.

Issue History

Date Modified Username Field Change
2010-04-16 12:52 Kisielewski Tomasz New Issue
2010-04-16 13:06 Jonas Maebe Project FPC => Lazarus
2010-04-16 21:51 Maxim Ganetsky LazTarget => -
2010-04-16 21:51 Maxim Ganetsky Summary Access Violation in IDE => [Debian Testing]: Access Violation in IDE
2010-04-18 10:13 Kisielewski Tomasz Note Added: 0036776
2010-04-19 06:53 Flávio Etrusco Note Added: 0036801
2010-04-19 07:50 Kisielewski Tomasz Note Added: 0036806
2010-04-21 14:54 Kisielewski Tomasz Note Added: 0036881
2010-04-21 18:17 Flávio Etrusco Note Added: 0036889
2010-04-21 19:25 Flávio Etrusco Note Edited: 0036889
2010-04-22 07:40 Kisielewski Tomasz Note Added: 0036902
2010-04-22 15:07 Flávio Etrusco Note Added: 0036913
2010-04-22 15:10 Flávio Etrusco Fixed in Revision => (debian) 0.9.28.2-10
2010-04-22 15:10 Flávio Etrusco Status new => resolved
2010-04-22 15:10 Flávio Etrusco Fixed in Version => 0.9.28
2010-04-22 15:10 Flávio Etrusco Resolution open => fixed
2010-04-22 15:10 Flávio Etrusco Assigned To => Flávio Etrusco
2011-12-01 11:23 Marc Weustink Status resolved => closed