View Issue Details

IDProjectCategoryView StatusLast Update
0016332LazarusWidgetsetpublic2011-12-01 11:24
Reporternicola gorlandiAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0016332: Menu on WinCe
DescriptionSome problems for menu:

a) If the main menu has an item without sub menu but run a forms than if selected blocks the application.

b) same beahviuor if the form is launched by a menu inside a sub menu.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWinCE
Attached Files

Relationships

related to 0014973 closedFelipe Monteiro de Carvalho WinCE: Can't change menu item caption in soft key bar 
related to 0016435 closedFelipe Monteiro de Carvalho Cannot change caption of MainMenuItem if Item has subitem, WinCE 
parent of 0016481 closedFelipe Monteiro de Carvalho WinCE, Menubehaviour if only mainmenu 2 iitems 

Activities

Felipe Monteiro de Carvalho

2010-06-01 08:03

developer   ~0038190

Here it works.

Could you test with the latest svn Lazarus?

If still doesn't work, could you upload a test project and give more information, such as your exact lazarus and fpc versions and what WinCE version and type you are using?

John vd Waeter

2010-06-01 08:14

reporter   ~0038191

Last edited: 2010-06-01 08:17

sri, cannot. Got a "550 failed to change directory" on snapshot page (www.hu.freepascal.org/lazarus)

Edit: ok, germany works. I'll test and provide feedback.

John

2010-06-01 09:10

 

testmenu1.zip (66,203 bytes)

John vd Waeter

2010-06-01 09:11

reporter   ~0038192

Last edited: 2010-06-01 09:28

Please find testmenu1.zip.
Only a left and a right menu. Onclick (should) change caption of label.
Using todays snapshot 25811 on FPC 2.4.1

In testmenu2 I try to change the caption of the left and the right menubutton.
Fails on Smartphone, works on PocketPC.

2010-06-01 09:27

 

testmenu2.zip (66,309 bytes)

Felipe Monteiro de Carvalho

2010-07-06 16:28

developer   ~0039077

Last edited: 2010-07-06 16:37

About testmenu1.zip, indeed, it doesn't work in the WM 5.0 Smartphone emulator, but it works perfectly in the WM 6.0 Classic emulator o.O

Copy of the info you wrote in the test app:

Tested on 5 emulators:

WM 5 pocket pc: OK
WM 5 smartphone: Left closes app,
right does not fire event.
WM 6.1 Pocket PC: OK
WM 6.5 Pocket PC: No events
fired
WM 6.5 Smartphone: Left closes
app, right does nothing.

Real device (HTC wm 6 (CE 5.2))
pocket pc (Pharos): OK

Felipe Monteiro de Carvalho

2010-07-06 17:12

developer   ~0039084

Aha, my mistake, WM 6.0 Classic emulator is not a atKeyPadDevice, so it doesn't work in any "Smartphone" version

Felipe Monteiro de Carvalho

2010-07-06 17:40

developer   ~0039086

Thanks for the test apps, they really helped

Felipe Monteiro de Carvalho

2010-07-06 17:42

developer   ~0039087

Wait a minute ... those test apps are for the bug 16481 ... and that is the bug I fixed

John vd Waeter

2010-07-07 08:52

reporter   ~0039098

Ok, tested on this mornings revision 26494 and both testmenu1 and testmenu2 work fine on keypaddevices! Thanks! :-)

Felipe Monteiro de Carvalho

2010-07-08 12:42

developer   ~0039126

About the original issue with menu items launching a form, I just tested and couldn't reproduce, so I assume it is fixed in the mean time.

John vd Waeter

2010-07-08 13:37

reporter   ~0039127

Yep, but probably introduced some other error, as my submenu's are gone and replaced by submenu SUB1 (left) and submenu SUB2 (right) on Keypaddevice. On PocketPC, all is ok (AFAICS)

John

John vd Waeter

2010-07-13 15:23

reporter   ~0039302

Please not inTestMenu3.zip the difference in behaviour between atPDA and atKeyPadDevice.

It seems like some indexing has a wrong offset or is mixed up.
E.g. that in this example in the case of KeyPadDevice the LEFT first submenu-event is triggered by the RIGHT toplevel-menuitem...

2010-07-13 15:24

 

TESTMENU3.ZIP (131,093 bytes)

Felipe Monteiro de Carvalho

2010-07-23 18:54

developer   ~0039627

rev26794 improves a little bit. My report, correct me if wrong:

PopUp - PopUp -> Works perfectly
Item - Item -> Works perfectly
PopUp - Item -> Now the PopUp should work, the item doesnt work
PopUp -> broken, at least in subforms
Item -> broken, at least in subforms
Nothing -> broken, at least in subforms

John vd Waeter

2010-07-23 19:03

reporter   ~0039630

I have to test that tomorrow...

John vd Waeter

2010-07-24 11:04

reporter   ~0039639

Last edited: 2010-07-24 12:03

Hmmm, improves... :-) yes, the behaviour changed a little.

-on PocketPC the LEFT top menu item will not change caption at runtime

- on keypaddevice NO menu-item will change caption at runtime

- on keypaddevice the left menu-item on the second form does nothing (no event)

- on keypaddevice there appears a right menu-item on the second form while there is none defined at designtime and none created at runtime.

tested with 26795

Felipe Monteiro de Carvalho

2010-07-24 12:02

developer   ~0039643

rev26798 fixes all problems, but now changing the submenu item caption isn't working.

John vd Waeter

2010-07-24 12:05

reporter   ~0039644

Menus must give you a headache....
I can only test tomorrow, as I use snapshots...

Felipe Monteiro de Carvalho

2010-07-24 12:36

developer   ~0039648

Ah ... I now saw that one on PocketPC ... pretty terrible. That's exactly what I wanted to avoid, KeyPadDevice changes interfering in PocketPC ...

Also in the second form, although the layout is now correct, the problem is that the IDs are fixed in the RC file, you can't change them, so they clash with the first form ...

Felipe Monteiro de Carvalho

2010-07-24 12:46

developer   ~0039649

Indeed, the worse part is that not only the WinCE API has a horrible design, the worse menu API I have ever seen, but also the Microsoft documentation about it nearly useless.

They were designed to be static, so if you want to change them at runtime you have real problems.

Luckly I found a wiki which explains what the official docs don't:

http://channel9.msdn.com/wiki/MobileDeveloper/Menu/

And now I am doing some good progress.

rev26804 removes the start menu index, which was a big problem.

John vd Waeter

2010-07-24 12:51

reporter   ~0039650

Uhm... I don't think I fully understand... I thought ID's are obtained when creating the menus, e.g. at runtime?

John vd Waeter

2010-07-24 13:01

reporter   ~0039651

Right, seen. I'll await your progress to test... :-)

Felipe Monteiro de Carvalho

2010-07-24 13:21

developer   ~0039654

rev26807 fixed the PDA issue.

By the way, please follow up this conversation in bug 16435

Issue History

Date Modified Username Field Change
2010-04-25 09:59 nicola gorlandi New Issue
2010-04-25 09:59 nicola gorlandi Widgetset => WinCE
2010-04-25 17:57 Felipe Monteiro de Carvalho Status new => assigned
2010-04-25 17:57 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2010-06-01 07:55 Felipe Monteiro de Carvalho Relationship added related to 0014973
2010-06-01 07:56 Felipe Monteiro de Carvalho Relationship added related to 0016435
2010-06-01 07:56 Felipe Monteiro de Carvalho Relationship added parent of 0016481
2010-06-01 08:03 Felipe Monteiro de Carvalho LazTarget => -
2010-06-01 08:03 Felipe Monteiro de Carvalho Note Added: 0038190
2010-06-01 08:03 Felipe Monteiro de Carvalho Status assigned => feedback
2010-06-01 08:14 John vd Waeter Note Added: 0038191
2010-06-01 08:17 John vd Waeter Note Edited: 0038191
2010-06-01 09:10 John vd Waeter File Added: testmenu1.zip
2010-06-01 09:11 John vd Waeter Note Added: 0038192
2010-06-01 09:12 John vd Waeter Note Edited: 0038192
2010-06-01 09:27 John vd Waeter File Added: testmenu2.zip
2010-06-01 09:28 John vd Waeter Note Edited: 0038192
2010-07-06 16:21 Felipe Monteiro de Carvalho Status feedback => assigned
2010-07-06 16:28 Felipe Monteiro de Carvalho Note Added: 0039077
2010-07-06 16:37 Felipe Monteiro de Carvalho Note Edited: 0039077
2010-07-06 17:12 Felipe Monteiro de Carvalho Note Added: 0039084
2010-07-06 17:40 Felipe Monteiro de Carvalho Fixed in Revision => 26489
2010-07-06 17:40 Felipe Monteiro de Carvalho Status assigned => resolved
2010-07-06 17:40 Felipe Monteiro de Carvalho Fixed in Version => 0.9.29 (SVN)
2010-07-06 17:40 Felipe Monteiro de Carvalho Resolution open => fixed
2010-07-06 17:40 Felipe Monteiro de Carvalho Note Added: 0039086
2010-07-06 17:42 Felipe Monteiro de Carvalho Status resolved => assigned
2010-07-06 17:42 Felipe Monteiro de Carvalho Resolution fixed => reopened
2010-07-06 17:42 Felipe Monteiro de Carvalho Note Added: 0039087
2010-07-07 08:52 John vd Waeter Note Added: 0039098
2010-07-08 12:42 Felipe Monteiro de Carvalho Fixed in Revision 26489 =>
2010-07-08 12:42 Felipe Monteiro de Carvalho Status assigned => resolved
2010-07-08 12:42 Felipe Monteiro de Carvalho Resolution reopened => fixed
2010-07-08 12:42 Felipe Monteiro de Carvalho Note Added: 0039126
2010-07-08 13:37 John vd Waeter Note Added: 0039127
2010-07-13 15:23 John vd Waeter Note Added: 0039302
2010-07-13 15:24 John vd Waeter File Added: TESTMENU3.ZIP
2010-07-22 18:15 Felipe Monteiro de Carvalho Status resolved => assigned
2010-07-23 18:54 Felipe Monteiro de Carvalho Note Added: 0039627
2010-07-23 19:03 John vd Waeter Note Added: 0039630
2010-07-24 11:04 John vd Waeter Note Added: 0039639
2010-07-24 12:02 Felipe Monteiro de Carvalho Note Added: 0039643
2010-07-24 12:03 John vd Waeter Note Edited: 0039639
2010-07-24 12:05 John vd Waeter Note Added: 0039644
2010-07-24 12:36 Felipe Monteiro de Carvalho Note Added: 0039648
2010-07-24 12:46 Felipe Monteiro de Carvalho Note Added: 0039649
2010-07-24 12:51 John vd Waeter Note Added: 0039650
2010-07-24 13:01 John vd Waeter Note Added: 0039651
2010-07-24 13:21 Felipe Monteiro de Carvalho Note Added: 0039654
2010-07-24 13:23 Felipe Monteiro de Carvalho Status assigned => resolved
2011-12-01 11:24 Marc Weustink Status resolved => closed