View Issue Details

IDProjectCategoryView StatusLast Update
0016379LazarusLCLpublic2010-10-31 23:16
ReporterSven BarthAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.9.28.2Product Build 
Target VersionFixed in Version 
Summary0016379: WinCE: TImage is not drawn at it's correct position in TScrollBox
DescriptionIf a TImage control is in a scrollbox and you scroll the box, the control itself is moved to the correct position, but the image is drawn as if the image had not moved.
Additional InformationThe scrollbox in the example contains five images of which the bottom two are below the client rectangle of the scrollbox. Clicking on an image displays the components name in the label.

If you scroll down completely and click on the image at the bottom the label will display "Image5". Also if you click on images above it (also a "invisible" one at the top of the scrolled down scroll box) you will see the name of the images as if they were scrolled. It might be that there is a problem with drawing TGraphicControl descendants on a scrolled canvas on WinCE.

This bug is related to 0011567 but specifically asks about the image issue and narrows down the problem.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0011567 closedFelipe Monteiro de Carvalho ScrollBox doesn't work properly 
related to 0016638 closedFelipe Monteiro de Carvalho WinCE: Client area of scrollbox is scrolled in wrong direction 
related to 0013300 closedFelipe Monteiro de Carvalho TScrollBox and WinCE 
has duplicate 0016657 closedFelipe Monteiro de Carvalho WinCE: Vertical position of Tlabel on TScrollbox does not scroll 

Activities

2010-04-30 17:32

 

scrollbox.zip (2,528 bytes)

Felipe Monteiro de Carvalho

2010-10-24 11:06

developer   ~0042044

I just tested and it works perfectly, so it was fixed in the mean time. Fixed as of the latest Lazarus 0.9.29

Sven Barth

2010-10-31 23:16

manager   ~0042517

Yes, it's indeed fixed. :)

Regards,
Sven

Issue History

Date Modified Username Field Change
2010-04-30 17:32 Sven Barth New Issue
2010-04-30 17:32 Sven Barth File Added: scrollbox.zip
2010-04-30 17:32 Sven Barth Widgetset => WinCE
2010-05-06 17:49 Felipe Monteiro de Carvalho Status new => assigned
2010-05-06 17:49 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2010-05-06 17:50 Felipe Monteiro de Carvalho Relationship added related to 0011567
2010-06-04 19:16 Felipe Monteiro de Carvalho Relationship added related to 0016638
2010-06-04 19:16 Felipe Monteiro de Carvalho Relationship added related to 0013300
2010-06-10 17:59 Felipe Monteiro de Carvalho Relationship added has duplicate 0016657
2010-10-24 11:00 Felipe Monteiro de Carvalho LazTarget => -
2010-10-24 11:00 Felipe Monteiro de Carvalho Widgetset WinCE =>
2010-10-24 11:00 Felipe Monteiro de Carvalho Relationship replaced duplicate of 0011567
2010-10-24 11:00 Felipe Monteiro de Carvalho Duplicate ID 0 => 11567
2010-10-24 11:00 Felipe Monteiro de Carvalho Status assigned => resolved
2010-10-24 11:00 Felipe Monteiro de Carvalho Resolution open => duplicate
2010-10-24 11:06 Felipe Monteiro de Carvalho Note Added: 0042044
2010-10-31 23:16 Sven Barth Status resolved => closed
2010-10-31 23:16 Sven Barth Note Added: 0042517