View Issue Details

IDProjectCategoryView StatusLast Update
0016399LazarusLCLpublic2010-05-05 17:16
ReporterFlávio Etrusco (notifications not working)Assigned ToZeljan Rikalo 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.30 
Summary0016399: Double-clicking an item in the Breakpoint List causes a SIGSEGV (because of infinite loop)
DescriptionLooking at the stack trace it doesn't seem to be anything specific to the Breakpoint list, but instead something general to multi-select listviews, maybe only if a header is present, but I couldn't find other places the problem is triggered.
Additional Information0 TGTK2WSCUSTOMLISTVIEW__ITEMSETSTATE(0xb5741dd0, 9, 0xb51dfeb0, LISSELECTED, false, 0xb6c96bf0) at gtk2wscustomlistview.inc:1103
1 TLISTITEM__SETSTATE(3, false, <error reading variable>) at ./include/listitem.inc:730
2 TCUSTOMLISTVIEW__DOSELECTITEM(0xb51dfeb0, false, <error reading variable>) at ./include/customlistview.inc:392
3 TCUSTOMLISTVIEW__CNNOTIFY({MSG = 48206, IDCTRL = -1214147332, NMHDR = 0xbfffdc00, RESULT = 0}, <error reading variable>) at ./include/customlistview.inc:266
4 SYSTEM_TOBJECT_$__DISPATCH$formal at :0
5 TCUSTOMLISTVIEW__COLCLICK(0xbfffdc2c, <error reading variable>) at ./include/customlistview.inc:174
6 TWINCONTROL__WNDPROC({MSG = 48206, WPARAM = -1214147332, LPARAM = -1073751040, RESULT = 0, WPARAMLO = 38140, WPARAMHI = 47009, LPARAMLO = 56320, LPARAMHI = 49151, RESULTLO = 0, RESULTHI = 0}, <error reading variable>) at ./include/wincontrol.inc:5284
7 DELIVERMESSAGE(0xb5741dd0, void) at lclmessageglue.pas:112
8 DELIVERMESSAGE(0xb5741dd0, void) at /home/etrusco/projetos/lazarus/lcl/interfaces/gtk/gtkproc.inc:3774
9 GTK2_ITEMSELECTIONCHANGED(0x8eaba60, 0xb51d4530) at gtk2wscustomlistview.inc:181
10 IA__g_cclosure_marshal_VOID__VOID(0x0, 0x0, 1, 0x8f34eb0, 0xbfffdd94, 0xb6c96bf0) at /build/buildd/glib2.0-2.24.0/gobject/gmarshal.c:77
11 IA__g_closure_invoke(0x8eacba0, 0x0, 1, 0x8f34eb0, 0xbfffdd94) at /build/buildd/glib2.0-2.24.0/gobject/gclosure.c:767
12 signal_emit_unlocked_R(<value optimized out>, <value optimized out>, 0x8eaba60, 0x0, 0x8f34eb0) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:3248
13 IA__g_signal_emit_valist(0x8eaba60, 175, 0, 0xbfffdf50 'U*'0000207#183#160#242#211#8#1) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:2981
14 IA__g_signal_emit(0x8eaba60, 175, 0) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:3038
15 _gtk_tree_selection_internal_select_node(0x8eaba60, 0x8eb6300, 0x8eb6418, 0x8d962a8, GTK_TREE_SELECT_MODE_TOGGLE, 0) at /build/buildd/gtk+2.0-2.20.0/gtk/gtktreeselection.c:1427
16 IA__gtk_tree_selection_select_path(0x8eaba60, 0x8d962a8) at /build/buildd/gtk+2.0-2.20.0/gtk/gtktreeselection.c:760
17 TGTK2WSCUSTOMLISTVIEW__ITEMSETSTATE(0xb5741dd0, 9, 0xb51dfeb0, LISSELECTED, true, 0xb6c96bf0) at gtk2wscustomlistview.inc:1107
18 TLISTITEM__SETSTATE(3, true, <error reading variable>) at ./include/listitem.inc:730
19 TCUSTOMLISTVIEW__DOSELECTITEM(0xb51dfeb0, true, <error reading variable>) at ./include/customlistview.inc:392
20 TCUSTOMLISTVIEW__CNNOTIFY({MSG = 48206, IDCTRL = -1214147332, NMHDR = 0xbfffe20c, RESULT = 0}, <error reading variable>) at ./include/customlistview.inc:272
21 SYSTEM_TOBJECT_$__DISPATCH$formal at :0
22 TCUSTOMLISTVIEW__COLCLICK(0xbfffe238, <error reading variable>) at ./include/customlistview.inc:174
23 TWINCONTROL__WNDPROC({MSG = 48206, WPARAM = -1214147332, LPARAM = -1073749492, RESULT = 0, WPARAMLO = 38140, WPARAMHI = 47009, LPARAMLO = 57868, LPARAMHI = 49151, RESULTLO = 0, RESULTHI = 0}, <error reading variable>) at ./include/wincontrol.inc:5284
24 DELIVERMESSAGE(0xb5741dd0, void) at lclmessageglue.pas:112
25 DELIVERMESSAGE(0xb5741dd0, void) at /home/etrusco/projetos/lazarus/lcl/interfaces/gtk/gtkproc.inc:3774
26 GTK2_ITEMSELECTIONCHANGED(0x8eaba60, 0xb51d4530) at gtk2wscustomlistview.inc:181
27 IA__g_cclosure_marshal_VOID__VOID(0x0, 0x0, 1, 0x8ec59b0, 0xbfffe3a0, 0xb528a0c8) at /build/buildd/glib2.0-2.24.0/gobject/gmarshal.c:77
28 IA__g_closure_invoke(0x8eacba0, 0x0, 1, 0x8ec59b0, 0xbfffe3a0) at /build/buildd/glib2.0-2.24.0/gobject/gclosure.c:767
29 signal_emit_unlocked_R(<value optimized out>, <value optimized out>, 0x8eaba60, 0x0, 0x8ec59b0) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:3248
30 IA__g_signal_emit_valist(0x8eaba60, 175, 0, 0xbfffe55c 'U*'0000207#183#160#242#211#8#1) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:2981
31 IA__g_signal_emit(0x8eaba60, 175, 0) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:3038
32 _gtk_tree_selection_internal_select_node(0x8eaba60, 0x8eb6300, 0x8eb6418, 0x8d81aa8, GTK_TREE_SELECT_MODE_TOGGLE, 1) at /build/buildd/gtk+2.0-2.20.0/gtk/gtktreeselection.c:1427
33 IA__gtk_tree_selection_unselect_path(0x8eaba60, 0x8d81aa8) at /build/buildd/gtk+2.0-2.20.0/gtk/gtktreeselection.c:796
34 TGTK2WSCUSTOMLISTVIEW__ITEMSETSTATE(0xb5741dd0, 9, 0xb51dfeb0, LISSELECTED, false, 0xb6c96bf0) at gtk2wscustomlistview.inc:1110
35 TLISTITEM__SETSTATE(3, false, <error reading variable>) at ./include/listitem.inc:730
36 TCUSTOMLISTVIEW__DOSELECTITEM(0xb51dfeb0, false, <error reading variable>) at ./include/customlistview.inc:392
37 TCUSTOMLISTVIEW__CNNOTIFY({MSG = 48206, IDCTRL = -1214147332, NMHDR = 0xbfffe818, RESULT = 0}, <error reading variable>) at ./include/customlistview.inc:266
38 SYSTEM_TOBJECT_$__DISPATCH$formal at :0
39 TCUSTOMLISTVIEW__COLCLICK(0xbfffe844, <error reading variable>) at ./include/customlistview.inc:174
40 TWINCONTROL__WNDPROC({MSG = 48206, WPARAM = -1214147332, LPARAM = -1073747944, RESULT = 0, WPARAMLO = 38140, WPARAMHI = 47009, LPARAMLO = 59416, LPARAMHI = 49151, RESULTLO = 0, RESULTHI = 0}, <error reading variable>) at ./include/wincontrol.inc:5284
41 DELIVERMESSAGE(0xb5741dd0, void) at lclmessageglue.pas:112
42 DELIVERMESSAGE(0xb5741dd0, void) at /home/etrusco/projetos/lazarus/lcl/interfaces/gtk/gtkproc.inc:3774
43 GTK2_ITEMSELECTIONCHANGED(0x8eaba60, 0xb51d4530) at gtk2wscustomlistview.inc:181
44 IA__g_cclosure_marshal_VOID__VOID(0x0, 0x0, 1, 0x8ec5968, 0xbfffe9ac, 0xb528a098) at /build/buildd/glib2.0-2.24.0/gobject/gmarshal.c:77
45 IA__g_closure_invoke(0x8eacba0, 0x0, 1, 0x8ec5968, 0xbfffe9ac) at /build/buildd/glib2.0-2.24.0/gobject/gclosure.c:767
46 signal_emit_unlocked_R(<value optimized out>, <value optimized out>, 0x8eaba60, 0x0, 0x8ec5968) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:3248
47 IA__g_signal_emit_valist(0x8eaba60, 175, 0, 0xbfffeb68 0000244#15#233#183#160#242#211#8#1) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:2981
48 IA__g_signal_emit(0x8eaba60, 175, 0) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:3038
49 _gtk_tree_selection_internal_select_node(0x8eaba60, 0x8eb6300, 0x8eb6418, 0x8d95c30, 0, 0) at /build/buildd/gtk+2.0-2.20.0/gtk/gtktreeselection.c:1427
50 gtk_tree_view_real_set_cursor(0x8d3f258, 0x8d95c30, 1, 1) at /build/buildd/gtk+2.0-2.20.0/gtk/gtktreeview.c:12569
51 gtk_tree_view_button_press(0x8d3f258, 0x8eba9e0) at /build/buildd/gtk+2.0-2.20.0/gtk/gtktreeview.c:2793
52 _gtk_marshal_BOOLEAN__BOXED(0x8c78200, 0xbfffee70, 2, 0x8d5f540, 0xbfffee5c, 0xb7d152e0) at /build/buildd/gtk+2.0-2.20.0/gtk/gtkmarshalers.c:84
53 g_type_class_meta_marshal(0x8c78200, 0xbfffee70, 2, 0x8d5f540, 0xbfffee5c, 0xb0) at /build/buildd/glib2.0-2.24.0/gobject/gclosure.c:878
54 IA__g_closure_invoke(0x8c78200, 0xbfffee70, 2, 0x8d5f540, 0xbfffee5c) at /build/buildd/glib2.0-2.24.0/gobject/gclosure.c:767
55 signal_emit_unlocked_R(<value optimized out>, <value optimized out>, 0x8d3f258, 0xbfffefb8, 0x8d5f540) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:3286
56 IA__g_signal_emit_valist(0x8d3f258, 33, 0, 0xbffff01c 'H'0000240#255#191'`'0000146#200#8'D'0000240#255#191#170#160#210#183#244#15#233#183'X'0000242#211#8'd'0000240#255#191'X'0000242#211#8'X'0000242#211#8'`'0000146#200#8'd'0000240#255#191) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:2991
57 IA__g_signal_emit(0x8d3f258, 33, 0) at /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:3038
58 gtk_widget_event_internal(<value optimized out>, 0x8eba9e0) at /build/buildd/gtk+2.0-2.20.0/gtk/gtkwidget.c:4951
59 IA__gtk_propagate_event(0x8d3f258, 0x8eba9e0) at /build/buildd/gtk+2.0-2.20.0/gtk/gtkmain.c:2447
60 IA__gtk_main_do_event(0x8eba9e0) at /build/buildd/gtk+2.0-2.20.0/gtk/gtkmain.c:1608
61 gdk_event_dispatch(0x8c72708, 0, 0x0) at /build/buildd/gtk+2.0-2.20.0/gdk/x11/gdkevents-x11.c:2372
62 g_main_dispatch at /build/buildd/glib2.0-2.24.0/glib/gmain.c:1960
63 IA__g_main_context_dispatch(0x8c72750) at /build/buildd/glib2.0-2.24.0/glib/gmain.c:2513
64 g_main_context_iterate(0x8c72750, <value optimized out>, 1, 0x8c519a0) at /build/buildd/glib2.0-2.24.0/glib/gmain.c:2591
65 IA__g_main_context_iteration(0x8c72750, 0) at /build/buildd/glib2.0-2.24.0/glib/gmain.c:2654
66 IA__gtk_main_iteration_do(0) at /build/buildd/gtk+2.0-2.20.0/gtk/gtkmain.c:1320
67 TGTKWIDGETSET__APPPROCESSMESSAGES(<error reading variable>) at /home/etrusco/projetos/lazarus/lcl/interfaces/gtk/gtkwidgetset.inc:1224
68 TAPPLICATION__HANDLEMESSAGE(<error reading variable>) at ./include/application.inc:1221
69 TAPPLICATION__RUNLOOP(<error reading variable>) at ./include/application.inc:1355
70 TWIDGETSET__APPRUN(0x8088bb0 <TAPPLICATION__RUNLOOP>, <error reading variable>) at ./include/interfacebase.inc:49
71 TAPPLICATION__RUN(<error reading variable>) at ./include/application.inc:1343
72 main at lazarus.pp:112
TagsNo tags attached.
Fixed in Revision25217
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0019806 closedFelipe Monteiro de Carvalho TListView under GTK2 does not issue OnSelect correctly 

Activities

Zeljan Rikalo

2010-05-04 08:59

developer   ~0037227

@Flavio it is very important that you write gtk2 version here. Seem that there's problem with gtk2 >= 2.18 since treeviews api is changed.
Yes, I forgot it. gtk is 2.20 (in Ubuntu 10.04).
FPC is 2.4 and Lazarus is latest svn.

Zeljan Rikalo

2010-05-04 21:31

developer   ~0037263

hm..it seem that it runs into loop when double clicked.

Zeljan Rikalo

2010-05-05 16:13

developer   ~0037288

Please test and close if ok.

Issue History

Date Modified Username Field Change
2010-05-04 08:48 Flávio Etrusco (notifications not working) New Issue
2010-05-04 08:48 Flávio Etrusco (notifications not working) LazTarget => -
2010-05-04 08:48 Flávio Etrusco (notifications not working) Widgetset => GTK 2
2010-05-04 08:49 Flávio Etrusco (notifications not working) Additional Information Updated
2010-05-04 08:50 Flávio Etrusco (notifications not working) Additional Information Updated
2010-05-04 08:59 Zeljan Rikalo Note Added: 0037227
2010-05-04 16:56 Flávio Etrusco (notifications not working) Note Added: 0037256
2010-05-04 21:31 Zeljan Rikalo Note Added: 0037263
2010-05-05 16:13 Zeljan Rikalo Fixed in Revision => 25217
2010-05-05 16:13 Zeljan Rikalo Status new => resolved
2010-05-05 16:13 Zeljan Rikalo Resolution open => fixed
2010-05-05 16:13 Zeljan Rikalo Assigned To => Zeljan Rikalo
2010-05-05 16:13 Zeljan Rikalo Note Added: 0037288
2010-05-05 17:16 Flávio Etrusco (notifications not working) Status resolved => closed
2010-05-05 17:16 Flávio Etrusco (notifications not working) Fixed in Version => 0.9.30
2011-07-27 20:42 Felipe Monteiro de Carvalho Relationship added related to 0019806