View Issue Details

IDProjectCategoryView StatusLast Update
0016477FPCFCLpublic2010-11-16 17:00
ReporterGraeme Geldenhuys Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformx86OSUbuntu Linux 
Product Version2.5.1 
Summary0016477: fcl-passrc & fpdoc doesn't understand the 'deprecated' syntax
Description'git bisect' reported that this problem existed as far back as 2009-04. From that I safely assume fcl-passrc never knew how to parse the 'deprecated' modifier.


---------[ fpdoc errors ]------------------
../Source/Core/tiVisitorDB.pas(160,16): Expected ";" at token "Identifier
deprecated"
----------------------------

Same code that causes the error with fpdoc:

------------[ tiVisitorDB.pas ]-------------
 // alias class will be removed soon.
 TVisOwnedQrySelect = class(TtiVisitorSelect)
 end deprecated; // <<-- error reported here
--------------------------------------------
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0016342 closedMarco van de Voort fcl-passrc cannot parse platform, library, deprecated hint directives 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2010-05-14 14:49 Graeme Geldenhuys New Issue
2010-05-14 15:08 Jonas Maebe Relationship added duplicate of 0016342
2010-05-14 15:08 Jonas Maebe Duplicate ID 0 => 16342
2010-05-14 15:08 Jonas Maebe Status new => resolved
2010-05-14 15:08 Jonas Maebe Resolution open => duplicate
2010-05-14 15:08 Jonas Maebe Assigned To => Jonas Maebe
2010-11-16 17:00 Jonas Maebe Status resolved => closed