View Issue Details

IDProjectCategoryView StatusLast Update
0016526LazarusWidgetsetpublic2011-12-01 11:25
ReporterMartin Friebe Assigned ToFelipe Monteiro de Carvalho  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version0.9.29 (SVN) 
Target Version0.9.30 
Summary0016526: Regression: TNotebook paint incorrect
Description1) TNotebook does not paint it's borders at all (right and bottom)

If you resize a window containing an alPage TNotebook, you will see that the small 1 or 2 pixel border on the right/bottom are not painted => they will be filled with random images.

This used to work, at least if the tabs are on Topof the notebook
For tabs on the right/left of the notebook, this issue existed for longer

----
2) TNotebook does not adjust the space needed for headers, if it switches to multi-line, due to resize of the notebook.
(e.g.) a Notebook with multiline enables starts with a single line of tabs (because they fit). As either tabs gets added or the the notebook is resized to a lesser width => the notebook needs a 2nd line of tabs => space is not allocated => tabs and content are painted corrupted
Additional Information1 can be seen on SourceEditor or Find in files => simply by resizing the window and looking at the white border around the notebook

2 can be seen by performing several "find in files"
TagsNo tags attached.
Fixed in Revision
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Relationships

has duplicate 0017007 closedVincent Snijders Multiline TabView is not repainted on Resize 
has duplicate 0017826 closedPaul Ishenin Multiline tabs in search results windows aren't displayed correctly 
related to 0017232 closedMattias Gaertner [partly regression] TPageControl's page width and height properties are updated only when the page is visible 
related to 0017741 closedVincent Snijders TCustomNotebook header sometimes not correctly redrawn with Multiline=True 

Activities

Paul Ishenin

2010-08-02 10:41

manager   ~0039876

Can't reproduce neither 1 nor 2 on a simple application. Please add a simplier case than IDE.

Martin Friebe

2010-08-03 03:21

manager   ~0039911

Only happens in the IDE (actually the find in files only) => so maybe the treeview (it has owner drawn stuff)...

I noted it is created with the NotebookPage as owner (instead of the form)

But I haven't had time to debug that yet...

---

tabs on the left do give a lot of drawing errors:
  Notebook1.TabPosition := tpLeft;

Paul Ishenin

2010-08-03 08:54

manager   ~0039917

Last edited: 2010-08-03 08:57

TabPosition is a known problem and not related to this report :)

I've attached the find in files as it looks here. Please show me what is wrong or attach your screenshot.

2010-08-03 08:56

 

screen.png (48,792 bytes)   
screen.png (48,792 bytes)   

2010-08-03 16:12

 

searchresult_error.png (61,840 bytes)   
searchresult_error.png (61,840 bytes)   

Martin Friebe

2010-08-03 16:17

manager   ~0039957

Last edited: 2010-08-03 16:20

3 pictures (pasted into one)

1) taken after reducing the height => look at the lower bottom, something is drawing there

2) reduced width => now the right edge
It appears to be, one of the treeviews, of one of the not active tab (the one in the active tab has text in the 3rd line, that would show)

3) Now multiline tab.
The upper blue line, is from one of the hidden tabs.

So the current visible tab, gets resized, repositioned and all.
But the tab(s) that are hidden, are not updated => yet they get painted?

---
In case: Vista (aero turned off)

Luiz Americo

2010-08-03 21:23

developer   ~0039962

I've seen this also (Windows XP - Classic theme)

Felipe Monteiro de Carvalho

2010-08-03 22:39

developer   ~0039965

TNotebook should not be used as a TPageControl, use TPageControl for that instead.

In the future when it's implementation is fixed TNotebook may loose it's tabs.

Felipe Monteiro de Carvalho

2010-09-27 11:02

developer   ~0041322

This bug report is invalid, because TNotebook is a wrongly implemented component scheduled for removal in Lazarus 0.9.31

Please use TPageControl instead and only use the correct TNotebook which will be introduced in Lazarus 0.9.31

Issue History

Date Modified Username Field Change
2010-05-20 13:51 Martin Friebe New Issue
2010-05-20 13:51 Martin Friebe LazTarget => -
2010-05-20 13:51 Martin Friebe Widgetset => Win32/Win64
2010-07-22 12:09 Martin Friebe Relationship added has duplicate 0017007
2010-07-31 23:43 Martin Friebe LazTarget - => 0.9.30
2010-07-31 23:43 Martin Friebe Target Version => 0.9.30
2010-08-02 10:41 Paul Ishenin Note Added: 0039876
2010-08-02 10:41 Paul Ishenin Status new => feedback
2010-08-03 03:21 Martin Friebe Note Added: 0039911
2010-08-03 08:54 Paul Ishenin Note Added: 0039917
2010-08-03 08:56 Paul Ishenin File Added: screen.png
2010-08-03 08:57 Paul Ishenin Note Edited: 0039917
2010-08-03 16:12 Martin Friebe File Added: searchresult_error.png
2010-08-03 16:17 Martin Friebe Note Added: 0039957
2010-08-03 16:20 Martin Friebe Note Edited: 0039957
2010-08-03 16:20 Martin Friebe Note Edited: 0039957
2010-08-03 21:23 Luiz Americo Note Added: 0039962
2010-08-03 22:39 Felipe Monteiro de Carvalho Note Added: 0039965
2010-08-21 23:39 Martin Friebe Relationship added related to 0017232
2010-09-27 11:02 Felipe Monteiro de Carvalho Status feedback => resolved
2010-09-27 11:02 Felipe Monteiro de Carvalho Resolution open => no change required
2010-09-27 11:02 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2010-09-27 11:02 Felipe Monteiro de Carvalho Note Added: 0041322
2010-10-28 16:42 Zeljan Rikalo Relationship added related to 0017741
2010-11-04 16:46 Vincent Snijders Relationship added has duplicate 0017826
2011-12-01 11:25 Marc Weustink Status resolved => closed