View Issue Details

IDProjectCategoryView StatusLast Update
0016601FPCDatabasepublic2011-04-25 15:18
ReporterChristian Ortiz Assigned ToJoost van der Sluis  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionunable to reproduce 
Summary0016601: libpq in MAC
DescriptionWhen i try to connect to a PostgreSQL database in MacOSX (leopard 10.5.6 intel )display the error : None of the dynamic libraries can be found libpq.so.4, libpq.so.

i have the libpq.dylib in /usr/lib

it solves renaming the file libpq.dylib (macosx file extension) to libpq.so (linux file extension)

TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

Joost van der Sluis

2010-07-22 10:28

manager   ~0039592

I think this is fixed in recent fpc versions. So what fpc-version are you using?

Christian Ortiz

2010-07-24 17:35

reporter   ~0039667

My actual version is 2.4.0, i will try last fpc

Jonas Maebe

2010-11-02 20:25

manager   ~0042665

It should have been fixed already in FPC 2.4.0. Are you using the postgres3dyn unit?

Marco van de Voort

2011-03-30 13:06

manager   ~0046947

No feedback, last call before closing.

Issue History

Date Modified Username Field Change
2010-05-30 20:45 Christian Ortiz New Issue
2010-05-30 20:45 Christian Ortiz Widgetset => Carbon
2010-07-22 10:27 Joost van der Sluis Status new => assigned
2010-07-22 10:27 Joost van der Sluis Assigned To => Joost van der Sluis
2010-07-22 10:28 Joost van der Sluis Note Added: 0039592
2010-07-24 17:35 Christian Ortiz Note Added: 0039667
2010-11-02 19:01 Vincent Snijders Project Lazarus => FPC
2010-11-02 20:25 Jonas Maebe Note Added: 0042665
2010-12-05 09:59 Marco van de Voort Status assigned => feedback
2011-03-30 13:06 Marco van de Voort Note Added: 0046947
2011-04-25 15:18 Joost van der Sluis Status feedback => closed
2011-04-25 15:18 Joost van der Sluis Resolution open => unable to reproduce