View Issue Details

IDProjectCategoryView StatusLast Update
0016615LazarusWidgetsetpublic2010-06-10 10:29
ReporterDRIGUS GmbHAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0016615: TForm in WinCE: Height at runtime is wrong when BorderStyle = bsDialog
DescriptionAt run time the height of a TForm with BorderStyle = bsDialog differs from the height at design time. Seems to me that the offset is the height of the caption bar - perhaps a problem with Height/ClientHeight?

(This isn't reproducible using the Win32 WdgetSet.)
Additional InformationLazarus 0.9.29 r25811
FPC 2.4.1
i386-win32-win32/win64

Windows CE 6.0 ARM Device
(no SmartPhone / PocketPC)
TagsNo tags attached.
Fixed in Revision26007
LazTarget-
WidgetsetWinCE
Attached Files

Relationships

related to 0017304 closedFelipe Monteiro de Carvalho [WinCE] Extra window above taskbar 

Activities

2010-06-01 16:20

 

2010_6_1__16_12_17.PNG (22,030 bytes)
2010_6_1__16_12_17.PNG (22,030 bytes)

2010-06-01 16:21

 

Lazarus.zip (738,729 bytes)

Felipe Monteiro de Carvalho

2010-06-01 18:01

developer   ~0038217

Does the current code detect your device type? I mean, what is the value of Application.ApplicationType after Application.Initialize ?

It should be atDesktop.

2010-06-02 10:05

 

device.jpg (21,844 bytes)
device.jpg (21,844 bytes)

DRIGUS GmbH

2010-06-02 10:06

reporter   ~0038236

It is atPDA. I manually changed it to atDesktop in the project source, just before calling Application.Initialize. But the result seems to be the same, only the OK button in the caption bar disappeared.

The device is based on a ARM COM with a 800*600 touch screen and a keyboard. I uploaded a picture to make it clear.

Felipe Monteiro de Carvalho

2010-06-09 17:33

developer   ~0038434

It should be fixed now. By the way, could you add another button to your application and tell me what does it write to your caption? I am curious about what String it writes to your application.

uses Windows;

procedure TForm1.Button2Click(Sender: TObject);
var
  buf: array[0..50] of WideChar;
  bufPtr: PWideChar;
  WideStr: widestring;
begin
  if Windows.SystemParametersInfo(SPI_GETPLATFORMTYPE, sizeof(buf), @buf, 0) then
  begin
    BufPtr := @Buf[0];
    unaligned(WideStr) := unaligned(WideString(BufPtr));
    Caption := UTF16ToUTF8(WideStr);
  end;
end;

Also, very strange that the OK button disappears, I just looked at the code here and it shouldn't disappear in atDesktop mode, and it doesn't disappear in my PocketPC emulator ...

DRIGUS GmbH

2010-06-10 10:29

reporter   ~0038446

Lazarus 0.9.29 r26016 FPC 2.4.1 i386-win32-win32/win64
Fixed, thx.

SPI_GETPLATFORMTYPE returns the product name of the single board computer we use in this device, chosen by the manufacturer of the COM.

About the OK button: Regarding WinCEProc.BorderStyleToWinAPIFlagsEx it seems logical to me that there is no OK button in atDesktop mode, because it is explicit added in atPDA, atKeyPadDevice and atDefault modes.

(Should I close this issue?)

Issue History

Date Modified Username Field Change
2010-06-01 16:20 DRIGUS GmbH New Issue
2010-06-01 16:20 DRIGUS GmbH File Added: 2010_6_1__16_12_17.PNG
2010-06-01 16:20 DRIGUS GmbH Widgetset => WinCE
2010-06-01 16:21 DRIGUS GmbH File Added: Lazarus.zip
2010-06-01 18:01 Felipe Monteiro de Carvalho LazTarget => -
2010-06-01 18:01 Felipe Monteiro de Carvalho Note Added: 0038217
2010-06-01 18:01 Felipe Monteiro de Carvalho Status new => assigned
2010-06-01 21:11 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2010-06-02 10:05 DRIGUS GmbH File Added: device.jpg
2010-06-02 10:06 DRIGUS GmbH Note Added: 0038236
2010-06-09 17:33 Felipe Monteiro de Carvalho Fixed in Revision => 26007
2010-06-09 17:33 Felipe Monteiro de Carvalho Status assigned => resolved
2010-06-09 17:33 Felipe Monteiro de Carvalho Fixed in Version => 0.9.29 (SVN)
2010-06-09 17:33 Felipe Monteiro de Carvalho Resolution open => fixed
2010-06-09 17:33 Felipe Monteiro de Carvalho Note Added: 0038434
2010-06-10 10:29 DRIGUS GmbH Status resolved => closed
2010-06-10 10:29 DRIGUS GmbH Note Added: 0038446
2010-09-15 14:45 Felipe Monteiro de Carvalho Relationship added related to 0017304