View Issue Details

IDProjectCategoryView StatusLast Update
0016650LazarusIDEpublic2011-06-19 03:49
Reportersamuel herzogAssigned ToMattias Gaertner 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Platformwin32OSxpOS Versionsp3
Product Version0.9.29 (SVN)Product Build25948 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0016650: Feature "desktop files (.lds)" does not work correctly.
DescriptionWhen saving and reloading an .lds the compiler-path seems to get lost.
Steps To Reproduce1. Choose "Environment"->"Options"->"Desktop".
2. Press button "Save desktop settings to file" and save for example to c:\
3. Close and re-open lazarus.
4. go again to "Environment"->"Options"->"Desktop".
5. Press button "Load desktop settings from file" to load the .lds file.

Now the compiler path is gone and you can not compile anymore.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

2010-06-12 11:52

 

2010-06-12 11:53

 

invalid_compiler.jpg (27,217 bytes)
invalid_compiler.jpg (27,217 bytes)

2010-06-12 11:53

 

FPC_Path_missing.jpg (77,010 bytes)
FPC_Path_missing.jpg (77,010 bytes)

samuel herzog

2010-07-23 10:51

developer   ~0039609

I tested today again and found now that it complains with this message
'TEnvironmentOptions.CreateWindowLayout TheFormID exists'
when saving the desktop.


function TSimpleWindowLayoutList.CreateWindowLayout(const TheFormID: string
  ): TSimpleWindowLayout;
begin
  if TheFormID='' then
    raise Exception.Create('TEnvironmentOptions.CreateWindowLayout TheFormID empty');
  if ItemByFormID(TheFormID)<>nil then
    raise Exception.Create('TEnvironmentOptions.CreateWindowLayout TheFormID exists');
  Result:=TSimpleWindowLayout.Create(TheFormID);
  Add(Result);
end;

samuel herzog

2010-07-23 17:08

developer   ~0039618

By the way...
I like exception messages which contain some information:

instead of

raise Exception.Create('TEnvironmentOptions.CreateWindowLayout TheFormID exists');

this would be much better!

raise Exception.CreateFmt('TEnvironmentOptions.CreateWindowLayout TheFormID <%s> exists',[TheFormID]);

Mattias Gaertner

2010-07-23 17:13

manager   ~0039619

If the message would be for the user, it would be translated.
This is an internal consistency check, that should never happen.

samuel herzog

2010-07-23 17:29

developer   ~0039621

Yes, you are right.
That should never happen ;-)

samuel herzog

2011-03-28 05:42

developer   ~0046869

Seems to be ok now. Tested today with Lazarus 0.9.31 r30043 FPC 2.4.3 i386-win32-win32/win64.

Thanks.

Issue History

Date Modified Username Field Change
2010-06-06 12:13 samuel herzog New Issue
2010-06-06 12:13 samuel herzog LazTarget => -
2010-06-12 11:52 samuel herzog File Added: Please_Check_the_compiler_Name.jpg
2010-06-12 11:53 samuel herzog File Added: invalid_compiler.jpg
2010-06-12 11:53 samuel herzog File Added: FPC_Path_missing.jpg
2010-07-23 10:51 samuel herzog Note Added: 0039609
2010-07-23 15:27 Mattias Gaertner Status new => assigned
2010-07-23 15:27 Mattias Gaertner Assigned To => Mattias Gaertner
2010-07-23 17:08 samuel herzog Note Added: 0039618
2010-07-23 17:13 Mattias Gaertner Note Added: 0039619
2010-07-23 17:29 samuel herzog Note Added: 0039621
2011-03-28 05:42 samuel herzog Status assigned => resolved
2011-03-28 05:42 samuel herzog Fixed in Version => 0.9.31 (SVN)
2011-03-28 05:42 samuel herzog Resolution open => fixed
2011-03-28 05:42 samuel herzog Note Added: 0046869
2011-06-19 03:49 samuel herzog Status resolved => closed
2011-06-19 03:49 samuel herzog Target Version 1.0.0 => 0.99.0