View Issue Details

IDProjectCategoryView StatusLast Update
0016659LazarusWidgetsetpublic2011-12-01 11:24
ReporterJohn vd WaeterAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0016659: WinCE: TEdit draws ugly when app is "hiresaware"
DescriptionFont inside TEdit has wrong vertical offset when app is made hiresaware.

Tested on WM 6.5 Professional VGA emulator.
TagsNo tags attached.
Fixed in Revision26870
LazTarget-
WidgetsetWinCE
Attached Files

Relationships

related to 0016661 closedFelipe Monteiro de Carvalho WinCE: Checkbox Autosize does not reflect caption-width when caption changed at runtime 

Activities

Felipe Monteiro de Carvalho

2010-06-10 17:59

developer   ~0038459

How do you make an app "hiresaware"?

John vd Waeter

2010-06-10 18:44

reporter   ~0038463

By creating a resource 'hiresaware.res', which contains

HI_RES_AWARE CEUX DISCARDABLE
BEGIN
 0x0001
END

Note that this has only effect on devices with screens larger then 240x320
I tried with device emulator professional VGA (480x640)

John vd Waeter

2010-07-17 23:10

reporter   ~0039419

If I set the Editboxes properties like:
- Autosize := false
- Height := 4* font.size

then the editbox looks fine on hiresaware (=480x800) apps but is twice the normal height on non-hiresaware apps (240x320)

Felipe Monteiro de Carvalho

2010-07-28 11:14

developer   ~0039735

I see, the problem is that the font is much larger in higher resolution, but somehow the autosizing doesn't understand that...

Felipe Monteiro de Carvalho

2010-07-28 12:59

developer   ~0039742

I fixed TEdit and TButton autosizing. Works now in my emulator

Issue History

Date Modified Username Field Change
2010-06-07 13:47 John vd Waeter New Issue
2010-06-07 13:47 John vd Waeter Widgetset => WinCE
2010-06-10 17:58 Felipe Monteiro de Carvalho Status new => assigned
2010-06-10 17:58 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2010-06-10 17:59 Felipe Monteiro de Carvalho Note Added: 0038459
2010-06-10 18:01 Felipe Monteiro de Carvalho Relationship added related to 0016661
2010-06-10 18:44 John vd Waeter Note Added: 0038463
2010-07-17 23:10 John vd Waeter Note Added: 0039419
2010-07-28 11:14 Felipe Monteiro de Carvalho Note Added: 0039735
2010-07-28 12:59 Felipe Monteiro de Carvalho Fixed in Revision => 26870
2010-07-28 12:59 Felipe Monteiro de Carvalho LazTarget => -
2010-07-28 12:59 Felipe Monteiro de Carvalho Status assigned => resolved
2010-07-28 12:59 Felipe Monteiro de Carvalho Fixed in Version => 0.9.29 (SVN)
2010-07-28 12:59 Felipe Monteiro de Carvalho Resolution open => fixed
2010-07-28 12:59 Felipe Monteiro de Carvalho Note Added: 0039742
2011-12-01 11:24 Marc Weustink Status resolved => closed