View Issue Details

IDProjectCategoryView StatusLast Update
0016661LazarusWidgetsetpublic2011-12-01 11:24
ReporterJohn vd WaeterAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0016661: WinCE: Checkbox Autosize does not reflect caption-width when caption changed at runtime
DescriptionA autosize issue:
When setting the text of a TCheckbox at runtime in a hires-aware app the width of the TCheckbox is wrongly adapted.

tested on Win 6.5 emulator, Professional VGA

TagsNo tags attached.
Fixed in Revision26897
LazTarget-
WidgetsetWinCE
Attached Files

Relationships

related to 0016659 closedFelipe Monteiro de Carvalho WinCE: TEdit draws ugly when app is "hiresaware" 

Activities

John vd Waeter

2010-06-07 14:15

reporter   ~0038364

Maybe related:
the square check area and the check-sign are drawn disproportional as well.

Felipe Monteiro de Carvalho

2010-07-29 11:49

developer   ~0039784

Please test.

From what I understood in this hires-aware mode everything is bigger. Fonts are much bigger,etc, so you need to set AutoSize to true in as many controls as possible. Then if I understood correctly, the advantage of this mode is that you have more pixels to draw graphics?

2010-07-29 14:00

 

testhires.zip (66,304 bytes)

John vd Waeter

2010-07-29 14:04

reporter   ~0039791

Yes it is. And for having more (readable) text on a line.
In testhires, please see the differences. Compile and run on wm5/6 pocketpc, wm5/6 smartphone and wm6 Prof VGA emulator. The last one has the biggest (resizing) problems. If no hiresaware flag is set in the resources, everything is scaled to 240x320. If the flag is set, this rescaling should not take place and pixelsizes should remain. However, it looks like this hiresawre-flag is not always respected. I don't know if this is a Lazarus or Windows issue.

Issue History

Date Modified Username Field Change
2010-06-07 14:13 John vd Waeter New Issue
2010-06-07 14:13 John vd Waeter Widgetset => WinCE
2010-06-07 14:15 John vd Waeter Note Added: 0038364
2010-06-10 18:01 Felipe Monteiro de Carvalho Relationship added related to 0016659
2010-06-10 18:02 Felipe Monteiro de Carvalho Status new => assigned
2010-06-10 18:02 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2010-07-29 11:49 Felipe Monteiro de Carvalho Fixed in Revision => 26897
2010-07-29 11:49 Felipe Monteiro de Carvalho LazTarget => -
2010-07-29 11:49 Felipe Monteiro de Carvalho Status assigned => resolved
2010-07-29 11:49 Felipe Monteiro de Carvalho Fixed in Version => 0.9.29 (SVN)
2010-07-29 11:49 Felipe Monteiro de Carvalho Resolution open => fixed
2010-07-29 11:49 Felipe Monteiro de Carvalho Note Added: 0039784
2010-07-29 14:00 John vd Waeter File Added: testhires.zip
2010-07-29 14:04 John vd Waeter Note Added: 0039791
2011-12-01 11:24 Marc Weustink Status resolved => closed