View Issue Details

IDProjectCategoryView StatusLast Update
0016715LazarusLCLpublic2010-10-20 12:27
ReporterTomasz WieckowskiAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0016715: Mouse over speedbutton
DescriptionSpeedbutton (on form1) sets as highlighted when hovering with mouse over it from form2.
Run attached project, click on Button1 then from Form2 move mouse directly to SpeedButton, SpeedButton is highlighted, but it should not.

Windows XP/32
TagsNo tags attached.
Fixed in Revision27770
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Activities

2010-06-12 16:03

 

testA.zip (112,923 bytes)

Tomasz Wieckowski

2010-06-12 16:18

reporter   ~0038515

Speedbutton sets as highlighted only if mouse move directly from form2. If mouse move from Form2 to Form1 and then to SpeedButton, then is ok.

Tomasz Wieckowski

2010-10-19 20:20

reporter   ~0041918

This bug still exists, I just checked on Linux/gtk and everything is ok. So the problem is only on Windows.

Maxim Ganetsky

2010-10-20 01:17

developer   ~0041924

Confirmed. Lazarus 0.9.29 r27765 FPC 2.4.3 i386-win32-win32/win64 (WinXP SP2 32 bit).

Paul Ishenin

2010-10-20 10:02

manager   ~0041931

Please test and close if ok.

Tomasz Wieckowski

2010-10-20 12:27

reporter   ~0041935

Thanks. Works perfect now.

Issue History

Date Modified Username Field Change
2010-06-12 16:03 Tomasz Wieckowski New Issue
2010-06-12 16:03 Tomasz Wieckowski File Added: testA.zip
2010-06-12 16:03 Tomasz Wieckowski Widgetset => Win32/Win64
2010-06-12 16:18 Tomasz Wieckowski Note Added: 0038515
2010-10-19 20:20 Tomasz Wieckowski Note Added: 0041918
2010-10-20 01:17 Maxim Ganetsky LazTarget => -
2010-10-20 01:17 Maxim Ganetsky Note Added: 0041924
2010-10-20 01:17 Maxim Ganetsky Status new => confirmed
2010-10-20 10:02 Paul Ishenin Fixed in Revision => 27770
2010-10-20 10:02 Paul Ishenin LazTarget - => 0.9.30
2010-10-20 10:02 Paul Ishenin Status confirmed => resolved
2010-10-20 10:02 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-10-20 10:02 Paul Ishenin Resolution open => fixed
2010-10-20 10:02 Paul Ishenin Assigned To => Paul Ishenin
2010-10-20 10:02 Paul Ishenin Note Added: 0041931
2010-10-20 10:03 Paul Ishenin Target Version => 0.9.30
2010-10-20 12:27 Tomasz Wieckowski Note Added: 0041935
2010-10-20 12:27 Tomasz Wieckowski Status resolved => closed