View Issue Details

IDProjectCategoryView StatusLast Update
0016797LazarusLCLpublic2010-07-09 00:31
ReporterOpenLieroXor Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.28.2 
Summary0016797: Can't open a file from Windows 7 library using OpenDialog
DescriptionIt's not possible to open a file which is located in the Windows 7 library, using TOpenDialog or TOpenPictureDialog. When you select such file, the FileName property contains only name of file, without path, so it can't be opened. It happens only when you try to open a file which is located in the main library directory, when the file is located in a subdirectory, everything works without problems.
TagsNo tags attached.
Fixed in Revision26471
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Activities

Dmitry Boyarintsev

2010-06-30 08:22

developer   ~0038880

How do you manage to copy a file to the Library root?

Windows Explorer doesn't allow me to do this. As far as I can see "Library" is virtual folder, created by Windows Shell, not the real directory.

Can other applications (i.e. Notepad) open a file at the Library root?

OpenLieroXor

2010-06-30 11:28

reporter   ~0038881

Sorry if I didn't explained it clearly. By main library directory I mean directory of the single libraty, for exemple '\Libraries\Documents'. And when you try to open file '\Libraries\Documents\something.txt' the bug appears. But when you open a file from subdirectory in library, for example '\Libraries\Documents\newfolder\something.txt' everything is ok.

Yes, Notepad is able to open such files. Also my old Delphi 7 applications don't have problem with that.

OpenLieroXor

2010-07-05 11:22

reporter   ~0039026

I also noticed that there is the same problem with TSaveDialog too.

Dmitry Boyarintsev

2010-07-05 15:50

developer   ~0039037

please test and close if ok

OpenLieroXor

2010-07-07 20:58

reporter   ~0039118

I've tested the latest Lazarus snapshot, and now file opening works properly.
However, there is a small issue: after opening a file from the library, when the open dialog is executed second time, the initial directory is not the directory of the library (where the first file was selected to open), but the directory where the file is really located. For example: I open a file '\Libraries\Documents\aaa.txt', I open the dialog again, and it shows up with opened directory 'C:\Users\(username)\Documents\', which is the real directory of the file. But the dialog should open with the library directory. It isn't a very serious problem, but it doesn't appear with other applications, like Notepad.

OpenLieroXor

2010-07-07 21:00

reporter   ~0039119

Last edited: 2010-07-07 21:01

There's a small problem with the InitialDir, which I described in previous note, so I reopen.

Dmitry Boyarintsev

2010-07-08 19:40

developer   ~0039154

The open/save dialog changes initial dir to the directory of the last opened file. Eventually the real path would be used.

Old Windows API doesn't allow open virtual "Library" directory. So this cannot be implemented easily.

If you insist on implementing the required feature please create a new bug report. But I doubt if it would be implemented any time soon.

please close this issue, since it's working fine now.

Issue History

Date Modified Username Field Change
2010-06-27 13:30 OpenLieroXor New Issue
2010-06-27 13:30 OpenLieroXor Widgetset => Win32/Win64
2010-06-30 08:22 Dmitry Boyarintsev LazTarget => -
2010-06-30 08:22 Dmitry Boyarintsev Note Added: 0038880
2010-06-30 08:22 Dmitry Boyarintsev Status new => feedback
2010-06-30 11:28 OpenLieroXor Note Added: 0038881
2010-07-05 11:22 OpenLieroXor Note Added: 0039026
2010-07-05 15:50 Dmitry Boyarintsev Fixed in Revision => 26471
2010-07-05 15:50 Dmitry Boyarintsev LazTarget - => 0.9.30
2010-07-05 15:50 Dmitry Boyarintsev Status feedback => resolved
2010-07-05 15:50 Dmitry Boyarintsev Resolution open => fixed
2010-07-05 15:50 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2010-07-05 15:50 Dmitry Boyarintsev Note Added: 0039037
2010-07-07 20:58 OpenLieroXor Note Added: 0039118
2010-07-07 21:00 OpenLieroXor Status resolved => assigned
2010-07-07 21:00 OpenLieroXor Resolution fixed => reopened
2010-07-07 21:00 OpenLieroXor Note Added: 0039119
2010-07-07 21:01 OpenLieroXor Note Edited: 0039119
2010-07-08 19:40 Dmitry Boyarintsev Status assigned => resolved
2010-07-08 19:40 Dmitry Boyarintsev Resolution reopened => fixed
2010-07-08 19:40 Dmitry Boyarintsev Note Added: 0039154
2010-07-09 00:31 OpenLieroXor Status resolved => closed