View Issue Details

IDProjectCategoryView StatusLast Update
0016901FPCCompilerpublic2010-07-18 00:05
ReporterInoussa OUEDRAOGO Assigned ToJonas Maebe  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionduplicate 
Platformwin32OSWindowsXP 32 Bits 
Product Version2.5.1 
Summary0016901: Access Violation when assigning "Self" to local interface Reference in constructor
DescriptionThe atached program crash :

F:\Inoussa\fpc\tests\fpc-intf1>project1.exe
An unhandled exception occurred at $00000000 :
EAccessViolation : Access violation
  $00000000
  $004060E9
  $0040163D P$PROJECT1_finalize_implicit, of project1.lpr
  $00407378
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0016592 closedJonas Maebe AfterConstruction regression 

Activities

2010-07-10 23:02

 

project1.lpr (313 bytes)

Jonas Maebe

2010-07-10 23:16

manager   ~0039253

I guess this may be the same issue as 0016592

Inoussa OUEDRAOGO

2010-07-10 23:30

reporter   ~0039254

Not sure, this program works when compiled by fpc 2.2.2/2.2.4/2.4.0 and Delphi7

Jonas Maebe

2010-07-10 23:39

manager   ~0039255

So does the other one.

Inoussa OUEDRAOGO

2010-07-18 00:05

reporter   ~0039421

It works now, thank you very much.

Issue History

Date Modified Username Field Change
2010-07-10 23:02 Inoussa OUEDRAOGO New Issue
2010-07-10 23:02 Inoussa OUEDRAOGO File Added: project1.lpr
2010-07-10 23:15 Jonas Maebe Relationship added related to 0016592
2010-07-10 23:16 Jonas Maebe Note Added: 0039253
2010-07-10 23:30 Inoussa OUEDRAOGO Note Added: 0039254
2010-07-10 23:39 Jonas Maebe Note Added: 0039255
2010-07-15 21:25 Jonas Maebe Relationship replaced duplicate of 0016592
2010-07-15 21:27 Jonas Maebe Duplicate ID 0 => 16592
2010-07-15 21:27 Jonas Maebe Status new => resolved
2010-07-15 21:27 Jonas Maebe Resolution open => duplicate
2010-07-15 21:27 Jonas Maebe Assigned To => Jonas Maebe
2010-07-18 00:05 Inoussa OUEDRAOGO Status resolved => closed
2010-07-18 00:05 Inoussa OUEDRAOGO Note Added: 0039421