View Issue Details

IDProjectCategoryView StatusLast Update
0016929LazarusWidgetsetpublic2011-09-18 23:06
Reporterwht244 Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version0.9.28.3 (SVN) 
Summary0016929: Cannot activate application by clicking on the background window when ShowModal is used on other window
DescriptionIn Delphi, when application shows window in ShowModal function, user can activate this window by clicking on the background window. In Lazarus, user can't do so, so, when the other application is running and it covers the ShowModal form and not covers background form of the same application, user needs to switch the application with Alt+Tab or minimize the application he's currently using.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0019069 closedPaul Ishenin Wrong modal form behavior in windows 

Activities

Juha Manninen

2011-09-18 15:42

developer   ~0051981

In a forum thread
 http://lazarus.freepascal.org/index.php/topic,14668.msg78016/topicseen.html#new
jixian.yang writes as a solution:
 Just set Application.MainFormOnTaskbar := True.

Anton

2011-09-18 19:17

reporter   ~0051990

Last edited: 2011-09-18 19:18

duplicate 0019069

Juha Manninen

2011-09-18 23:06

developer   ~0052001

Resolved because has duplicate.

Issue History

Date Modified Username Field Change
2010-07-14 17:39 wht244 New Issue
2010-07-14 17:39 wht244 Widgetset => Win32/Win64
2010-10-29 13:34 Vincent Snijders LazTarget => -
2010-10-29 13:34 Vincent Snijders Status new => acknowledged
2011-09-18 15:42 Juha Manninen Note Added: 0051981
2011-09-18 19:17 Anton Note Added: 0051990
2011-09-18 19:18 Anton Note Edited: 0051990
2011-09-18 23:05 Juha Manninen Relationship added duplicate of 0019069
2011-09-18 23:06 Juha Manninen Duplicate ID 0 => 19069
2011-09-18 23:06 Juha Manninen Status acknowledged => resolved
2011-09-18 23:06 Juha Manninen Resolution open => duplicate
2011-09-18 23:06 Juha Manninen Assigned To => Juha Manninen
2011-09-18 23:06 Juha Manninen Note Added: 0052001