View Issue Details

IDProjectCategoryView StatusLast Update
0016941LazarusPatchpublic2017-11-14 11:10
ReporterMarcelo B PaulaAssigned ToJesus Reyes 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0016941: NewField form is not Delphi compatible. It misses Field Type Data
DescriptionThe NewField form is used to insert TFields into a DataSet. Delphi permits to insert fields of type DATA,CALCULATED and LOOKUP (INTERNALCALC and AGGREGATES TClientData specific not used in Lazarus).
This is critical when using Memory DataSets like TBufDataSet, because without this type, these datasets is useless.

Follow suggested patch to solve the problem.
Zip file contains regenerated .po file in portuguese language too.
Additional InformationPS: Tested with Lazarus 0.9.29 rev 26670 - win32 - FPC 2.5.1
TagsNo tags attached.
Fixed in Revision26694
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0032692 closedJuha Manninen Adding TAGGREGATE Field to Sqlquery 

Activities

2010-07-16 02:45

 

newfieldupd.zip (10,772 bytes)

2010-07-16 02:46

 

newfield.PNG (14,131 bytes)
newfield.PNG (14,131 bytes)

Joost van der Sluis

2010-07-16 10:52

manager   ~0039380

Note that the remark about TBufDataset being useless is nonsense. That's because a new dataset is created based on the TFieldDefs, not on the TFields.

So to create a dataset the programmer have to add TFieldDefs, which is already possible.

Nonetheless this is a good fix for persistent fields. Although there are other options to add data-TFields, this could be added.

Jesus Reyes

2010-07-16 21:25

developer   ~0039397

Applied, thanks.

Marcelo B Paula

2010-07-16 23:53

reporter   ~0039408

Thank you.

Issue History

Date Modified Username Field Change
2010-07-16 02:45 Marcelo B Paula New Issue
2010-07-16 02:45 Marcelo B Paula File Added: newfieldupd.zip
2010-07-16 02:45 Marcelo B Paula Widgetset => Win32/Win64
2010-07-16 02:46 Marcelo B Paula File Added: newfield.PNG
2010-07-16 10:52 Joost van der Sluis Note Added: 0039380
2010-07-16 21:00 Jesus Reyes Status new => assigned
2010-07-16 21:00 Jesus Reyes Assigned To => Jesus Reyes
2010-07-16 21:25 Jesus Reyes Fixed in Revision => 26694
2010-07-16 21:25 Jesus Reyes LazTarget => 0.9.30
2010-07-16 21:25 Jesus Reyes Status assigned => resolved
2010-07-16 21:25 Jesus Reyes Fixed in Version => 0.9.29 (SVN)
2010-07-16 21:25 Jesus Reyes Resolution open => fixed
2010-07-16 21:25 Jesus Reyes Note Added: 0039397
2010-07-16 21:25 Jesus Reyes Target Version => 0.9.30
2010-07-16 23:53 Marcelo B Paula Status resolved => closed
2010-07-16 23:53 Marcelo B Paula Note Added: 0039408
2017-11-14 11:10 Juha Manninen Relationship added related to 0032692