View Issue Details

IDProjectCategoryView StatusLast Update
0016944LazarusIDEpublic2010-07-19 14:33
ReporterAlexander S. Klenin Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version0.9.30 
Summary0016944: Package Editor: Context menu items do nothing
DescriptionAlso, pressing Enter does not open the selected file,
despite the FilesTreeViewKeyPress handler.
Steps To Reproduce1) Open package editor
2a) Right+click on file in the tree view
2b) Click on 'More' button
3) Select any item
=>
Nothing happens
TagsNo tags attached.
Fixed in Revision26734
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0016950 closedPaul Ishenin OnKeyPress event never gets called 

Activities

Mattias Gaertner

2010-07-16 09:03

manager   ~0039375

The move file down was broken. I fixed that.
The rest seems to work.
Which other one does not work?

Note: Some widgetsets do not show disabled menu items as disabled.

2010-07-16 09:21

 

packageeditor_context_menu.png (14,826 bytes)   
packageeditor_context_menu.png (14,826 bytes)   

Alexander S. Klenin

2010-07-16 09:26

developer   ~0039378

>Which other one does not work?
All of them. It seems like clicks are simply ignored --
I added debug output to, e.g. OpenFileMenuItemClick, and it was not triggered.

>Some widgetsets do not show disabled menu items as disabled.
As you can see on attached screenshot, WinWP does not have this problem.

Mattias Gaertner

2010-07-16 09:45

manager   ~0039379

It works under qt, gtk2 and carbon.
It is a win32 interface issue.

Alexander S. Klenin

2010-07-16 21:45

developer   ~0039399

Hm, I thought that 16950 may be the reason
why FilesTreeViewKeyPress does not work.

Mattias Gaertner

2010-07-16 22:00

manager   ~0039401

I don't see the relationship between popup menu item click and OnKeyPress. Can you explain?

Alexander S. Klenin

2010-07-16 22:09

developer   ~0039402

See description of this bug.
I should have probably filed a separate bug for FilesTreeViewKeyPress problem,
but I felt it would be too much of a bug spam.

samuel herzog

2010-07-18 11:33

developer   ~0039426

I can confirm this problem on win32 xp sp3. Current SVN Revision 26722.

Paul Ishenin

2010-07-19 08:08

manager   ~0039443

Revision 26415 breaks the package editor under windows. At windows close happens before the WM_COMMAND message which triggers the OnClick event handler. As result popup menu contains 0 items when WM_COMMAND happens and Find by item command and therefore click event fails.

Reverting the change of packageeditor of 26415 (which seems unrelated to bitmap handling) restores the popup menu clicks.

Mattias Gaertner

2010-07-19 12:46

manager   ~0039449

Thanks Paul.
I added this trap to the documentation and restrictions.

Alexander S. Klenin

2010-07-19 14:33

developer   ~0039458

Thanks, it works now

Issue History

Date Modified Username Field Change
2010-07-16 07:06 Alexander S. Klenin New Issue
2010-07-16 07:06 Alexander S. Klenin LazTarget => -
2010-07-16 08:55 Mattias Gaertner Status new => assigned
2010-07-16 08:55 Mattias Gaertner Assigned To => Mattias Gaertner
2010-07-16 09:03 Mattias Gaertner Note Added: 0039375
2010-07-16 09:03 Mattias Gaertner Status assigned => feedback
2010-07-16 09:21 Alexander S. Klenin File Added: packageeditor_context_menu.png
2010-07-16 09:26 Alexander S. Klenin Note Added: 0039378
2010-07-16 09:36 Mattias Gaertner LazTarget - => 0.9.30
2010-07-16 09:36 Mattias Gaertner Widgetset => Win32/Win64
2010-07-16 09:36 Mattias Gaertner Assigned To Mattias Gaertner =>
2010-07-16 09:45 Mattias Gaertner Note Added: 0039379
2010-07-16 15:37 Alexander S. Klenin Relationship added related to 0016950
2010-07-16 21:29 Mattias Gaertner Relationship deleted related to 0016950
2010-07-16 21:45 Alexander S. Klenin Note Added: 0039399
2010-07-16 22:00 Mattias Gaertner Note Added: 0039401
2010-07-16 22:09 Alexander S. Klenin Note Added: 0039402
2010-07-16 22:19 Mattias Gaertner Relationship added related to 0016950
2010-07-18 11:33 samuel herzog Note Added: 0039426
2010-07-18 11:33 samuel herzog Status feedback => confirmed
2010-07-18 11:33 samuel herzog Target Version => 0.9.30
2010-07-19 08:08 Paul Ishenin Note Added: 0039443
2010-07-19 08:08 Paul Ishenin Status confirmed => assigned
2010-07-19 08:08 Paul Ishenin Assigned To => Mattias Gaertner
2010-07-19 12:46 Mattias Gaertner Fixed in Revision => 26734
2010-07-19 12:46 Mattias Gaertner Note Added: 0039449
2010-07-19 12:46 Mattias Gaertner Status assigned => resolved
2010-07-19 12:46 Mattias Gaertner Resolution open => fixed
2010-07-19 14:33 Alexander S. Klenin Status resolved => closed
2010-07-19 14:33 Alexander S. Klenin Note Added: 0039458