View Issue Details

IDProjectCategoryView StatusLast Update
0017077LazarusIDEpublic2010-10-08 13:24
ReporterAlexander S. KleninAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0017077: Component editor is hidden after double-click
DescriptionIf component's default editor is a dialog, like e.g. SQLQuery,
that dialog should be displayed on double-clicking the component.
Instead, it is displayed very briefly and is immediately
hidden by the main window.
Steps To Reproduce1) Put SQLQuery component on the form
2) Double-click on it
=>
Fields editor flashes briefly and disappears.
Additional InformationI have anchordocking installed -- maybe this is related.
TagsNo tags attached.
Fixed in Revision27610
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Alexander S. Klenin

2010-08-07 15:23

developer   ~0040049

This is probably a regression introduced by r25457
(IDE: removed TComponentInterface), since the code in
TDesigner.InvokeComponentEditor is very strange -- a can not understand
how it is supposed to work.
I guess this revision has also caused AVs in TAChart's subcomponent
editor, but I am not 100% sure, will continue to investigate
after this issue is fixed.

Jesus Reyes

2010-10-07 22:49

developer   ~0041596

Fields Editor showing logic was redesigned, please test again.

Jesus Reyes

2010-10-08 02:40

developer   ~0041604

@Alexander, tried to fix TAChart problem in r27612, please test.

Alexander S. Klenin

2010-10-08 13:24

developer   ~0041609

Yes, your changes do indeed fix both fields editor and tachart series editor.
Thanks.

Issue History

Date Modified Username Field Change
2010-08-01 11:52 Alexander S. Klenin New Issue
2010-08-01 11:52 Alexander S. Klenin LazTarget => -
2010-08-01 11:52 Alexander S. Klenin Widgetset => Win32/Win64
2010-08-07 15:23 Alexander S. Klenin Note Added: 0040049
2010-08-11 23:39 Mattias Gaertner Status new => assigned
2010-08-11 23:39 Mattias Gaertner Assigned To => Mattias Gaertner
2010-10-07 22:49 Jesus Reyes Fixed in Revision => 27610
2010-10-07 22:49 Jesus Reyes Status assigned => resolved
2010-10-07 22:49 Jesus Reyes Fixed in Version => 0.9.29 (SVN)
2010-10-07 22:49 Jesus Reyes Resolution open => fixed
2010-10-07 22:49 Jesus Reyes Note Added: 0041596
2010-10-08 02:40 Jesus Reyes Note Added: 0041604
2010-10-08 13:24 Alexander S. Klenin Status resolved => closed
2010-10-08 13:24 Alexander S. Klenin Note Added: 0041609