View Issue Details

IDProjectCategoryView StatusLast Update
0017080LazarusIDEpublic2011-12-01 11:24
ReporterAlejandro LavarelloAssigned ToMattias Gaertner 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.28.3 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0017080: Lazarus IDE form editor do not show form at design time
DescriptionI use Lazarus 0.9.29 2010-07-07 SVN revision 26494 FPC 2.4.3 in Windows XP Service Pack 2 Spanish (32 bits). The problem is the same in various PCs.

I was triying to make a simple image viewer and wallpaper changer for WineXO running in XO-1, and this works.

I did something and Lazarus IDE do not show more the main form in the form editor.

But, when I open this project in Puppy Linux using Lazarus 0.9.29 , the form
is showed.

In Windows XP the project compiles OK, the application shows OK at run time,
but the form is invisible in the Lazarus IDE. I have tried the obvious menu
View / Forms / View Project Form but nothing happens.

If I open another project or if I create a new project, the forms are
shown correctly. I have tried to delete the lib and backup folders; when
I rebuild the project, all is re-generated, but the form still invisible.

What happens?

-- alejandro.lavarello (at) gmail (dot) com

TagsNo tags attached.
Fixed in Revision26975
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

2010-08-01 16:26

 

IDENotShowForm.rar (37,942 bytes)

Maxim Ganetsky

2010-08-01 17:49

developer   ~0039867

Last edited: 2010-08-01 17:51

The form will be shown at designtime if you will change your form's AlphaBlend property value to 'false' and then restart IDE.

Reproducable in Lazarus 0.9.29 r26942 FPC 2.4.1 i386-win32-win32/win64, Windows XP SP2 32 bit, FPC 2.4.1.

Paul Ishenin

2010-08-02 11:03

manager   ~0039880

Alphablend should not be applied in the design-time. Thanks Maxim for research.

Please test and close if ok.

Alejandro Lavarello

2010-08-04 23:21

reporter   ~0039993

Thanks Maxim, thanks Paul!
Yes, the solution is to set the form's property AlphaBlend= FALSE , then
saving all files, then restoring the IDE.
This problem occurs in Windows, not in Linux.
Thanks again!

Issue History

Date Modified Username Field Change
2010-08-01 16:26 Alejandro Lavarello New Issue
2010-08-01 16:26 Alejandro Lavarello File Added: IDENotShowForm.rar
2010-08-01 16:26 Alejandro Lavarello Widgetset => Win32/Win64
2010-08-01 17:49 Maxim Ganetsky LazTarget => -
2010-08-01 17:49 Maxim Ganetsky Note Added: 0039867
2010-08-01 17:49 Maxim Ganetsky Status new => confirmed
2010-08-01 17:51 Maxim Ganetsky Note Edited: 0039867
2010-08-02 00:16 Mattias Gaertner Status confirmed => assigned
2010-08-02 00:16 Mattias Gaertner Assigned To => Mattias Gaertner
2010-08-02 11:03 Paul Ishenin Fixed in Revision => 26975
2010-08-02 11:03 Paul Ishenin Status assigned => resolved
2010-08-02 11:03 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-08-02 11:03 Paul Ishenin Resolution open => fixed
2010-08-02 11:03 Paul Ishenin Note Added: 0039880
2010-08-04 23:21 Alejandro Lavarello Note Added: 0039993
2011-12-01 11:24 Marc Weustink Status resolved => closed