View Issue Details

IDProjectCategoryView StatusLast Update
0017135LazarusWidgetsetpublic2010-08-28 02:05
ReporterMartin FriebeAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0017135: QT: Stack window jumps to wrong source line (deferred itemindex?)
DescriptionIf I double click an item in the debug/stack view, it should take me to the position in the Source.

instead of taking me to the source of the item I double click, it takes me to the source of the item, that was selected before the doubleclick.
(changing the selection before the double click to theitem, that is about to be double clicked, does not help either.
TagsNo tags attached.
Fixed in Revision27213
LazTarget-
WidgetsetQT
Attached Files

Relationships

child of 0016712 closedZeljan Rikalo In QT version of TListView OnClick event returns the previously selected item 

Activities

Juha Manninen

2010-08-08 18:55

developer   ~0040074

It is caused by a TListView bug in QT bindings, 0016712.

Zeljan Rikalo

2010-08-27 12:39

developer   ~0040522

Can you retest with r27213 ?

Martin Friebe

2010-08-27 13:20

manager   ~0040525

works, thanks

Issue History

Date Modified Username Field Change
2010-08-08 18:28 Martin Friebe New Issue
2010-08-08 18:28 Martin Friebe LazTarget => -
2010-08-08 18:28 Martin Friebe Widgetset => QT
2010-08-08 18:53 Juha Manninen Relationship added child of 0016712
2010-08-08 18:55 Juha Manninen Note Added: 0040074
2010-08-10 17:03 Zeljan Rikalo Status new => assigned
2010-08-10 17:03 Zeljan Rikalo Assigned To => Zeljan Rikalo
2010-08-27 12:39 Zeljan Rikalo Note Added: 0040522
2010-08-27 12:39 Zeljan Rikalo Status assigned => feedback
2010-08-27 13:20 Martin Friebe Fixed in Revision => 27213
2010-08-27 13:20 Martin Friebe Status feedback => resolved
2010-08-27 13:20 Martin Friebe Fixed in Version => 0.9.29 (SVN)
2010-08-27 13:20 Martin Friebe Resolution open => fixed
2010-08-27 13:20 Martin Friebe Note Added: 0040525
2010-08-28 02:05 Martin Friebe Status resolved => closed