View Issue Details

IDProjectCategoryView StatusLast Update
0017142LazarusIDEpublic2011-12-01 11:24
ReporterPhillAssigned ToJuha Manninen 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionno change required 
Product Version0.9.28Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0017142: Access Violation when
DescriptionAny compiled program (including start new project) issues a fatal error:
project1.lpr(8,7) Fatal: Can't find unit Interfaces used by Project1

When I attempt to Tool/Configure "Build Lazarus" ...
a popup dialog appears stating that there has been an access violation.

The install is Fedora 13 KDE via yum.
Linux localhost.localdomain 2.6.33.6-147.fc13.i686 0000001 SMP Tue Jul 6 22:30:55 UTC 2010 i686 i686 i386 GNU/Linux

I ran Lazarus from the command line which produced some debug output (see Additional Information)

From the help/about Lazarus dialog
Version #: 0.9.28 beta
Date: 2009-10-17
FPC: Version 2.2.4
SVN Revision: 21928
i386-linux-gtk 2

Any help most welcome.
Thanks in advance.
Phill.
Additional Information[root@localhost Downloads]# /usr/lib/lazarus/lazarus
[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of unassigned VK codes, assigning $FF
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/root/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
NOTE: miscellaneous options file not found - using defaults
NOTE: codetools config file not found - using defaults
NOTE: help options config file not found - using defaults
TMainIDE.DoNewProject A
TheFontStock.CalcFontAdvance: Font=Courier New Size=10 Width(9) > tmMaxWidth+Over(8)
TheFontStock.CalcFontAdvance: Font=Courier New Size=10 Width(9) > tmMaxWidth+Over(8)
TCustomFormEditor.CreateComponent Form1:TForm1 True
TMainIDE.DoNewEditorFile END unit1.pas
ETCHED IN
TApplication.HandleException Access violation
  Stack trace:
  $007770CE
  $082BB40D
  $081EA2AB
  $081E94FA
  $081A84C8
  $081A80B5
  $081A90AA
  $081A85A5
  $081A80B5
  $081A90AA
  $081A85A5
  $0824E5B1
  $081A80B5
  $081A90AA
  $081A85A5
  $08078A31
  $0807DD1C
WARNING: TLCLComponent.Destroy with LCLRefCount>0. Hint: Maybe the component is processing an event?
[TMainIDE.Destroy] A
[TMainIDE.Destroy] B -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END
[root@localhost Downloads]#
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0016955 closedMattias Gaertner Packages Several Menu Options causing Access Violations 
related to 0015114 closedJuha Manninen Lazarus IDE dies when trying to select FPC source directory 

Activities

Phill

2010-08-10 12:14

reporter   ~0040102

Just installed from updates-testing. Same results. Version from Help/About Lazarus:
Version #: 0.9.28.2 beta
Date: 2010-5-27
FPC Version: 2.4.0
SVN Revision: 22279
i386-linux-gtk 2 (beta)

Phill

2010-08-10 12:17

reporter   ~0040103

Console output for Version #: 0.9.28.2 beta

[root@localhost yum.repos.d]# /usr/lib/lazarus/lazarus
[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of unassigned VK codes, assigning $FF
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/root/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
NOTE: miscellaneous options file not found - using defaults
NOTE: codetools config file not found - using defaults
NOTE: help options config file not found - using defaults
TMainIDE.DoNewProject A
TheFontStock.CalcFontAdvance: Font=Courier New Size=10 Width(9) > tmMaxWidth+Over(8)
TheFontStock.CalcFontAdvance: Font=Courier New Size=10 Width(9) > tmMaxWidth+Over(8)
TCustomFormEditor.CreateComponent Form1:TForm1 True
TMainIDE.DoNewEditorFile END unit1.pas
ETCHED IN
TApplication.HandleException Access violation
  Stack trace:
  $0075A0CE
  $082B9CCC
  $081EA62B
  $081E989A
  $081A8D6C
  $081A8965
  $081A993A
  $081A8E35
  $081A8965
  $081A993A
  $081A8E35
  $0824D101
  $081A8965
  $081A993A
  $081A8E35
  $0807B571
  $080807F2
WARNING: TLCLComponent.Destroy with LCLRefCount>0. Hint: Maybe the component is processing an event?
[TMainIDE.Destroy] A
[TMainIDE.Destroy] B -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END

Juha Manninen

2010-08-11 13:48

developer   ~0040140

Last edited: 2010-08-11 14:07

I have a Fedora now, too, although it is 64-bit.
I don't know the exact reason for your problem but I recommend you install the trunk version of Lazarus, using the FPC 2.4.0 which you already have installed. That's what I have done myself. First make sure you have also "fpc-src" and "subversion" installed. If not, do:
 $ yum install fpc-src
 $ yum install subversion
Then get rid of Lazarus 0.9.28:
 $ yum erase lazarus
Then at ~:
 $ svn co http://svn.freepascal.org/svn/lazarus/trunk lazarus
 $ cd lazarus
 $ make all
 $ ./lazarus &

Works for me.

Juha Manninen

2010-08-11 13:51

developer   ~0040141

Lazarus setting "FPC source directory" should be then:
  /usr/share/fpcsrc/

Vincent Snijders

2010-08-11 13:55

manager   ~0040142

Or you can try a different gtk2 theme. See related issues.

Phill

2010-08-12 08:28

reporter   ~0040158

The gtk2 theme settings did not work for me. I changed the widget and gtk+ settings as described but it still crashed.

The svn download and compile has worked for me. I'm back on air again!

Thanks for you help Juha, much appreciated. My project fully compiles and works again.

Please close.

Phill.

Juha Manninen

2010-08-12 11:02

developer   ~0040161

Resolved. Phill, you can close it yourself now.

Issue History

Date Modified Username Field Change
2010-08-10 11:07 Phill New Issue
2010-08-10 12:14 Phill Note Added: 0040102
2010-08-10 12:17 Phill Note Added: 0040103
2010-08-11 13:28 Juha Manninen Status new => assigned
2010-08-11 13:28 Juha Manninen Assigned To => Juha Manninen
2010-08-11 13:48 Juha Manninen LazTarget => -
2010-08-11 13:48 Juha Manninen Note Added: 0040140
2010-08-11 13:48 Juha Manninen Status assigned => feedback
2010-08-11 13:51 Juha Manninen Note Added: 0040141
2010-08-11 13:55 Vincent Snijders Note Added: 0040142
2010-08-11 13:57 Vincent Snijders Relationship added related to 0016995
2010-08-11 13:59 Vincent Snijders Relationship added related to 0016955
2010-08-11 13:59 Vincent Snijders Relationship deleted related to 0016995
2010-08-11 14:00 Vincent Snijders Relationship added related to 0015114
2010-08-11 14:07 Juha Manninen Note Edited: 0040140
2010-08-12 08:28 Phill Note Added: 0040158
2010-08-12 11:02 Juha Manninen Status feedback => resolved
2010-08-12 11:02 Juha Manninen Fixed in Version => 0.9.29 (SVN)
2010-08-12 11:02 Juha Manninen Resolution open => no change required
2010-08-12 11:02 Juha Manninen Note Added: 0040161
2011-12-01 11:24 Marc Weustink Status resolved => closed