View Issue Details

IDProjectCategoryView StatusLast Update
0017166Packages-public2011-12-01 11:25
ReporterJason P Sage Assigned ToMartin Friebe  
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.28 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0017166: SynEdit - Unable to Select ALL on LONG lines. Same issue with mouse Select.. seems to max out.
DescriptionI opened a html file that was without CRLF - so it was one very long line.

Now SynEdit took it all like a champ - but:
--- CNTL + A (Select All) didn't work properly
--- Mousing (attempting to select all with a long sweeping mouse drag) seems to act oddly as well..
Additional InformationGot the feeling there may be a limit to how far apart the SelStart and SelEnd (length of selection) could be on a single line.

TagsNo tags attached.
Fixed in Revision27100
LazTarget0.9.30
Widgetset
Attached Files

Relationships

related to 0017174 closedVincent Snijders Lazarus Horizontal scrollbar limited to 32768, while vertical scrollbar supports bigger values 

Activities

Martin Friebe

2010-08-14 19:29

manager   ~0040209

In 0.9.29 select-all, and using the mouse seems to work.

But using cursor left/right keys only goes to column 1024

Martin Friebe

2010-08-14 23:52

manager   ~0040216

Partly fixed in 27100.

There are/were several issues:

- Moving the caret with the cursor keys would stop at 1024 (or jump back to 1024, if the caret was further right)
- editing text would limit the caret to x<=1024

This has been fixed. The caret can now freely move to the end of the Line.

There is another issue (at least on Win32, but maybe others) or maybe in the LCL:
vertical scrollbars only support a range of 32767 as maximum. As a consequence SynEdit can not scroll any further.
- Selecting by mouse will therefore stop, since it is restraint to visible text.
- Selecting by keyboard (shift cursor-keys or ctrl-a) will work, but the result will not be visible.

I believe (I do not know for sure) this is a limitation by the Windows OS, which originally only supports 32bits for any scrollbar. Bigger values need certain extra computation. I do not know why they are only available in vertical scrollbars.

The scrolling issue, is not limited to SynEdit, and needs to be a separate report.

Martin Friebe

2010-08-14 23:59

manager   ~0040217

Created new issue for scrollbar limit 0017174

Martin Friebe

2010-08-15 00:00

manager   ~0040218

SynEdit related parts are fixed

Vincent Snijders

2010-12-28 16:55

manager   ~0044656

Scrollbar issue was synedit related too.

Issue History

Date Modified Username Field Change
2010-08-14 07:06 Jason P Sage New Issue
2010-08-14 07:06 Jason P Sage Widgetset => Win32/Win64
2010-08-14 19:28 Martin Friebe Status new => assigned
2010-08-14 19:28 Martin Friebe Assigned To => Martin Friebe
2010-08-14 19:29 Martin Friebe Note Added: 0040209
2010-08-14 23:52 Martin Friebe Note Added: 0040216
2010-08-14 23:58 Martin Friebe Relationship added related to 0017174
2010-08-14 23:59 Martin Friebe Note Added: 0040217
2010-08-15 00:00 Martin Friebe Fixed in Revision => 27100
2010-08-15 00:00 Martin Friebe LazTarget => 0.9.30
2010-08-15 00:00 Martin Friebe Widgetset Win32/Win64 =>
2010-08-15 00:00 Martin Friebe Status assigned => resolved
2010-08-15 00:00 Martin Friebe Fixed in Version => 0.9.29 (SVN)
2010-08-15 00:00 Martin Friebe Resolution open => fixed
2010-08-15 00:00 Martin Friebe Note Added: 0040218
2010-08-15 00:00 Martin Friebe Target Version => 0.9.30
2010-12-28 16:55 Vincent Snijders Note Added: 0044656
2011-12-01 11:25 Marc Weustink Status resolved => closed