View Issue Details

IDProjectCategoryView StatusLast Update
0017241LazarusWidgetsetpublic2010-08-25 10:37
ReporterBernd KreussAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0017241: win32: TDBGrid with dgAlwaysShowEditor: in-place editor opens in wrong row when appending a new row
DescriptionWhen dgAlwaysShowEditor is in the options and a new row is appended (press <down> until the new row opens and then start typing to to edit the cell) the in-place editor will be one row above the new row. It will edit the correct row but the visual feedback will look like the user is editing a different row.

The attached demo program demonstrates this (it also demonstrates a GTK2 problem but this is another bug). Compile and run it on win32, check the checkbox dbAlwaysShowEditor and try to append and edit new rows.
TagsNo tags attached.
Fixed in Revision27172
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Activities

2010-08-22 14:06

 

TDBGrid_not_working.tar.bz2 (2,323 bytes)

Jesus Reyes

2010-08-23 19:34

developer   ~0040421

the problem was the same under GTK2 so I tested there, please test on Windows and close this report if it's ok.

Bernd Kreuss

2010-08-25 10:37

reporter   ~0040439

yes, it works now.

Issue History

Date Modified Username Field Change
2010-08-22 14:06 Bernd Kreuss New Issue
2010-08-22 14:06 Bernd Kreuss File Added: TDBGrid_not_working.tar.bz2
2010-08-22 14:06 Bernd Kreuss Widgetset => Win32/Win64
2010-08-22 19:08 Jesus Reyes Status new => assigned
2010-08-22 19:08 Jesus Reyes Assigned To => Jesus Reyes
2010-08-23 19:34 Jesus Reyes Fixed in Revision => 27172
2010-08-23 19:34 Jesus Reyes LazTarget => 0.9.30
2010-08-23 19:34 Jesus Reyes Status assigned => resolved
2010-08-23 19:34 Jesus Reyes Fixed in Version => 0.9.29 (SVN)
2010-08-23 19:34 Jesus Reyes Resolution open => fixed
2010-08-23 19:34 Jesus Reyes Note Added: 0040421
2010-08-23 19:34 Jesus Reyes Target Version => 0.9.30
2010-08-25 10:37 Bernd Kreuss Status resolved => closed
2010-08-25 10:37 Bernd Kreuss Note Added: 0040439