View Issue Details

IDProjectCategoryView StatusLast Update
0017349LazarusLCLpublic2014-08-21 05:35
ReporterVitaly Yakunin Assigned ToBart Broersma  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.9.29 (SVN) 
Summary0017349: TCustomEditButon SetAlign hide Button
DescriptionAny component, based on TCustomEditButton, loses Button after installation properties Align in alTop or alBottom.
TagsTEditButton
Fixed in Revision
LazTarget-
WidgetsetGTK 2, Win32/Win64, WinCE, Carbon, QT, fpGUI
Attached Files

Relationships

duplicate of 0012155 closedBart Broersma TEditButton aligns incorrect (glyph is not taken into account) 

Activities

Zeljan Rikalo

2010-09-05 08:43

developer   ~0040826

Would be nice if you provide an example, I cannot reproduce it.

Zeljan Rikalo

2010-09-05 09:17

developer   ~0040829

ah TCustomEditButton :) thought about TCustomButton.Yes, it's bug , but in LCL since all WS shows same problem (tested on linux qt,gtk2 and win32 on Win7).

Vitaly Yakunin

2010-09-05 10:24

reporter   ~0040830

Will-Does it ever fixed? I will now make a platform for this component (TPanel), so you can adjust the button on the edge. And what will happen in the future?

Vitaly Yakunin

2011-07-23 17:29

reporter   ~0050106

What changes are on the subject?

Vitaly Yakunin

2011-09-05 17:27

reporter   ~0051473

And now?

Juha Manninen

2014-04-07 11:55

developer   ~0074183

Vitaly, now there is a change. :)

Vitaly Yakunin

2014-08-21 05:35

reporter   ~0076662

Thank you! It's perfect! :)

Issue History

Date Modified Username Field Change
2010-09-04 22:32 Vitaly Yakunin New Issue
2010-09-04 22:32 Vitaly Yakunin Widgetset => QT
2010-09-05 08:43 Zeljan Rikalo Status new => assigned
2010-09-05 08:43 Zeljan Rikalo Assigned To => Zeljan Rikalo
2010-09-05 08:43 Zeljan Rikalo LazTarget => -
2010-09-05 08:43 Zeljan Rikalo Note Added: 0040826
2010-09-05 08:43 Zeljan Rikalo Status assigned => feedback
2010-09-05 09:17 Zeljan Rikalo Note Added: 0040829
2010-09-05 09:17 Zeljan Rikalo Status feedback => confirmed
2010-09-05 09:17 Zeljan Rikalo Widgetset QT => GTK 2, Win32/Win64, WinCE, Carbon, QT, fpGUI
2010-09-05 09:57 Zeljan Rikalo Assigned To Zeljan Rikalo =>
2010-09-05 10:24 Vitaly Yakunin Note Added: 0040830
2011-07-23 17:29 Vitaly Yakunin Note Added: 0050106
2011-07-23 21:53 Maxim Ganetsky Description Updated
2011-09-05 17:27 Vitaly Yakunin Note Added: 0051473
2011-10-28 09:25 Juha Manninen Relationship added related to 0012155
2012-02-10 09:21 Zeljan Rikalo Tag Attached: TEditButton
2014-04-07 11:54 Juha Manninen Assigned To => Bart Broersma
2014-04-07 11:54 Juha Manninen Status confirmed => assigned
2014-04-07 11:55 Juha Manninen Note Added: 0074183
2014-04-07 15:57 Bart Broersma Relationship replaced duplicate of 0012155
2014-04-07 15:57 Bart Broersma Status assigned => resolved
2014-04-07 15:57 Bart Broersma Resolution open => duplicate
2014-08-21 05:35 Vitaly Yakunin Note Added: 0076662
2014-08-21 05:35 Vitaly Yakunin Status resolved => closed