View Issue Details

IDProjectCategoryView StatusLast Update
0000174Lazaruspublic2004-03-18 17:37
ReporterBug Import Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Summary0000174: xpm loading works but doesn´t appear on tform
Descriptionloading an xpm only works if it is generated by gimp (any other tool didn´t create a compatible file ?)
the image doesn´t appear on the tform,

missing "luxus" feature:
changing with and height attributes don´t affect the canvas instantly
Additional InformationImported information
--------------------
Name: anarco
Mail: anarco (at) thepixel.net
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2004-03-18 17:37

reporter   ~0000153

I didn't received any unloadable xpm, so this part is unreproducable.
The canvas of a TImage is the bitmap, which is not resized, when the TImage is resized, for speed reasons and because resizing would destroy the old TBitmap for Delphi compatibility.

MG

Issue History

Date Modified Username Field Change
2004-01-30 00:00 Bug Import New Issue
2004-01-30 00:00 Bug Import Widgetset => GTK, Win32
2004-03-18 17:37 Bug Import Note Added: 0000153
2004-03-18 17:37 Bug Import Status new => closed
2004-03-18 17:37 Bug Import Resolution open => no change required